Search found 84 matches

Search found 84 matches

Re: Is it possible to extend the timeout period of outgoing emails from OpenCart?

Mail protocol is not safe. SMTP with TLS / SSL is rather recommended. When you say Mail protocol is not safe, what are some examples of harmful things that could happen? Does it make the site more prone to being hacked or is it a matter of the actual emails getting hacked? So do I have to put my em...

Jump to post
  • Wed Dec 30, 2020 10:25 am
  • Replies 19
  • Views 791
Re: Is it possible to extend the timeout period of outgoing emails from OpenCart?

By the way, what's the difference between using Mail and SMTP in the mail protocol setting? Mail will use the PHP mail function. This will likely be configured to send to the servers MTA (mail transfer agent). Mail is likely to be quicker as it's not likely to have to wait. The MTA will do that par...

Jump to post
  • Tue Dec 29, 2020 9:59 am
  • Replies 19
  • Views 791
How do I add a message telling customers not to click the "Confirm Order" button twice?

Sometimes customers are pressing the "Confirm Order" button twice which causes a duplicate payment. I wanted to add a message telling them not to click the button again while waiting for the payment to process. I was thinking of adding the message just below the "Confirm Order" button on the checkou...

Jump to post
  • Tue Dec 29, 2020 7:42 am
  • Replies 2
  • Views 217
Re: Is it possible to extend the timeout period of outgoing emails from OpenCart?

In my php.ini file, the max_execution_time is set to 36000. Is that also in seconds, and if so isn't that a pretty high value? I don't remember changing this, is that the default value?

Jump to post
  • Thu Dec 03, 2020 8:38 am
  • Replies 19
  • Views 791
Re: Is it possible to extend the timeout period of outgoing emails from OpenCart?

Assuming you are using SMTP as the Mail Protocol in the OpenCart Mail settings. Have you tried increasing the SMTP Timeout value in the OpenCart Mail?settings? Have you tried using Mail as the Mail Protocol in the OpenCart Mail settings? By the way, what's the difference between using Mail and SMTP...

Jump to post
  • Thu Dec 03, 2020 6:56 am
  • Replies 19
  • Views 791
Re: Is it possible to extend the timeout period of outgoing emails from OpenCart?

I'm using SMTP in the mail protocol setting. I see the SMTP Timeout, it's currently set to 7. Is that in seconds? What is the recommend value this should be and what value should it be if I have a slow sending email?

Jump to post
  • Thu Dec 03, 2020 6:22 am
  • Replies 19
  • Views 791
Is it possible to extend the timeout period of outgoing emails from OpenCart?

Sometimes my outgoing mail is very slow to send. Sometimes it could take a few minutes before the email sends. This is likely an issue with the host. Whenever this happens, automated order confirmation emails sent to a customer after a purchase don't get sent. The emails sent to a customer after an ...

Jump to post
  • Thu Dec 03, 2020 6:01 am
  • Replies 19
  • Views 791
Re: PHP Warning in error log: A non-numeric value encountered in /vq2-catalog_controller_product_category.php on line 3

That line 378 reads: $data['results'] = sprintf($this->language->get('text_pagination'), ($product_total) ? (($page - 1) * $limit) + 1 : 0, ((($page - 1) * $limit) > ($product_total - $limit)) ? $product_total : ((($page - 1) * $limit) + $limit), $product_total, ceil($product_total / $limit)); Line ...

Jump to post
  • Fri Jul 03, 2020 2:48 am
  • Replies 3
  • Views 248
PHP Warning in error log: A non-numeric value encountered in /vq2-catalog_controller_product_category.php on line 378

I'm on OC 2.3.0.2. In my error log, I see the following error: PHP Warning: A non-numeric value encountered in /home/xxx/public_html/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 378 There are a few of these lines and the line number might change (like instead of line 378 there a...

Jump to post
  • Thu Jul 02, 2020 7:30 am
  • Replies 3
  • Views 248
Re: Internal Server Error When updating orders

I'm looking in the metrics section of cPanel and under Errors it says: "Last 300 Error Log messages in reverse order" but the screen is blank so I'm assuming there are no errors?

Jump to post
  • Wed Jul 01, 2020 1:42 am
  • Replies 12
  • Views 1362
Re: Internal Server Error When updating orders

I disabled fraud labs pro, The line of code creating the issue was 267 of catalog/model/checkout/order.php $fraud_status_id = $this->{'model_fraud_' . $extension['code']}->check($order_info); I fixed the issue by disabling fraud labs pro. I would like to keep the fraud labs pro extension. Any sugge...

Jump to post
  • Tue Jun 30, 2020 2:26 pm
  • Replies 12
  • Views 1362
Re: After upgrading PHP 5.6 to 7.2, Warning: count(): Parameter must be an array or an object that implements Countable

Thanks alot. I found out the error also disappears if line 11 is changed to: if( count((array)$query) ) {
Anything wrong with that line as well? Do you have a preference over which to use?

Jump to post
  • Sat Mar 21, 2020 12:19 pm
  • Replies 3
  • Views 510
Re: Update server PHP gives error on 2.3 version

Sanshay, can you tell us what exactly did you change in your code to make it work?

Jump to post
  • Sat Mar 21, 2020 12:00 pm
  • Replies 10
  • Views 4377
[SOLVED] - Warning: count(): Parameter must be an array or an object that implements Countable in

I have an OpenCart 2.3.0.2 site. After upgrading PHP from version 5.6 to 7.2, I get an error in a theme page that has a slideshow. That error is: Warning: count(): Parameter must be an array or an object that implements Countable in /xxxx/xxxxxxx/public_html/catalog/model/slider/camera_slider.php on...

Jump to post
  • Sat Mar 21, 2020 11:58 am
  • Replies 3
  • Views 510
Transferring website files & database to a new server & testing using a test domain name – what needs to be done?

I’m planning to move my website to another server which has a higher PHP version, higher MySQL version, higher cPanel/WHM version, etc. Before doing this, I want to make sure everything works first. So I plan to download all my site files and database, then re-upload them to the new server. I obviou...

Jump to post
  • Sat Mar 14, 2020 12:40 am
  • Replies 1
  • Views 203
Re: Will updating from EasyApache3 to EasyApache4 affect or break anything in an OpenCart site?

Yeah, I figure as long as the PHP and MySQL are not changed, then everything should be all right. I'm just concerned that if I update EA3 to EA4, will that somehow also update the PHP version because I know the PHP version I'm using, 5.6, is old (but it's still supported by EA4). So does anyone know...

Jump to post
  • Fri Mar 13, 2020 5:27 am
  • Replies 7
  • Views 417
Re: Will updating from EasyApache3 to EasyApache4 affect or break anything in an OpenCart site?

I'm about to go through with the update via WHM and these are the pre-flight check warnings that I'm getting: Warning: “Cpanel::Easy::PHP5::MailHeaders” ignored since it does not have an RPM. Warning: “Cpanel::Easy::Apache::Fileprotect” ignored since it does not have an RPM. Warning: “Cpanel::Easy::...

Jump to post
  • Fri Mar 13, 2020 4:25 am
  • Replies 7
  • Views 417
Re: Will updating from EasyApache3 to EasyApache4 affect or break anything in an OpenCart site?

That post was talking about upgrading cPanel/WHM and that is optional. For this post I'm specifically talking about updating EasyApache3 to EasyApache4 which is not optional - my host said that cPanel will be forcing this update to everyone after March 18, 2020.

Jump to post
  • Fri Mar 13, 2020 4:20 am
  • Replies 7
  • Views 417
Will updating from EasyApache3 to EasyApache4 affect or break anything in an OpenCart site?

I got an email from my host saying that cPanel will be forcing all servers to update from EA3 to EA4 which could break the site. I have PHP 5.6 and MySQL 5.5. Does anyone know if this update will affect the PHP or MySQL or anything related to an OpenCart site? I'm using OpenCart 2.3.0.2. Will this u...

Jump to post
  • Fri Mar 13, 2020 3:36 am
  • Replies 7
  • Views 417
Re: Will upgrading cPanel/WHM from version 64.0 to 84.0 affect any functionality in OpenCart 2.3.0.2?

If upgrading cPanel/WHM from version 64.0 to 84.0 changes anything with PHP or my SQL, then most likely it would affect the functionality of an OpenCart store. I'm currently using MySQL 5.5 and it appears that cPanel/WHM version 84.0 has removed MySQL 5.5 and replaced it with MySQL 5.6. So if I go a...

Jump to post
  • Fri Dec 06, 2019 8:33 am
  • Replies 6
  • Views 376

Search found 84 matches