Search found 28 matches

Search found 28 matches

CJC

Re: How to configure OC for a single country?

Ah, ok. I'll give that a try.

Thank You.

by mona wrote:
Thu Oct 22, 2020 1:00 am
You can set shipping to a single country and only have one currency.

This might help
viewtopic.php?f=186&t=206217

Jump to post
  • Thu Oct 22, 2020 1:18 am
  • Replies 2
  • Views 162

CJC

How to configure OC for a single country?

What's the preferred way to set up an OC shop to be for only one country? Do I really have to disable 230+ countries in the backend? And what about getting rid of the currency selector as well?

Thanks.

Jump to post
  • Wed Oct 21, 2020 11:49 pm
  • Replies 2
  • Views 162

CJC

Re: Language Editor html problem

Thank you! I think I understand how this works. Seems like an easy enough way to handle mods to core files. Yes there is that possibility. There is also the possibility that should this happen VQMOD will return. Anyway, we are mere mortals .. This example would be this. Then you just add to this sin...

Jump to post
  • Fri Oct 16, 2020 7:49 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

I'm new to OC, but I thought I understood that OCMOD was going away in 3.1. If that's not true are you aware of any guides for using it? I'm willing to learn. But then that gets lost during an update... YES EXACTLY .. that is why OCMOD and VQMOD are the only protective / logical / sensible / safest ...

Jump to post
  • Fri Oct 16, 2020 4:32 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

But then that gets lost during an update...

sw!tch wrote:
Fri Oct 16, 2020 3:07 am
All this for the {{ powered }} text? A lot less work to just edit your twig template literally one line of code.

Jump to post
  • Fri Oct 16, 2020 3:38 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

If anyone is following along, it's: admin/view/template/design/translation_form.twig ;)

by mona wrote:
Thu Oct 15, 2020 10:29 pm
For completeness to fix the edit

admin/view/design/translation_form.twig
remove from line 98 - 149

snip....

Jump to post
  • Fri Oct 16, 2020 2:31 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

This worked. But I had to delete the original entry and re-create it. Thank You! You can try this admin/model/design/translation.php line 4 change $this->db->query("INSERT INTO `" . DB_PREFIX . "translation` SET `store_id` = '" . (int)$data['store_id'] . "', `language_id` = '" . (int)$data['language...

Jump to post
  • Fri Oct 16, 2020 2:28 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

So I'm assuming based on the need to edit core files to make this work that this should be reported as a bug. Also, another issue is that once you have an edit created, you can never modify it. If you try to open it and make a change when you click the Save button you'll get an error and the screen ...

Jump to post
  • Thu Oct 15, 2020 8:45 pm
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

Here's a screenshot of the front end: http://c2-it.com/pics/footer.png And a screenshot of the language editor screen: http://c2-it.com/pics/editor.png And this is the code for the value field: Website Design: <a href="http://www.c2-it.com">C2 It Multimedia</a><br /> %s © %s Can you do a pasteb...

Jump to post
  • Thu Oct 15, 2020 7:31 am
  • Replies 20
  • Views 914

CJC

Re: Language Editor html problem

The new text shows up, but the html code is displayed instead of being interpreted.

rjcalifornia wrote:
Thu Oct 15, 2020 12:16 am

Is the new text not showing up in the footer? Did you disable OpenCart's cache?

Jump to post
  • Thu Oct 15, 2020 12:58 am
  • Replies 20
  • Views 914

CJC

Language Editor html problem

Hi All, On a basic OC 3.0.3.6 installation I'm trying to use the language editor to modify the "Powered By" text in the footer. I have the correct route and key, but any html I put in the Value gets displayed in the front end. This happens even if I just copy/paste the existing string that's in the ...

Jump to post
  • Thu Oct 15, 2020 12:04 am
  • Replies 20
  • Views 914

CJC

Re: Question about .idea directory

Ok, thank you.

sw!tch wrote:
Wed Oct 14, 2020 5:48 am
No. I guess they didn't put a .gitignore and uploaded their PHPStorm directory. You can remove it.

Jump to post
  • Wed Oct 14, 2020 9:18 am
  • Replies 2
  • Views 722

CJC

Question about .idea directory

Hi All, I just did a new install of OC 3.0.3.6. I uploaded the .zip file to the server, extracted it, then moved the contents of the Upload directory to the root level. I ran the install and all seemed fine. I then noticed that there was a hidden directory (.idea) within Upload that didn't get moved...

Jump to post
  • Wed Oct 14, 2020 5:35 am
  • Replies 2
  • Views 722

CJC

Re: What's the correct way to add some custom css?

I believe the only issue with your approach is that both your twig file and your stylesheet will be overwritten during an update and you'll lose your customizations. Hopefully someone with more OC experience will confirm. I wanted to simply add some custom CSS to some elements. Here is what I did: W...

Jump to post
  • Mon Jun 29, 2020 11:19 pm
  • Replies 17
  • Views 1495

CJC

Re: What's the correct way to add some custom css?

Thanks. I just gave it a quick try and it seems to work. The only thing is I had a hard time getting my browser to reload the stylesheet. I used the theme cache refresh on the Dashboard page, but that didn't seem to do anything. I had to manually force my browser to load the stylesheet in a new wind...

Jump to post
  • Tue Jun 09, 2020 11:36 pm
  • Replies 17
  • Views 1495

CJC

Re: What's the correct way to add some custom css?

Will this approach work on its own, or do you still need to go through the whole process of setting up a custom theme first? Normally you'd only add some modified or additional CSS for a new web theme, in which case proceed as follows: Copy the catalog/view/theme/default/stylesheet/stylesheet.css to...

Jump to post
  • Mon Jun 08, 2020 9:38 pm
  • Replies 17
  • Views 1495

CJC

Re: What's the correct way to add some custom css?

That's an interesting approach. I may give it a shot. Well, you CAN do something like that in a default installation, it just takes a bit of setup. You can use an HTML module and its source code mode to add CSS (with no other HTML content), and then apply that module to every layout. That would add ...

Jump to post
  • Mon Jun 08, 2020 9:34 pm
  • Replies 17
  • Views 1495

CJC

What's the proper way to create a custom template?

Hi All, I've seen various responses on this. Some say that you can just create a new template folder and bring over any default files that you wish to change. Others say you have to duplicate the entire default template and go through a laundry list of edits within a few files. Is there any referenc...

Jump to post
  • Sat Jun 06, 2020 8:51 am
  • Replies 1
  • Views 215

CJC

Re: What's the correct way to add some custom css?

I guess so.

johnp wrote:
Sat Jun 06, 2020 5:41 am
If that was a core feature there would be people saying "I don't need that, why don't they leave it out".

You can't think of everything and keep everybody happy as the core OC developers know only too well.

Jump to post
  • Sat Jun 06, 2020 7:09 am
  • Replies 17
  • Views 1495

CJC

Re: What's the correct way to add some custom css?

Thanks. That looks useful, but I can't believe there isn't something available within the core installation to do that. I normally use this or something similar and add custom CSS from the admin panel: https://www.opencart.com/index.php?route=marketplace/extension/info&extension_id=36586&filter_sear...

Jump to post
  • Sat Jun 06, 2020 5:19 am
  • Replies 17
  • Views 1495

Search found 28 matches