Search found 29 matches

Search found 29 matches

Help - I have been hacked!

Greetings. Google advised that my site had 'Social Engineering Content' and after checking, I found several errant PHP files and appeared backdoor attack stubs. Clearly, I need to start again. Instead of an upgrade I need to reinstall OpenCart using same db and images and uploads and addons. I chang...

Jump to post
  • Thu Oct 01, 2020 4:07 am
  • Replies 2
  • Views 900
[SOLVED] Admin unable to make changes to Store settings

Version 3.0.3.6, both Chrome and Firefox. Hi there if I go to my default store, the Save Icon is disabled despite all mandatory fields are present and correct. https://i.imgur.com/VqyQqh3.png Also, if I try to change an icon in the same, Edit icon has no action. Even clicking on dashboard/gear has n...

Jump to post
  • Mon Sep 14, 2020 5:40 am
  • Replies 0
  • Views 493
Re: Cross-Origin Request Blocked

Further to before, I was finding my .htaccess was working fine on Firefox, but not Chromium. Remember to clear caches and cookies when testing any such changes to be sure. Anyway, the above mods Ive changed to the below which works on both Chromium and Firefox (untested on others) # SEO URL Settings...

Jump to post
  • Mon Aug 24, 2020 10:19 am
  • Replies 4
  • Views 259
Re: Cross-Origin Request Blocked

You need a .htaccess redirect from www. to non www. Correct; the below works and sorts out those issues thanks vm. If anyone has time please advise if my code below is incorrect, or could be improved? #added # without www #RewriteCond %{HTTPS} off RewriteCond %{HTTPS} !=on RewriteRule ^/?(.*) https...

Jump to post
  • Mon Aug 24, 2020 8:58 am
  • Replies 4
  • Views 259
Cross-Origin Request Blocked

Hi there I have a CORS problem and tried to fix with this added to .htaccess #added SetEnvIf Origin ^(https?://.+\.webike\.co.nz(?::\d{1,5})?)$ CORS_ALLOW_ORIGIN=$1 Header append Access-Control-Allow-Origin %{CORS_ALLOW_ORIGIN}e env=CORS_ALLOW_ORIGIN Header merge Vary "Origin" Header always #ends Im...

Jump to post
  • Mon Aug 24, 2020 8:03 am
  • Replies 4
  • Views 259
Re: 3.0.3.6 install problems

sw!tch wrote:
Sun Aug 23, 2020 3:59 pm
Whats your .htaccess look like?
Absolutely! .htaccess was not enabled; I had expected it to migrate via the one in higher directory, but wrong.
Thanks so much it appears that was the culprit, or should I say I was the culprit!!
Best wishes from New Zealand.

Jump to post
  • Sun Aug 23, 2020 4:09 pm
  • Replies 16
  • Views 984
Re: 3.0.3.6 install problems

no, that is because you do a cross origin ajax request from www to non-www. Ive fixed the missing png thanks, but should I get in touch with admin this sounds like a cpanel problem: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://webike.co.nz/in...

Jump to post
  • Sun Aug 23, 2020 3:51 pm
  • Replies 16
  • Views 984
Re: 3.0.3.6 install problems

Yikes; Ive just done a FTP install same version, and get exactly the same errant operations. EG if I go to login with or without the correct user/pwd the admin/login screen simply refreshes without any error message. Whats more annoying is in this state Im not getting any error.log in directory eith...

Jump to post
  • Sun Aug 23, 2020 2:49 pm
  • Replies 16
  • Views 984
Re: 3.0.3.6 install problems

you could add this temporarily one time only into admin/controller/startup/startup.php $firstname = 'admin'; Cheers but I had effectively done that. Despite the db entry for adminx and password happens, the password entry still does not let me get into admin, and at this stage I dont have localhost...

Jump to post
  • Sun Aug 23, 2020 12:05 pm
  • Replies 16
  • Views 984
Re: 3.0.3.6 install problems

No, Opencart is more robust than this. If I figure out whats going on, I'll post it up as it seems to have changed recently, but the admin of cpanel/me should be able to sort it, so I will persevere.

Jump to post
  • Sun Aug 23, 2020 5:59 am
  • Replies 16
  • Views 984
Re: 3.0.3.6 install problems

Regardless of your comment, I should be able to log in using any of the recommended create admin methods. Sorry, but I dont understand where you are coming from; I described a problem which cant be addressed by the methods I mentioned.

Jump to post
  • Sat Aug 22, 2020 1:41 pm
  • Replies 16
  • Views 984
3.0.3.6 install problems

Greetings. The latest version needed recent PHP, which meant the mysqli was now changed in cpanel (I was using earlier PHP with different component defines). Once sorted, site loaded fine, but no logins existed. It was not a concern non-admin users were gone, but admin is impossible to recreate Ive ...

Jump to post
  • Sat Aug 22, 2020 1:13 pm
  • Replies 16
  • Views 984
Re: Link to local url in New Product/General

Hi Im a retired programmer, both shareware and freeware, so have empathy for any public domain developers. And complain - was my OP a complaint?
Certainly, there was no intention, simply a comment. I went down to check your url which requires a registration.
Anyway cheers,
Alistair.

Jump to post
  • Thu Feb 14, 2019 6:09 am
  • Replies 2
  • Views 236
V3.1 Affiliate problems

A logged in user cant see the terms of Affiliate, only a non-logged in user can. Makes no sense whatsoever, as you want to see what you are getting before you go to the trouble. Once an affiliate is set up, there is no way to disable, or remove it from a user account as admin. Even the affiliate can...

Jump to post
  • Wed Feb 13, 2019 12:35 pm
  • Replies 1
  • Views 209
Re: Unable install (.htaccess permission denied) [solved] after install theme seems corrupt.

No, the install directory 777
Later I got the weird what looked like theme issue, but in fact it was paths defined in config.php needed tweaking.

Jump to post
  • Wed Feb 13, 2019 9:28 am
  • Replies 2
  • Views 423
Re: How to Change Store URL

Only in very old versions of OpenCart, this is the OC3 forum. Please give full OC version. 3.0.3.1 Unfortunately (I say this because I dont know why) its sorted. I edited the config.php also Images started to work albeit when first viewing the site some of the buttons do not appear with graphic, bu...

Jump to post
  • Wed Feb 13, 2019 3:28 am
  • Replies 6
  • Views 345
Link to local url in New Product/General

Despite this being a well developed product, what should be really obvious, isnt, and there is no documentation. In my new product/general tab, I want to add a link to a menu item, or for that matter any local url. What is the preferred method, or what method do you use? Also the default editor in V...

Jump to post
  • Wed Feb 13, 2019 3:21 am
  • Replies 2
  • Views 236
Re: How to Change Store URL

xxvirusxx wrote:
Fri Feb 08, 2019 3:48 pm
In database.
Hi R u sure? I had done a search for the url string in DB before asking the question with 0 results.

Jump to post
  • Sat Feb 09, 2019 2:01 am
  • Replies 6
  • Views 345
Re: How can I add line returns to my product descriptions?

how to add carriage return in option/value name? eg dont want this: Assemble, tutorial, dispose packaging <br>(DONT CHECK if want packaged). (+$65.22) but this: Assemble, tutorial, dispose packaging (DONT CHECK if want packaged). (+$65.22) In those input fields Im not sure its possible, but desirabl...

Jump to post
  • Fri Feb 08, 2019 2:51 pm
  • Replies 9
  • Views 673

Search found 29 matches