Search found 62 matches

Search found 62 matches

Address to PayPal adding non-encoded characters

We tested an order and we're getting + and %2C where spaces should exist. I know this is an encoding issue, but it's only on the PayPal side of things and it never appears on OC. I'm getting a ticket raised with PayPal, but has anyone else experienced the same thing. We're using payment module PayPa...

Jump to post
  • Wed Jun 10, 2020 4:14 pm
  • Replies 7
  • Views 657
Re: Undefined index for receipt_id in the PayPal Pro iFrame

Hi Mike, we're using 2.1.0.1. We did make some changes to this file in March when we changed the template from TemplateD to mobile-iframe: $s_data['L_BUTTONVAR55'] = 'template=TemplateD'; $s_data['L_BUTTONVAR55'] = 'template=mobile-iframe'; But we didn't touch this line (line 175 for us): 'receipt_i...

Jump to post
  • Tue Jun 09, 2020 4:00 am
  • Replies 2
  • Views 455
PHP Notice: Undefined index: quantity when updating order status

Hiya, every time we update order status to, say, Processing or Shipped, we get this written to the log: 2020-06-01 23:05:49 - PHP Notice: Undefined index: quantity in /home/sites/xx/x/xxxxxxxxxx/public_html/system/library/openbay/ebay.php on line 349 2020-06-01 23:05:49 - PHP Notice: Undefined index...

Jump to post
  • Tue Jun 02, 2020 6:12 am
  • Replies 1
  • Views 141
Undefined index for receipt_id in the PayPal Pro iFrame

My system error log is filling up of these little beauties: 2020-05-30 13:47:28 - PHP Notice: Undefined index: receipt_id in /home/sites/xx/x/xxxxxxxxxx/public_html/catalog/controller/payment/pp_pro_iframe.php on line 175 Line 175 is: 'receipt_id' => $this->request->post['receipt_id'], It's not caus...

Jump to post
  • Tue Jun 02, 2020 6:01 am
  • Replies 2
  • Views 455
Region drops and so VAT (Tax) disappears

Hiya. Customer had a problem today when all of the VAT dropped across the whole catalog. When I looked, the Region / State in Settings > Local was showing as "Please select" and not the correct entry. I fixed this and the VAT came back. I know for sure this was showing before and the customer is ada...

Jump to post
  • Tue Jun 02, 2020 5:52 am
  • Replies 1
  • Views 308
Re: PayPal Pro iFrame L_BUTTONVAR in the API call

Found

Code: Select all

$s_data['L_BUTTONVAR55'] = 'template=templateD'; 
replaced with

Code: Select all

$s_data['L_BUTTONVAR55'] = 'template=mobile-iframe';
and works fine. :-)

Cheers all!

Jump to post
  • Wed Mar 25, 2020 6:05 am
  • Replies 6
  • Views 981
Re: PayPal Pro iFrame L_BUTTONVAR in the API call

Ok, ignore that. It's not making any difference as it's outside the iframe ?! ... The logic excludes the hidden fields by the looks of it so it's redundant ...

Any help would be gratefully received.

Jump to post
  • Wed Mar 25, 2020 4:39 am
  • Replies 6
  • Views 981
Re: PayPal Pro iFrame L_BUTTONVAR in the API call

Hi straightlight, Thankyou for this. I've added the hidden values into both locations: /public_html/catalog/view/theme/default/template/payment/pp_pro_iframe.tpl /public_html/catalog/view/theme/default/template/payment/pp_pro_iframe_body.tpl But nothing. :-( I've been able to edit the iframe inline ...

Jump to post
  • Tue Mar 24, 2020 7:47 pm
  • Replies 6
  • Views 981
PayPal Pro iFrame L_BUTTONVAR in the API call

OK, loads of threads online about this, but nothing I can see with a resolution? I have the same problem as a few posts on the PayPal Pro iFrame (we're using PayPal to action the payment) and it's not showing on the page correctly. I've had a support email back from PayPal to say that OC makes use o...

Jump to post
  • Sat Mar 21, 2020 5:12 am
  • Replies 6
  • Views 981
Re: Module causing 500 in admin when rebuilding modification cache

I don't know what module it might be. We've just installed 2 recently, and checking with both developers it's not theirs that does this action. I have a copy of the ocmod.log which may have some clue, but I don't know what I'm looking for. I might very well check the GIT logs too to see what has cha...

Jump to post
  • Fri Jan 31, 2020 5:03 pm
  • Replies 4
  • Views 960
Module causing 500 in admin when rebuilding modification cache

Each time I build the modification cache I get a 500 in the admin panel with this as the issue: Parse error: syntax error, unexpected 'UPDATE' (T_STRING) in /{.....}/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 171 where {.....} is my hosting home...

Jump to post
  • Thu Jan 30, 2020 9:50 pm
  • Replies 4
  • Views 960
What actually does the 'Install' button of a module do?

This is probably an extremely simplistic way to put it, but I'd like to know what actually happens when you click the 'Install' button for a newly installed plugin? I used OCMOD to install a plugin and got a 500 in the admin area pretty much immediately. I then backed out the changes using GIT and t...

Jump to post
  • Tue Jan 21, 2020 9:53 pm
  • Replies 4
  • Views 627
Re: Problem with category.tpl rendering parent but child pages are fine

Hey Ernie, Ah yes, sorry ... We're running 2.1.0.1 and I've done quite a bit of custom changes to styles but the template really hasn't been touched (I've attached it). I just find it very odd that for the main parent category it goes belly up, but for all sub categories under that use the same temp...

Jump to post
  • Sat Mar 16, 2019 4:52 am
  • Replies 3
  • Views 573
Problem with category.tpl rendering parent but child pages are fine

Hiya. I have a problem with the category.tpl markup on the top level parent category, but ALL category pages underneath are fine. I'm using the Basecart theme. In the admin, ALL the category pages are using the same page design, so I'm not really sure where else to go and it's quite frustrating. I'm...

Jump to post
  • Fri Mar 15, 2019 6:33 am
  • Replies 3
  • Views 573
Re: PSD2 PayPal Pro upgrade

Hi, thank you. Not sure how or where I would go to follow the GitHub Opencart updates about PCI compliance changes.... Sorry I've searched the net and OpenCart forums, and not sure where to go? ...

Jump to post
  • Mon Mar 04, 2019 3:52 am
  • Replies 3
  • Views 791
PSD2 PayPal Pro upgrade

Hi, I have customer on 2.1.0.1 and we've had an update from Paypal about the new regulations coming into effect in September 2019 https://www.paypal.com/uk/webapps/mpp/psd2 We're currently using the "PayPal Pro iFrame" for payment method. I just need to know what to do to ensure we're compliant late...

Jump to post
  • Fri Mar 01, 2019 9:04 pm
  • Replies 3
  • Views 791
Trader account with simple order form, pay by invoice and free delivery over £x

I have a customer that needs to set up an existing 2.1.0.1 OC account with a TRADE OPTION with some specific requirements that relates to both extensions and templates. I'm a frontend developer with good template knowledge but will need some support for both this and extensions that will allow us to...

Jump to post
  • Wed Feb 27, 2019 7:02 am
  • Replies 1
  • Views 629
Trader account with simple order form, pay by invoice and free delivery over £x

I have a customer that needs to set up an existing 2.1.0.1 OC account with a TRADE OPTION with some specific requirements that relates to both extensions and templates. I'm a frontend developer with good template knowledge but will need some support for both this and extensions that will allow us to...

Jump to post
  • Wed Feb 27, 2019 6:59 am
  • Replies 1
  • Views 409
Re: Copy of PROD site on localhost and all JS calls failing

SOLVED: The jquery and bootstrap JS files when FTP'd up from the prod server didn't format correctly, so I had a load of unrecognised characters in the scripts. Copy and paste the PROD versions and all good :-)

Jump to post
  • Thu Nov 15, 2018 5:22 am
  • Replies 1
  • Views 249
SOLVED: Copy of PROD site on localhost and all JS calls failing

Hiya, I've got a copy of my site from production to localhost on my laptop and after some changes to the config.php in both root and admin it's all working, but for some reason all the jquery is failing in the console: https://image.ibb.co/k3XPkL/Screen-Shot-2018-11-13-at-23-51-02.png I'm sure it's ...

Jump to post
  • Wed Nov 14, 2018 7:54 am
  • Replies 1
  • Views 249

Search found 62 matches