Post by fdoreCadex » Thu Feb 26, 2015 9:44 pm

Hello.

I've looked all over the internet for a fix but all i've found are unresolved answers on forums (even here), so i'll try myself and see.

So I've got the UPS shipping extension on my store. (I believe it is the default one, since i'm not the initial dev of the store.)

The shipping cost for UPS is charging way too much.
Ex: Customer charged 78$ for UPS saver from Canada to US, and we only paid 34$

I contacted UPS but i'm lost as they are asking for the XML Request and Response files, and SOAP envelopes.
I have no idea what those are. If someone could help me for this too it'd be appreciated.

I've already checked everything mentioned in the "Read before you post" topic; Weight rates and whatnot are all good.

If someone has anything for me, a clue to understand what's wrong or something, feel free to post it.

Thanks!

Newbie

Posts

Joined
Thu Feb 26, 2015 4:57 am

Post by hyperfly » Tue Mar 17, 2015 11:41 pm

I am having the same sort of problem. I am also using the same module as you. The problem that I am having is that I am seeing the module under charge. One thing that I did find out is that you need to have all of the currencies inputted into Open Cart. As my site is in Canada but I am going to charge USD the UPS module will only out put the currency where you live. So if you are in Canada it will give back the value in Canadian Dollars. So I have added the Canadian currency along with the currency converter module and it seems to be working. But I do have to say that some of the rates are all over the map.

Newbie

Posts

Joined
Fri Jan 09, 2015 6:10 am

Post by promofire » Thu Jun 18, 2015 2:42 am

Did you get an answer to this? We're seeing prices more than double as well.

Active Member

Posts

Joined
Thu Jan 27, 2011 2:00 am

Post by Johnathan » Thu Jun 18, 2015 10:12 pm

Like hyperfly suggests, you should check your weight classes, product weights, and currency settings, to make sure they're all set right. Beyond that, you may need to hire someone to look at the code for you, or try Qphoria's UPS Deluxe extension to see if it gives better rates.

If you can't figure out the cause, but the UPS extension rates are off by a standard percentage, you could also use Hidden Shipping Adjustments to adjust them to match the rates you're getting.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by promofire » Thu Jun 18, 2015 11:30 pm

Thanks. We had some caching problems (locally with the ISP that kept us from seeing some changes). Changing the default dimensions in the UPS module to 4x4x4 was all we needed to do.

Active Member

Posts

Joined
Thu Jan 27, 2011 2:00 am

Post by fdoreCadex » Thu Jul 16, 2015 10:23 pm

Ok @promofire, I'll try that!

Edit: It didn't do anything, no changes in prices, thanks anyway.

Newbie

Posts

Joined
Thu Feb 26, 2015 4:57 am

Post by Qphoria » Fri Jul 17, 2015 1:22 am

The UPS core module is very basic. I offer an enhancement for the UPS mod that offers the ability to do Individual shipping rates, which means it passes in the actual weight and dimensions of each item in the cart, rather than using that single Avg dimension setting. It also adds support for discounted rates and manual price adjustments. This may be what you are looking for:
http://www.opencart.com/index.php?route ... n_id=19578

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 3 guests