Post by Alex1453 » Tue Jun 02, 2015 7:14 am

I'm looking to add FedEx shipping to my website which currently utilizes just a weight-based shipping system. I installed the FedEx module, edited it to go through the test mechanism, which came up ERROR (I didn't worry about this since other users seem to have had the same issue), and then I progressed through adding the permanent information (meter, key, etc.). After adding the permanent information and enabling FedEx, nothing seems to come up - not the FedEx shipping slot label nor the red "ERROR" button next to the slot for FedEx. Any idea what could be causing this and how to fix it?

Newbie

Posts

Joined
Tue Jun 02, 2015 7:06 am

Post by Qphoria » Fri Jun 05, 2015 9:19 pm

The basic fedex extension in opencart is unfortunately rather cryptic about it's errors. But I think you should be able to see the full error in the Error Logs section in the admin. Look for "Fedex" and see what it says.

In case you are looking for a better solution, I have an Advanced Fedex module that includes a box packaging algorithm with intelligent box splitting based on max weight and girth, the option to set each item as an Individual package, insurance, rate adjusting, transit times, improved error handling, and full message debugging here:
http://www.opencart.com/index.php?route ... n_id=19227

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 7 guests