Post by adicoto » Tue Jul 14, 2020 3:46 pm

1. For those who have import errors, I've noticed that importing file in xls format never generate error. I've had an xlsx file that was giving me errors about fields that were empty but after saving the file as xls importing from xls all was ok.

2. Can this module use product variants (GA Product Variants extension which generate a supplemental filed in product properties, variant)? We plan to migrate from X-cart to OpenCart and we have hundreds of products with variants and would like to be able to import them into OpenCart, so we won't lose a lot of work done previously.

Best regards
adicoto

Newbie

Posts

Joined
Fri Nov 29, 2019 10:44 pm

Post by JNeuhoff » Tue Jul 14, 2020 7:28 pm

adicoto wrote:
Tue Jul 14, 2020 3:46 pm
1. For those who have import errors, I've noticed that importing file in xls format never generate error. I've had an xlsx file that was giving me errors about fields that were empty but after saving the file as xls importing from xls all was ok.
A pretty vague description, you not not giving any details about the exact error messages you got.

adicoto wrote:
Tue Jul 14, 2020 3:46 pm
2. Can this module use product variants (GA Product Variants extension which generate a supplemental filed in product properties, variant)? We plan to migrate from X-cart to OpenCart and we have hundreds of products with variants and would like to be able to import them into OpenCart, so we won't lose a lot of work done previously.
OpenCart calls it Product Options, with different option types available for single-choice, multi-choice, and various text options. Just install a fresh OpenCart and the Export/Import tool, then do an Export to see the exact worksheet formats to be used in the spreadsheet files.
Last edited by JNeuhoff on Tue Jul 14, 2020 8:30 pm, edited 1 time in total.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by adicoto » Tue Jul 14, 2020 8:27 pm

1. I have encountered errors when importing, about fileds which where empty (and opencart had the impresion that those fields were not empty), but after re-saving the file as xls and not xlsx the error wasn't present any more.
2. I am using for some months your tool which is magnificent for what can do. The question was related to another module (GA Product Variants Extension) which add to the product info fields the product variant. Product variant it's largely used in X-Cart (you have a product that come in 128 colours so you create 1 product and add 127 variants, each with it's color. When selecting color, image changes, SKU changes...). So, it would be nice if your module would cover this possibility too (grabbing variants information added by the Variant module extension). Can this be done ?

Newbie

Posts

Joined
Fri Nov 29, 2019 10:44 pm

Post by litextension » Wed Jul 15, 2020 12:03 pm

adicoto wrote:
Tue Jul 14, 2020 3:46 pm
2. Can this module use product variants (GA Product Variants extension which generate a supplemental filed in product properties, variant)? We plan to migrate from X-cart to OpenCart and we have hundreds of products with variants and would like to be able to import them into OpenCart, so we won't lose a lot of work done previously.

Best regards
adicoto
Instead of trying to import files for your migration from X-cart to OpenCart (data migrated only), you can rely on our migration tool to both have quick and secure data migration plus the ability to complete tasks like keeping SEO rankings, migrate customer passwords, etc. A brief instruction video: https://www.youtube.com/watch?v=C2RCeHlotmE

LitExtension - Shopping Cart Migration Expert
Visit us at: https://litextension.com


User avatar
New member

Posts

Joined
Wed Aug 03, 2016 4:22 pm

Post by JNeuhoff » Wed Jul 15, 2020 7:39 pm

adicoto wrote:
Tue Jul 14, 2020 8:27 pm
1. I have encountered errors when importing, about fileds which where empty (and opencart had the impresion that those fields were not empty), but after re-saving the file as xls and not xlsx the error wasn't present any more.
This is most likely due to empty trailing rows in your XLSX file, a known MS Excel bug had probably caused this. We always recommend using LibreOffice Calc instead of MS Excel.

adicoto wrote:
Tue Jul 14, 2020 8:27 pm
2. I am using for some months your tool which is magnificent for what can do. The question was related to another module (GA Product Variants Extension) which add to the product info fields the product variant. Product variant it's largely used in X-Cart (you have a product that come in 128 colours so you create 1 product and add 127 variants, each with it's color. When selecting color, image changes, SKU changes...). So, it would be nice if your module would cover this possibility too (grabbing variants information added by the Variant module extension). Can this be done ?
We can customize the Export/Import to add support for extra DB fields introduced by 3rd party extensions, for a small charge. Please contact us with more details on this.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by potew » Thu Jul 16, 2020 10:44 pm

Hi,
I was able to successfully import all my products. However, for the clients, I am having trouble getting the current data in order to get a sample of the tables format. When I click to import, nothing happens and then I get the following messages in the error log:
[ quote]
16-07-2020 14:39:00 - PHP Unknown: Array and string offset access syntax with curly braces is deprecated in C:\MAMP\htdocs\loja\system\library\export_import\Classes\PHPExcel\Shared\String.php on line 542
16-07-2020 14:39:00 - PHP Unknown: Array and string offset access syntax with curly braces is deprecated in C:\MAMP\htdocs\loja\system\library\export_import\Classes\PHPExcel\Cell.php on line 812
16-07-2020 14:39:00 - PHP Notice: Trying to access array offset on value of type null in C:\MAMP\htdocs\loja\admin\model\extension\export_import.php on line 62.[/quote]

There is only one client registered in my database!
What can be done?
Thanks,

Newbie

Posts

Joined
Fri Jul 10, 2020 6:49 am

Post by JNeuhoff » Fri Jul 17, 2020 12:08 am

You are probably using the new PHP Version 7.4 where certain features like the usage of string offset access syntax with curly braces are now deprecated in PHP. Unfortunately it's still in the PHPExcel library used by the Export/Import tool.

For a quick solution, switch back to a previous PHP V7.x release for your server.

We are working on replacing the old PHPExcel library with the newer PHPOffice / PhpSpreadsheet library for the next release of the Export/Import tool, hopefully to be released in the next few days. That one should then work for PHP 7.4, too.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by potew » Fri Jul 17, 2020 12:39 am

JNeuhoff wrote:
Fri Jul 17, 2020 12:08 am
You are probably using the new PHP Version 7.4 where certain features like the usage of string offset access syntax with curly braces are now deprecated in PHP. Unfortunately it's still in the PHPExcel library used by the Export/Import tool.

For a quick solution, switch back to a previous PHP V7.x release for your server.

We are working on replacing the old PHPExcel library with the newer PHPOffice / PhpSpreadsheet library for the next release of the Export/Import tool, hopefully to be released in the next few days. That one should then work for PHP 7.4, too.
Nice, I switched to PHP 7.3.7 and it did work. Thanks a lot!
To import the updated file, just add new data and upload it back in the import tab?

Newbie

Posts

Joined
Fri Jul 10, 2020 6:49 am

Post by JNeuhoff » Fri Jul 24, 2020 1:01 am

We have now released the Export/Import tool V4.1 which uses the PhpOffice/PhpSpreadsheet package instead of the old PHPExcel. This allows for the support of the new PHP version 7.4 or higher. Minimum PHP version required is 7.2!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by SarahJMarsters » Fri Jul 24, 2020 8:50 pm

adicoto wrote:
Tue Jul 14, 2020 3:46 pm
1. For those who have import errors, I've noticed that importing file in xls format never generate error. I've had an xlsx file that was giving me errors about fields that were empty but after saving the file as xls importing from xls all was ok.

2. Can this module use product variants (GA Product Variants extension which generate a supplemental filed in product properties, variant)? We plan to migrate from X-cart to OpenCart and we have hundreds of products with variants and would like to be able to import them into OpenCart, so we won't lose a lot of work done previously.

Best regards
adicoto
thanks for the info about import errors! as for the migration procedure I would suggest you try an automated tool. it's fast and simple. the market's full of these services now and you can pick one to your personal liking. i usually go with cart2cart. they do the job quickly and i don't have to worry about data security and store's integrity


Posts

Joined
Tue May 26, 2020 9:26 pm

Post by belindaj » Thu Jul 30, 2020 10:55 am

I downloaded and installed opencart-3-x-export-import-multilingual-4-2-cloud.ocmod
No problem with the install - followed instructions completely.
php v7.2 required - which is what my site was on - should have been ok - but when I tried the first export it prompted me that php 7.3 was the minimum required.
I updated my php to 7.3 and then attempted another export - now it tells me I am using an old version of the Export/Import Tool, please upgrade to the new version 4.2

Version 4.2 IS what I installed, but nevertheless I uninstalled, refreshed, cleared cache, downloaded a fresh copy from the Marketplace, reinstalled (verifying the filename IS 4.2) - still getting the upgrade message that I am using an old version.

No export happens when I try to export product data by id range, and no error is returned.

My Opencart is 3.0.3.2

Suggestions?

New and Treading Water Feverishly ;D
Current Cart-in-progress: https://gtgshops.com 3.0.3.2 installation, no core files modified


New member

Posts

Joined
Wed Jul 31, 2019 6:59 am

Post by JNeuhoff » Thu Jul 30, 2020 6:22 pm

Sorry for this. There was a bug in the version checks. If you ugrade to the new 4.3 release it should now be fixed and work with PHP V7.2 or later.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by clubplug » Wed Aug 12, 2020 10:00 pm

Hi everyone
I have searched the posts and have come up with bits and pieces of information, but still have a problem, so I figured I would try here for some expert help...
Let me start with what I am running:

- I have opencart 3.0.3.2 with PHP 7.2.24 and using the latest Export/Import ver. 4.4 (free version)
- Currently used category IDs are between 17 and 91. Currently used product IDs are between 127 and 226986.
Just a small note about the ID numbers, the actual number of products is 12169. Some of the ID numbers are skipped, that is why the ID number goes to 226986

So if I try running the export (entire products) on my local dev. using XXAMP, it runs perfectly (spreadsheet is created, no issues about 3mb) and noticed that the error.log (not really errors) file that it generates is 386mb (this is the error.log file, not the spreadsheet)

Now if I try running on our webhosting, it starts to run, runs for about 100-120 seconds and then get a 500 Internal error.

ERROR.LOG
2020-08-11 20:04:13 - populateProductsWorksheet: numberFormat = 'object(PhpOffice\PhpSpreadsheet\Style\NumberFormat)#239 (5) {
["formatCode":protected]=>
string(7) "General"
["builtInFormatCode":protected]=>
int(0)
["isSupervisor":protected]=>
bool(true)
["parent":protected]=>
object(PhpOffice\PhpSpreadsheet\Style\Style)#211 (12) {
["font":protected]=>
object(PhpOffice\PhpSpreadsheet\Style\Font)#212 (13) {
["name":protected]=>
.....
}
["parentPropertyName":protected]=>
NULL
}
["parentPropertyName":protected]=>
NULL
}
'
<b>Warning</b>: Error while sending QUERY packet. PID=2371649 in <b>/home/sparkp9/public_html/can/oc/system/library/db/mysqli.php</b> on line <b>18</b>

I have tried playing with different settings in php.ini, .user.ini, my.ini

My question, is there a specific setting that needs to be set for large files or is this an issue with the webhosting company that is limiting large script execution?

Thank you
Frank

New member

Posts

Joined
Sun Dec 22, 2019 12:42 am

Post by JNeuhoff » Wed Aug 12, 2020 10:39 pm

I haven't seen this issue before. Might be a good idea to try the Import in smaller batches.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by clubplug » Wed Aug 12, 2020 10:57 pm

JNeuhoff wrote:
Wed Aug 12, 2020 10:39 pm
I haven't seen this issue before. Might be a good idea to try the Import in smaller batches.
Hi J
Thank you for the quick reply. That is what I am doing, I am exporting in smaller batches. But sometimes it would be great to export the whole product file in one shot...

I did more research and did find some new info.
In MySQL variables there are 2 settings called
wait_timeout
interactive_timeout

On my Webhosting they are both set to 30 and it does not allow me to change them (need supervisor rights, etc.. ), I will try to see if they can change it for me.

Thanks again.
Frank

New member

Posts

Joined
Sun Dec 22, 2019 12:42 am

Post by harlemangel » Thu Aug 27, 2020 7:51 am

Getting a 'Request Entity Too Large' on install of latest version to OC 3.0.3.6
Any ideas or help would be appreciated.
(Apache/Linux)

Newbie

Posts

Joined
Tue Oct 23, 2012 11:50 pm

Post by JNeuhoff » Thu Aug 27, 2020 4:40 pm

Getting a 'Request Entity Too Large' on install of latest version to OC 3.0.3.6
Any ideas or help would be appreciated.
(Apache/Linux)
A 413 Request Entity Too Large error occurs when a request made from a client is too large to be processed by the web server. ... An example request, that may cause this error would be if a client was trying to upload a large file to the server (e.g. a large media file). So in your case, try to do the Export and Import (the latter probably caused your error) in smaller batches.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by harlemangel » Thu Aug 27, 2020 6:46 pm

JNeuhoff wrote:
Thu Aug 27, 2020 4:40 pm
Getting a 'Request Entity Too Large' on install of latest version to OC 3.0.3.6
Any ideas or help would be appreciated.
(Apache/Linux)
A 413 Request Entity Too Large error occurs when a request made from a client is too large to be processed by the web server. ... An example request, that may cause this error would be if a client was trying to upload a large file to the server (e.g. a large media file). So in your case, try to do the Export and Import (the latter probably caused your error) in smaller batches.
Thanks for the reply. Its not on the import/export. Its when I am trying to install the extension. I have got this extension to work on a previous version (V3.22) on the same server, so I dont think its a server issue. Is there a manual way of installing it?

Newbie

Posts

Joined
Tue Oct 23, 2012 11:50 pm

Post by JNeuhoff » Thu Aug 27, 2020 7:15 pm

You should ask your webhost to increase the server request limit, the install file is 1.1MB zip archive. Or change web host if they don't.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by harlemangel » Thu Aug 27, 2020 9:00 pm

JNeuhoff wrote:
Thu Aug 27, 2020 7:15 pm
You should ask your webhost to increase the server request limit, the install file is 1.1MB zip archive. Or change web host if they don't.
Thats the problem. I own my own server, and have full control over it. Ive increased limits to max, and still getting the error. Just wondering is there another extension that I should be installing along with this one to get it working?
Also, would it be possible to download the previous version? I have 3.22 working on another site on the same server (PHP5.x) and it works fine. Maybe its a PHP issue? Its not a size issue, as you mentioned the install file is only 1.1Mb. The error is misleading I think

Is there a manual way of installing it? Just FTP the uploads folder?

Newbie

Posts

Joined
Tue Oct 23, 2012 11:50 pm
Who is online

Users browsing this forum: No registered users and 4 guests