Post by karl jacobs » Fri Nov 04, 2011 12:14 pm

Hi, I'm trying to install a FAQ module from http://www.opencart.com/index.php?route ... order=DESC

The module is written by Fido-X so is of decent quality and I have seen it working. I have only just started using vQmod so not familiar with it. I have read through the documention on google code and looked at the included xml file from the faq module and it looks OK. I could edit files manually but I like to have mods working as designed.

I have had another xml for vQmod fail aswell, so I suspect I may be making a simple newbie error somewhere, here is the code

Code: Select all

<modification>

	<id>FAQ for OpenCart 1.5.1.x</id>
	<version>1.0.0</version>
	<vqmver>1.2.3</vqmver>
	<author>Fido-X</author>

	<file name="admin/controller/common/header.php">
		<operation>
			<search position="after" index="1"><![CDATA[
			$this->data['text_information'] = $this->language->get('text_information');
			]]></search>
			<add><![CDATA[
			$this->load->language('module/faq');
			$this->data['text_faq'] = $this->language->get('text_faq');
			]]></add>
		</operation>
		<operation>
			<search position="after" index="1"><![CDATA[
			$this->data['zone'] = $this->url->link('localisation/zone', 'token=' . $this->session->data['token'], 'SSL');
			]]></search>
			<add><![CDATA[
			$this->data['faq'] = $this->url->link('module/faq/listing', 'token=' . $this->session->data['token'], 'SSL');
			]]></add>
		</operation>
	</file>

	<file name="admin/view/template/common/header.tpl">
		<operation>
			<search position="after" index="1"><![CDATA[
			<li><a href="<?php echo $information; ?>"><?php echo $text_information; ?></a></li>
			]]></search>
			<add><![CDATA[
			<li><a href="<?php echo $faq; ?>"><?php echo $text_faq; ?></a></li>
			]]></add>
		</operation>
	</file>

	<file name="catalog/controller/common/footer.php">
		<operation>
			<search position="after" index="1"><![CDATA[
			$this->data['text_newsletter'] = $this->language->get('text_newsletter');
			]]></search>
			<add><![CDATA[
			$this->load->language('information/faq');
			$this->data['text_faq'] = $this->language->get('text_faq');
			$this->data['faq'] = $this->url->link('information/faq');
			]]></add>
		</operation>
	</file>

	<file name="catalog/view/theme/default/template/common/footer.tpl">
		<operation>
			<search position="before" index="1"><![CDATA[
			<li><a href="<?php echo $contact; ?>"><?php echo $text_contact; ?></a></li>
			]]></search>
			<add><![CDATA[
			<li><a href="<?php echo $faq; ?>"><?php echo $text_faq; ?></a></li>
			]]></add>
		</operation>
	</file>

</modification>
Please advise how I can get this working.
Last edited by karl jacobs on Fri Nov 04, 2011 10:47 pm, edited 1 time in total.

User avatar
New member

Posts

Joined
Wed Jan 05, 2011 12:21 am

User avatar
Active Member

Posts

Joined
Thu Nov 11, 2010 6:11 pm
Location - New Zealand (Tokomaru, Palmerston North)

Post by karl jacobs » Fri Nov 04, 2011 10:46 pm

I realized my mistake which was not to try this stuff at 4.00am! It works fine now I've slept and done it correctly.

User avatar
New member

Posts

Joined
Wed Jan 05, 2011 12:21 am
Who is online

Users browsing this forum: No registered users and 3 guests