Post by tramhtp » Sun Jan 08, 2017 2:13 pm

Hello,
I have Opencart Version 2.3.0.3_rc. for my website https://thebeautyroomhi.com
When I submit 'Contact us' form, I received error bellow
Warning: fsockopen(): unable to connect to ssl://smtp.gmail.com:465 (Permission denied) in /var/www/html/system/library/mail.php on line 167
Here is my setting for SMTP Port Gmail
Image
I tried the setting with port 25, 465, 587 but all not work. Someone can help me?
Thanks so much.

Newbie

Posts

Joined
Sun Jan 08, 2017 12:52 pm

Post by michael2820 » Tue Jan 10, 2017 12:18 am

why not use Mail as Protocol ?

--- please reply only with verified data, that is: no 'I think', 'maybe' etc. ---


User avatar
Active Member

Posts

Joined
Sun May 15, 2011 8:16 pm
Location - Denmark ver. 2.1.0.2

Post by tramhtp » Tue Jan 10, 2017 12:24 pm

Thank you michael2820.
I set up the Protocol = Mail
Image
When I submit Contact Us Form, I get the message "Your enquiry has been successfully sent to the store owner!" but I also did not receive any email. I do not know where I wrong?

Newbie

Posts

Joined
Sun Jan 08, 2017 12:52 pm

Post by michael2820 » Tue Jan 10, 2017 4:25 pm

you set your email in System > Settings > Shop/Store > in the field = Email.
When posting here, always tell your version of OC

--- please reply only with verified data, that is: no 'I think', 'maybe' etc. ---


User avatar
Active Member

Posts

Joined
Sun May 15, 2011 8:16 pm
Location - Denmark ver. 2.1.0.2

Post by tramhtp » Wed Jan 11, 2017 11:31 am

michael2820 wrote:you set your email in System > Settings > Shop/Store > in the field = Email.
When posting here, always tell your version of OC
Thanks for your answer, michael2820. I have already told this on the first post. I have Opencart Version 2.3.0.3_rc. Here is the my website https://thebeautyroomhi.com.
Regards,

Newbie

Posts

Joined
Sun Jan 08, 2017 12:52 pm

Post by knowband.plugins » Wed Jan 11, 2017 5:32 pm

Your SMTP setting is correct, there is no issue in it. Please note that if you are configuring SMTP with a Gmail account, your store email address must be from Gmail.

If you are using other email address, then it will not work.

If it is still not working, make sure that imap is installed on your server and there is no security alert in your Gmail account.

Regards,
Knowband Team

Opencart Plugins: Knowband Store
Email: support@knowband.com


User avatar
Active Member

Posts

Joined
Thu Aug 04, 2016 2:56 pm


Post by tramhtp » Thu Jan 12, 2017 12:21 pm

Hi knowband.plugins ,
I want to clarify some point?
1. 'you are using other email address, then it will not work'.
I set mail in Store like this:
Image
Does the Store email need to be the same as in Mail setting or it just need to be a Gmail?

2. 'Make sure that imap is installed on your server and there is no security alert in your Gmail account'.
I set Less Security on Gmail, so app is allowed to send via Gmail. I guess no security issue with Gmail.
For 'imap', can you explain more on this, I don't know how to setup.

Thanks.

Newbie

Posts

Joined
Sun Jan 08, 2017 12:52 pm

Post by knowband.plugins » Thu Jan 12, 2017 10:16 pm

It need not to be same as in configuration, it can be any email address associated with Gmail.

Chances are either imap is disabled or is not installed on your server. If you are using Linux to host your site then use following commands to install and enable imap.


For nginx server

sudo apt-get install php5-imap
sudo php5enmod imap
service nginx restart
service php5-fpm restart


For apache server

sudo apt-get install php5-imap
sudo php5enmod imap
sudo service apache2 restart

If you are not sure what to do, please contact your hosting provider to ensure that imap is installed and enabled.

Regards,
Knowband Team

Opencart Plugins: Knowband Store
Email: support@knowband.com


User avatar
Active Member

Posts

Joined
Thu Aug 04, 2016 2:56 pm


Post by maxigallo76 » Sat May 20, 2017 12:52 am

1. Login to your Opencart Admin Page and navigate to System > Settings > Edit > Mail
2. Once you have opened up the Mail Settings tab you should complete the form using the following data:
Mail Protocol should be set to SMTP
Mail Parameters is an optional field we will not be discussing. You can leave it blank for now.
SMTP Host should be set to “ssl://smtp.gmail.com”
It is very important you include “ssl://” or your customers will receive errors when completing actions on your store that use the mail feature.
SMTP Username should be set to the account username for the Gmail account you would like to use. “yourusername@gmail.com
SMTP Password should be the corresponding password for your Google Account
SMTP Port should be “465"
This is also important as it’s a great feature of Google’s SMTP service. As it does not use port 20 it keeps your emails from being marked as spam.
SMTP Timeout you can leave set to the default of 5.
The alert email options can be turned on if you would like the store owner to be emailed every time an account is created or an order is processed. They are turned off by default and I suggest leaving them this way, especially if your store has a high volume of orders. These emails are sent to the email account specified from the General tab on the same settings page you are on now.
The additional alert email fields just specify other email address that you would like these alerts to be sent to if you did have them turned on.
That is all that must be completed from the Opencart admin. You can now hit save and move on to the next step.
3. Go to Gmail and login to the account that you used for your SMTP configuration in Step 2.
Once logged in, go to “https://accounts.google.com/b/0/DisplayUnlockCaptcha"
Click continue. This will authenticate the next app or device that tries to access your Gmail Account within the next 10 minutes.
Now you must go to your Opencart store front end and register for a new account. When this is done Opencart will attempt to access your Gmail Account for SMTP and Google will Authenticate it.
You should be sent to a confirmation page that your account was created on your site, and an email should be sent to your email address you used to register your account, using your Google SMTP configuration.
That’s it! You’re all set up!
If you receive any errors, make sure you completed step 3 to have your store authenticated with Google, as well as used ssl:// before your hostname in the Opencart admin mail settings.

Newbie

Posts

Joined
Fri May 19, 2017 10:43 pm

Post by huyen.ta » Wed Sep 02, 2020 3:36 pm

I had the same issue when I set SMTP Port Gmail for my website.
I followed step by step this website and It's working very well now.
https://www.opencart-templates.co.uk/ma ... nformation
I saved that link in my sheet. It's very helpful sometimes.
Be careful with step 2,3,4.

Newbie

Posts

Joined
Thu Aug 16, 2018 12:16 pm

Post by mikahawkins » Mon Oct 12, 2020 12:31 pm

Hello,
The Gmail SMTP setup settings are given as follows:
1.SMTP username: Your Gmail address.
2.SMTP password: Your Gmail password.
3.SMTP server address: smtp.gmail.com.
4.Gmail SMTP port (TLS): 587.
5.SMTP port (SSL): 465.
6.SMTP TLS/SSL required: yes

Regards,
Mika Hawkins

Newbie

Posts

Joined
Fri Sep 18, 2020 2:54 pm

Post by straightlight » Mon Oct 12, 2020 7:23 pm

mikahawkins wrote:
Mon Oct 12, 2020 12:31 pm
Hello,
The Gmail SMTP setup settings are given as follows:
1.SMTP username: Your Gmail address.
2.SMTP password: Your Gmail password.
3.SMTP server address: smtp.gmail.com.
4.Gmail SMTP port (TLS): 587.
5.SMTP port (SSL): 465.
6.SMTP TLS/SSL required: yes

Regards,
Mika Hawkins
Also ensure that crypto is enabled on your domain when using port 587 and to follow your cPanel's email settings instructions.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jenal5584 » Tue Nov 17, 2020 10:05 pm

How about for non-SSL? Should i put mail.domain.com under SMTP Hostname? I'm using own domain to send email but getting error as below.
Notice: Error: MAIL FROM not accepted from server! in /home/username/mydomain.com/system/library/mail.php on line 328

Newbie

Posts

Joined
Tue Nov 17, 2020 6:09 pm

Post by straightlight » Tue Nov 17, 2020 10:16 pm

jenal5584 wrote:
Tue Nov 17, 2020 10:05 pm
How about for non-SSL? Should i put mail.domain.com under SMTP Hostname? I'm using own domain to send email but getting error as below.
Notice: Error: MAIL FROM not accepted from server! in /home/username/mydomain.com/system/library/mail.php on line 328
smtp is sending secured emails, that is the one you should use. Ensure the hostname has: ssl:// in front of your SMTP hostname address , as well as your port number set to 587, and to follow your host's email settings description on your host console.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jenal5584 » Wed Nov 18, 2020 4:15 pm

Hi,

I use ssl also getting same error. But i can send email with ssl from email client like microsoft outlook and thunderbird and no issue.
Opencart version 2.1.0.1.

Newbie

Posts

Joined
Tue Nov 17, 2020 6:09 pm

Post by straightlight » Wed Nov 18, 2020 7:49 pm

jenal5584 wrote:
Wed Nov 18, 2020 4:15 pm
Hi,

I use ssl also getting same error. But i can send email with ssl from email client like microsoft outlook and thunderbird and no issue.
Opencart version 2.1.0.1.
What error?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jenal5584 » Wed Nov 18, 2020 8:43 pm

I'm getting this error:
Notice: Error: MAIL FROM not accepted from server! in /home/username/mydomain.com/system/library/mail.php on line 328

Newbie

Posts

Joined
Tue Nov 17, 2020 6:09 pm

Post by straightlight » Wed Nov 18, 2020 9:26 pm

jenal5584 wrote:
Wed Nov 18, 2020 8:43 pm
I'm getting this error:
Notice: Error: MAIL FROM not accepted from server! in /home/username/mydomain.com/system/library/mail.php on line 328
Your OC mail form settings are misconfigured. Ensure to follow your host's settings in your cPanel > Email > Your Email > Settings left-bottom corner page (SSL). The hostname must begin with: ssl:// in the hostname text box of the OC mail form settings. Port number: 587 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ADD Creative » Wed Nov 18, 2020 11:55 pm

jenal5584 wrote:
Wed Nov 18, 2020 8:43 pm
I'm getting this error:
Notice: Error: MAIL FROM not accepted from server! in /home/username/mydomain.com/system/library/mail.php on line 328
What form are you sending from? Register, order, contact, etc.?

Does you email in System -> Settings -> Store (tab) -> E-mail match System -> Settings -> Mail (tab) -> SMTP Username?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by jenal5584 » Thu Nov 19, 2020 9:40 am

I test using forgot password url. Using mail protocol no issue. Just smtp got issue.
Image

Newbie

Posts

Joined
Tue Nov 17, 2020 6:09 pm
Who is online

Users browsing this forum: No registered users and 12 guests