Post by mikhailjb » Sun Jun 28, 2020 12:41 am

Hi All,
I seem to be stuck on OC 2.2.0.0 and everytime I try to upload the upgrade even to 2.3.0.2 all I get is a white screen on my store and admin pages.
Where do I even beging with this? I am also running Journal Theme 2.7.3 and various other addons .
Thanks in advance.

MIKHAIL

Newbie

Posts

Joined
Wed Mar 25, 2015 8:17 pm

Post by xxvirusxx » Sun Jun 28, 2020 3:36 am

mikhailjb wrote:
Sun Jun 28, 2020 12:41 am
Where do I even beging with this?
Who knows what errors you have?

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by johnp » Sun Jun 28, 2020 10:04 pm

Journal theme. I'll get me coat. Lol. :)

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by JNeuhoff » Sun Jun 28, 2020 10:41 pm

The upgrade will almost certainly not work, especially not with Journal.

It's easier just to do a fresh install of the new version of OpenCart, and then migrate your products over to the new server via e.g. the Export/Import tool (see our FAQ page). And do yourself a favor and install a proper web theme, not Journal!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by litextension » Mon Jun 29, 2020 10:25 am

Hello @Mikhail
We do believe it's a lot easier for you to upgrade your store by first create a fresh install of the new version of OP, then transfer all the data from your old store. And in the data migration process, you could definitely use our automated tool to securely and accurately migrate your data. We also provide advanced additional options like SEO Url migration, Custom field migration, and more to fully help you in every task of the project. Learn how to migrate your data with us in this video: https://www.youtube.com/watch?v=x2WC8JyAJVs

LitExtension - Shopping Cart Migration Expert
Visit us at: https://litextension.com


User avatar
New member

Posts

Joined
Wed Aug 03, 2016 4:22 pm

Post by xxvirusxx » Mon Jun 29, 2020 4:02 pm

litextension wrote:
Mon Jun 29, 2020 10:25 am
Learn how to migrate your data with us in this video: https://www.youtube.com/watch?v=x2WC8JyAJVs
Learn? :laugh:
Maybe Pay

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Taylorsy » Mon Aug 10, 2020 2:30 pm

Everything seems to work well, I have installed the plugin and it seems to be working. Then, I have released an update using the code-push CLI, and when I open the app again, I receive the update in the alert.

The first update seems to work well, the app restarts and code changes seem to have applied successfully.

However, when I update again, and send a new release, I receive the update in the app, but when the plugin tries to restart the app, a white screen appears and the app breaks. When I restart the app manually, code changes are not applied, and the update does not trigger again. If I check the updates in the devices with the code-push cli

Newbie

Posts

Joined
Mon Aug 10, 2020 2:14 pm

Post by khnaz35 » Mon Aug 10, 2020 3:49 pm

Taylorsy wrote:
Mon Aug 10, 2020 2:30 pm
Everything seems to work well, I have installed the plugin and it seems to be working. Then, I have released an update using the code-push CLI, and when I open the app again, I receive the update in the alert.

The first update seems to work well, the app restarts and code changes seem to have applied successfully.

However, when I update again, and send a new release, I receive the update in the app, but when the plugin tries to restart the app, a white screen appears and the app breaks. When I restart the app manually, code changes are not applied, and the update does not trigger again. If I check the updates in the devices with the code-push cli
Does anybody understand what this person is trying to say or to do? :crazy: :crazy: ??? ::)

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by JNeuhoff » Mon Aug 10, 2020 4:20 pm

Taylorsy wrote:
Mon Aug 10, 2020 2:30 pm
Everything seems to work well, I have installed the plugin and it seems to be working. Then, I have released an update using the code-push CLI, and when I open the app again, I receive the update in the alert.

The first update seems to work well, the app restarts and code changes seem to have applied successfully.

However, when I update again, and send a new release, I receive the update in the app, but when the plugin tries to restart the app, a white screen appears and the app breaks. When I restart the app manually, code changes are not applied, and the update does not trigger again. If I check the updates in the devices with the code-push cli
Could you please explain what you are talking about? And what OpenCart extensions you are using? The OpenCart terminology doesn't know about plugins, it's called extensions. And while OpenCart does have PHP scripts for updating the server, it most cases it won't work.

CodePush normally is an App Center cloud service that enables Apache Cordova and React Native developers to deploy mobile app updates directly to their users' devices. This has nothing to do with OpenCart.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 10 guests