Post by WavMixer » Sun Aug 09, 2020 9:48 am

I have OC 2.3.0.2 installed and it has been working great! The current version of PHP is 5.6. Can I upgrade the site to 7.4 without running into any problems? I'm using the default theme and several aftermarket extensions.

User avatar
New member

Posts

Joined
Sun Feb 23, 2014 3:15 am


Post by IP_CAM » Sun Aug 09, 2020 11:29 am

You need to replace the OC Default system/library/encryption.php
file with the one linked below, that's all it usually takes:
https://github.com/IP-CAM/Opencart_2302 ... em/library
And when it comes to the Extensions installed, you will find out, I guess! :laugh:
But usually, they should work, if you don't use something really special.
Cross-check the content of Condor2's updated Github Version 2.3.0.2 with yours,
and you probably find some fixes, which also could be included in your stock 2.3.0.2,
just to make sure, to have what it's Creator CONDOR2 (xxvirusxx) found and changed
on misses. ;)
https://github.com/condor2/Opencart_2302
Good Luck!
Ernie
(Edited)
Last edited by IP_CAM on Mon Aug 10, 2020 3:31 am, edited 2 times in total.

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by xxvirusxx » Sun Aug 09, 2020 9:04 pm

That repo was removed from my github account.
I have only this version

https://github.com/condor2/Opencart_2302

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by EvolveWebHosting » Sun Aug 09, 2020 9:24 pm

WavMixer wrote:
Sun Aug 09, 2020 9:48 am
I have OC 2.3.0.2 installed and it has been working great! The current version of PHP is 5.6. Can I upgrade the site to 7.4 without running into any problems? I'm using the default theme and several aftermarket extensions.
Without knowing the extensions you're using, I would suggest trying PHP 7.2

You can change the PHP version and thoroughly test your site without the need to backup before doing so. If it doesn't work, you can bump down to a lower version.

Image
Hosting and Domain Specials until 01/01/2021 https://www.evolvewebhost.com/blog/blac ... riday_2020
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: No registered users and 7 guests