Post by abboodeh » Sat Sep 19, 2020 5:10 am

Hi

My site goes down from time to time, the server is fine i have other sites hosted they're almost up all the time, i contacted my hosting and they told me MAX_children limit reached 30

They recommended me to implement caching so that number of connections handled by Apache + php-fpm will be less



How to resolve this....is there any module that can help me in my issue?

New member

Posts

Joined
Sat Aug 06, 2016 7:48 pm

Post by rjcalifornia » Sat Sep 19, 2020 6:00 am

abboodeh wrote:
Sat Sep 19, 2020 5:10 am
Hi

My site goes down from time to time, the server is fine i have other sites hosted they're almost up all the time, i contacted my hosting and they told me MAX_children limit reached 30

They recommended me to implement caching so that number of connections handled by Apache + php-fpm will be less



How to resolve this....is there any module that can help me in my issue?
There are many possible reasons why yoy are reaching the max_children. Some are:

-A lot of parallel requests from your clients
-Slow execution of the PHP scripts
-Very low setting of the max_children

What are your server specifications?

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by OSWorX » Sat Sep 19, 2020 11:22 am

When you talk about "my Server".
Does mean what?
Shared, V-Server, root, managed, owned by yourself?
And how many sites do you have on this "server?
If not owned by you, how many other users are on this server?

Tell us more about the environement:
* Hardware
* Software

Next:
* which OpenCart Version
* which Template
* how many Categories
* how many Products
* which Extensions are installed additionally

You see, not so easy to give you a correct answer without these details!

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by abboodeh » Sat Sep 19, 2020 7:03 pm

Thanks for your replay, i'm using VPS
CPU 2 Core
RAM 4 GB
SSD Cloud Storage 80 GB
Bandwidth 4TB

I'm hosting my main opencart site, and another 2 sites with almost no traffic...inactive sites..
my main site is using an integration with Ebay, with mobile app, with POS system for my physical shops...too many things.

My OC version is 2.2

New member

Posts

Joined
Sat Aug 06, 2016 7:48 pm

Post by abboodeh » Sat Sep 19, 2020 7:09 pm

Tell us more about the environement:
* Hardware
* Software

Next:
* which OpenCart Version 2.2
* which Template Journal 2
* how many Categories 9
* how many Products enabled almost 200, enabled+disabled around 1,000
* which Extensions are installed additionally Mobile app Android & Ios, POS, ebay, SEO Backpack, facebook cataloge

New member

Posts

Joined
Sat Aug 06, 2016 7:48 pm

Post by OSWorX » Sun Sep 20, 2020 1:34 am

Well, those entries are for sure not the reason why you got that error.

But .... you are using one of the most worst "Templates" on that planet.
Ever tried the shop with the default?

And what about updating to OpenCart 2.3.0.2 - which is still one of the best versions?
Finally, ever checked the apache log - what's in there?

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by p419 » Sun Sep 20, 2020 1:44 am

abboodeh wrote:
Sat Sep 19, 2020 7:09 pm
Tell us more about the environement:
* Hardware
* Software

Next:
* which OpenCart Version 2.2
* which Template Journal 2
* how many Categories 9
* how many Products enabled almost 200, enabled+disabled around 1,000
* which Extensions are installed additionally Mobile app Android & Ios, POS, ebay, SEO Backpack, facebook cataloge
I'm running almost identical server specs, the Journal template with 300 categories and almost 2000 products and have no issues, I doubt very much it's a Journal issue!

Regards,

Paul


New member

Posts

Joined
Tue Nov 27, 2018 2:01 am
Location - Toronto

Post by straightlight » Sun Sep 20, 2020 1:49 am

p419 wrote:
Sun Sep 20, 2020 1:44 am
abboodeh wrote:
Sat Sep 19, 2020 7:09 pm
Tell us more about the environement:
* Hardware
* Software

Next:
* which OpenCart Version 2.2
* which Template Journal 2
* how many Categories 9
* how many Products enabled almost 200, enabled+disabled around 1,000
* which Extensions are installed additionally Mobile app Android & Ios, POS, ebay, SEO Backpack, facebook cataloge
I'm running almost identical server specs, the Journal template with 300 categories and almost 2000 products and have no issues, I doubt very much it's a Journal issue!
Which PHP version?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by OSWorX » Sun Sep 20, 2020 4:29 am

p419 wrote:
Sun Sep 20, 2020 1:44 am
.. I doubt very much it's a Journal issue ..
Then it must be a BUIFOTS ..

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by abboodeh » Mon Sep 21, 2020 3:00 am

i honestly doubt it's the template, i've been using the template for over 2 years now, i think it's my modules the ebay thing...the mobile app which is mirroring my site..., i would like to try some caching modules because the problem is just recently appeared, but i don't know where to start or which one would be my perfect option...

to upgrade from my current version, that would be too much work...i'm really not free for it now...

New member

Posts

Joined
Sat Aug 06, 2016 7:48 pm

Post by rjcalifornia » Thu Sep 24, 2020 9:24 am

p419 wrote:
Sun Sep 20, 2020 1:44 am
I'm running almost identical server specs, the Journal template with 300 categories and almost 2000 products and have no issues, I doubt very much it's a Journal issue!
Journal has some bugs. I suggest you to disable the theme and also all third-party extensions/modules until you find the one that is giving you issues. I suggest that because you say you almost have the same set up in another place, so that would be the first place to look

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide
Who is online

Users browsing this forum: No registered users and 7 guests