Post by niranjan528 » Sat Mar 24, 2018 7:56 pm

Hi all,
am getting this error while selecting extension => modules drop down , please help me please find attached image

Fatal error: Cannot redeclare k27e20f9f() (previously declared in /home/dezqkscy1ubl/public_html/admin/language/en-gb/extension/module/so_basic_products.php:1) in /home/dezqkscy1ubl/public_html/admin/language/en-gb/extension/module/so_basic_products.php on line 1

Attachments

modeule.png

modeule.png (22.2 KiB) Viewed 1201 times


New member

Posts

Joined
Sat Jun 27, 2015 6:48 pm

Post by straightlight » Sat Mar 24, 2018 8:16 pm

No OC version posted. Issue reported caused by an installed extension.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by niranjan528 » Sat Mar 24, 2018 8:20 pm

Installed module is uninstalled and removed all files , even thought am getting error .

New member

Posts

Joined
Sat Jun 27, 2015 6:48 pm

Post by thekrotek » Sat Mar 24, 2018 8:48 pm

Maybe you need to update the cache as well. Maybe you need to remove that language file, mentioned in error.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by straightlight » Sat Mar 24, 2018 9:06 pm

The cache wouldn't provide a re-declared error message, in this case. Line 1 of the file could also be related to a corrupted header file due to invalid file structure. Uploading the file in UTF-8 without BOM could be another solution.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Sun Mar 25, 2018 1:33 am

straightlight wrote:
Sat Mar 24, 2018 9:06 pm
The cache wouldn't provide a re-declared error message, in this case. Line 1 of the file could also be related to a corrupted header file due to invalid file structure. Uploading the file in UTF-8 without BOM could be another solution.
Has nothing to do with BOM, it's a strictly language file issue. Language file contains a k27e20f9f() function, which is being redeclared multiple times, when language file is loaded.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by niranjan528 » Sun Mar 25, 2018 2:24 am

Now its working , removed the error language file then its works...Thank you so much .....

New member

Posts

Joined
Sat Jun 27, 2015 6:48 pm
Who is online

Users browsing this forum: No registered users and 8 guests