Post by handarbetsboken » Sun Jul 01, 2018 5:58 pm

Hi.

I please need some help to install vqmod, i haved tried everything...but it will not work.

I have downloaded a zip file, and unzipped it, put the vqmod-folder in my root-directory.
Changed index-files x 2 and vqmod-folder to 775 and also tried 777.
Also tried to install vqmod manually by editing som files (read some guides on internet).

But still it will not work...
Please, can someone help me??
Hopefully it is an easy problem to solve for someone who is good at opencart.

Regards Sofi


Posts

Joined
Sat Jun 30, 2018 6:33 pm

Post by xxvirusxx » Sun Jul 01, 2018 6:10 pm

Open in a browser:

Code: Select all

http://your-website/vqmod/install

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by handarbetsboken » Sun Jul 01, 2018 6:15 pm

Hi.
Get error when typing that in my browser.
http://handarbetsboken.se/vqmod/install
Have spoken to Loopia where i have my serve/webhotel but they cant help.
Regards Sofi


Posts

Joined
Sat Jun 30, 2018 6:33 pm

Post by xxvirusxx » Sun Jul 01, 2018 6:43 pm

If vqmod folder is exactly on the same location as opencart files then is something else.

Try with .httacces disabled or .enabled.

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by OSWorX » Sun Jul 01, 2018 6:54 pm

handarbetsboken wrote:
Sun Jul 01, 2018 5:58 pm
I please need some help to install vqmod, i haved tried everything...but it will not work.

I have downloaded a zip file, and unzipped it, put the vqmod-folder in my root-directory.
Changed index-files x 2 and vqmod-folder to 775 and also tried 777.
Very bad idea to change such to 0777 > hight security risk!
Change them back to 0755 asap.
handarbetsboken wrote:
Sun Jul 01, 2018 5:58 pm
Also tried to install vqmod manually by editing som files (read some guides on internet).
Next bad idea, editing some files based on obscure suggestions from the net is never a good idea!

Basically I have to ask, what for do you need VQMod?
You have the shop in version 2.x, you have already everything you need to install extensions (= OCMod) on board.
And if an extension for 2.x still needs VQMod, forget it!

Next, as xxvirusxx mentioned, maybe some issue with an enabled .htaccess?
Could be also, that the permissions are in general wrong set - have you checked them already?
And finally, did you copy the vqmod folders and files into to correct directory?

I guess, you will need an expert if you are not able to install such an easy to install extension (only call the install url).

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by straightlight » Sun Jul 01, 2018 9:21 pm

In addition to the above, ensure that the changed permissions takes effect recursively. The best place to make permission changes to your folders would be in your Host's File Manager console. As for your language error file, in your catalog/model/localisation/language.php file, find:

Code: Select all

$language_data = $this->cache->get('language');

replace with:

Code: Select all

$language_data = $this->cache->get('catalog.language');
As for the cache files, replace your system/library/cache/file.php file with this one: https://github.com/opencart/opencart/bl ... e/file.php

Lastly, not to forget to apply these steps: viewtopic.php?f=176&p=727490#p718325

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Mon Jul 02, 2018 6:23 am

handarbetsboken wrote:
Sun Jul 01, 2018 6:15 pm
Hi.
Get error when typing that in my browser.
http://handarbetsboken.se/vqmod/install
Have spoken to Loopia where i have my serve/webhotel but they cant help.
Regards Sofi
Well, you probably just downloaded the wrong VqMod, if your VqMod Extension
does not include an install/ routine, as it looks.
But better never play around with CHMOD Settings, if you don't
know, how the default settings have to be, to make it work as secure
as possible.
Good Luck!
Ernie
---
v2.6.3-opencart
https://github.com/vqmod/vqmod/releases
---

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 10 guests