Post by SpannerMagnet » Sun Nov 25, 2018 7:07 am

Hi guys, I set up OpenCart 1.5.4 for a friend a few years ago. The web host has recently informed us that PHP 5.6 is going to expire soon and that we need to move to PHP 7.2. is OpenCart 1.5.4 compatible with PHP 7.2? Is there a way of making it work?

Newbie

Posts

Joined
Thu Dec 06, 2012 7:55 pm

Post by IP_CAM » Sun Nov 25, 2018 8:46 am

You might find an answer to this here:
http://forum.opencart.com/viewtopic.php?f=199&t=208476

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SpannerMagnet » Sun Nov 25, 2018 6:09 pm

Thanks for the quick response, Ernie!

So, in theory I should only need to complete the following steps?

1 - update the encryption.php file
2 - update the bcrypt.php file
3 - install "Mysqli for Opencart 1.5.x" extension

Newbie

Posts

Joined
Thu Dec 06, 2012 7:55 pm

Post by IP_CAM » Sun Nov 25, 2018 10:45 pm

Well, it might also depend on some extensions, but the other fellow
made it work this way. And I so far only found that file/image-editor,
unable to further do it's job, as it comes by default. But you won't be
able, to destroy anything by trying, so, just go ahed! :D
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SpannerMagnet » Mon Nov 26, 2018 7:45 pm

That worked a treat, Ernie. Thanks so much!

Newbie

Posts

Joined
Thu Dec 06, 2012 7:55 pm

Post by SpannerMagnet » Fri Oct 23, 2020 2:38 pm

I've been informed that the web host is updating its version of PHP from 7.2 to 7.4:
The PHP version of your web space will soon be updated from version 7.2 to the latest stable version, which is currently version 7.4. The reason for the update is that PHP version 7.2 will reach end of life on 30 November 2020.
Will the changes made previously work with 7.4? Do I need to make any further amendments?

Newbie

Posts

Joined
Thu Dec 06, 2012 7:55 pm

Post by IP_CAM » Fri Oct 23, 2020 4:12 pm

Do I need to make any further amendments?
I don't think so.

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SpannerMagnet » Fri Oct 23, 2020 5:09 pm

Thanks again! :)

Newbie

Posts

Joined
Thu Dec 06, 2012 7:55 pm

Post by OSWorX » Fri Oct 23, 2020 5:38 pm

SpannerMagnet wrote:
Fri Oct 23, 2020 2:38 pm
I've been informed that the web host is updating its version of PHP from 7.2 to 7.4:
The PHP version of your web space will soon be updated from version 7.2 to the latest stable version, which is currently version 7.4. The reason for the update is that PHP version 7.2 will reach end of life on 30 November 2020.
Will the changes made previously work with 7.4? Do I need to make any further amendments?
If you want to use php 7.4.x you may encounter other problems!
E.g. mostly all operations with arrays and where are values used not check before if they really exist.
Also some notices about integer values, etc. ..

Better you try your installation before in a testshop with php 7.4..x

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by IP_CAM » Fri Oct 23, 2020 7:55 pm

Well, I'm not sure about OC v.1.5.4 Versions, but my 1.5.6.5_rc works
well so far with PHP v.7.4.11 ...

Code: Select all

<?php
echo 'Current PHP version: ' . phpversion();
?>
Image

Attachments

php_version.png

php_version.png (14.61 KiB) Viewed 324 times


Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by johnp » Sat Oct 24, 2020 6:38 am

I would suggest an upgrade to 1.5.6.5 if you don't have too much customization on you 1.5.4. As Ernie has pointed out it works fine with PHP 7 with the new encryption file. I've got several 1.5.6.5 based sites using PHP 7.4.
Last edited by johnp on Sat Oct 24, 2020 6:27 pm, edited 1 time in total.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Sat Oct 24, 2020 9:22 am

johnp wrote:I would suggest an upgrade to 1.5.6.5 if you don't have too much customization on you 1.5.4 .....
... and if so, then, at best download this updated, but otherways 'virgin' 1.5.6.5_rc Release,
still equipped with the 1.5.6.4-type non-responsive OC Theme.
https://github.com/IP-CAM/Opencart-1.5. ... se-Version
You could then get a responsive Theme, one like shown here, i.E. the
OC Bootstrap Pro - Bootstrap 3 theme with options:
https://www.opencart.com/index.php?rout ... _license=0
JohnP's favoured OC v.1.5.6.x Bootstrap Theme Extension, :D, to have it fully responsive as well,
including a bunch of very useful free Mods. ;)
---
The OC Download linked has been updated already, to fix some (int) - security related finding,
and it contains a system/library/encryption.php file, able to handle up to PHP v.7.4.11 so far.
---
And if you like the most efficient 1.5.6.x VqMod-Version ever created, MaxD's unique VqMod PRO 2.6.1
works perfect with this Version. In contrary to 'regular' VqMod, it creates the whole bunch of
cached vqmodded Files, instead of waiting, until some Routine, to be modified, is called on
some Page the first time. This way, It saves overall (first) loading time on not yet called pages
too, in addition to so find potential Code-Problems or Misses in VqMods, before they ACT in real.

And it only presents a minor Error message, if it's own cache-clear function 'timewise' collides
with similar maual functions/operations from VqMod Editors and so ..., but only once in a while,
probably just to demonstrate, that it works .... :laugh:
--
Can be downloaded momentarely here from not yet blocked IP-Numbers ... ;)
http://www.ipc.li/os/vqmodpro.zip
---
More info about it here:
viewtopic.php?f=183&t=160997
---
Also download something like this, it add's very much to Admin Access Security:
https://www.opencart.com/index.php?rout ... n_id=21371
---
cache remove One of the free Admin Tools , to clean out Cache manually:
https://www.opencart.com/index.php?rout ... n_id=18823
---
And please use this highly efficient DB Cache System:
https://www.opencart.com/index.php?rout ... n_id=25388
---
301 Redirect Pages For OpenCart to re-link Intruder Attempts to Hell for good... 8)
on my Sites, to Las Vegas :laugh:
https://www.opencart.com/index.php?rout ... n_id=25864
---
and one of those, to compress your Output Content:
https://www.opencart.com/index.php?rout ... n_id=25615
https://www.opencart.com/index.php?rout ... n_id=36607
---
and check here, to find another great little speed-up-Gizmo, beeing part of all my Test Installs, It
caches Category Counting very efficiently:
viewtopic.php?t=203186
---
and you're quite ready, to have, what it takes, to compete with a very efficient OpenCart Instument. ;)
All it then still takes, is to rewrite some config.php Links, and some links in the Theme
Header File, to make your Images, CSS Styles and Scripts 'cookiefree', and then you're all set, to go.
Find some infos on this somewhere here, I forgot, where it's placed, just search for it ...

Good Luck ;)
Ernie

Attachments

updated_oc_1565_rc_download_source.png

updated_oc_1565_rc_download_source.png (66.99 KiB) Viewed 252 times


Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 11 guests