Post by techtools » Mon Jan 12, 2015 1:26 pm

This seems to be a common issue in OC 2 (all versions)


I have read all messages in forums in relation to this and attempted fix and yet still no results.

Has anyone found any solution?

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by melbagnato » Mon Jan 12, 2015 1:28 pm

Hi techtools,

can you provide more info (and a screenshot) and I'll take a look for you.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by techtools » Mon Jan 12, 2015 4:00 pm

This is exactly what I am getting too and none of teh suggestions have helped.

http://forum.opencart.com/viewtopic.php?f=181&t=133490

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by melbagnato » Tue Jan 13, 2015 12:14 pm

If somone posts what the exact set up is (OC version & extensions) and lists the steps that recreate this bug, I'll take a look and let you know the fix.

It sounds like a malformed JSON transaction, so should be pretty straight forward to bug fix.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by techtools » Tue Jan 13, 2015 2:09 pm

OC 2.0.1

Standard Store
No new extensions.

Step 1. Modify Orders (as per previous image)

(nothing has been modified. It was working fine and then that error occurred.)

Have followed every solution that has been suggested in the forums from previous store owners who receive the identical issue such as checking the API key in PHPadmin.

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by melbagnato » Wed Jan 14, 2015 7:26 am

I'll get on to it this afternoon (Melbourne/Australia Time).

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by techtools » Fri Jan 16, 2015 7:48 am

Thank you. How did you go?

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by melbagnato » Fri Jan 16, 2015 11:13 am

One two different servers I couldn't replicate the issue. Am trying on a third one today.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by techtools » Sun Jan 18, 2015 8:32 am

someone else thinks this may be the cause



Re: SyntaxError: JSON.parse: unexpected end of data at line

Postby cornernote » 16 Jan 2015, 03:51
Another reason this can occur is if your host is running mod_security. If this is the case you will have to contact them and ask they disable it for your account.

Just spent the last few hours debugging to find this. Hope it helps someone.

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by techtools » Sun Jan 18, 2015 8:56 am

btw

tried disabling and still get SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data OK


when trying to change status on order

New member

Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by ayrton » Sun Jan 18, 2015 4:27 pm

i have the same problem
standar installation..no external modules
i cannot edit or delete an order
i get this message
SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

OK
My server is host1plus

Any solution?
Thanks

Newbie

Posts

Joined
Thu Sep 13, 2012 5:14 pm

Post by opencarthow.com » Sun Jan 18, 2015 6:03 pm

ayrton wrote:i have the same problem
standar installation..no external modules
i cannot edit or delete an order
i get this message
SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

OK
My server is host1plus

Any solution?
Thanks
You can try this solution first.
It the prblem is still there, feel free to contact me and provide your site url, a admin account and a FTP account via PM, so I can fix it for your site.

Our free extensions:
Advanced Layout System, Display Raw Product Description in Product List, Minimum Order Amount Requirement, Add to Wish List Redirect for Anonymous Customer


User avatar
Active Member

Posts

Joined
Fri Nov 28, 2014 10:41 am


Post by melbagnato » Sun Jan 18, 2015 11:14 pm

If anyone is willing to provide temporary FTP access to a server with this issue, I'll take a look. I can't replicate it on my current hosts.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by melbagnato » Mon Jan 19, 2015 12:20 am

Testing a site now, getting this error:

Code: Select all

DOMException: Failed to execute 'querySelectorAll' on 'Document': 'select[name='store_id'] option:selected' is not a valid selector.
a: "select[name='store_id'] option:selected
I'll keep debugging.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by Ma3TiN » Tue Jan 20, 2015 6:57 pm

melbagnato wrote:Testing a site now, getting this error:

Code: Select all

DOMException: Failed to execute 'querySelectorAll' on 'Document': 'select[name='store_id'] option:selected' is not a valid selector.
a: "select[name='store_id'] option:selected
I'll keep debugging.

- Mel
any luck? :)

Newbie

Posts

Joined
Wed Jan 14, 2015 11:45 pm

Post by tallrabbit.co.uk » Mon Mar 16, 2015 3:06 am

Hi there,
Did anyone get this resolved?


Posts

Joined
Mon Mar 16, 2015 3:05 am

Post by msbree » Wed Apr 29, 2015 4:44 am

Has this issue been resolved yet? I have wasted 2 entire days searching for help....nothing!

I am using 2.0.2.0.

PLEASE help, someone! I am NOT OpenCart file tech savvy, so please provide 'baby step' fix please!
thank you!

Newbie

Posts

Joined
Mon Apr 27, 2015 8:08 pm

Post by npn2531 » Sat May 23, 2015 3:31 am

Yes, I am getting the same issue with 2.0.2.0. Everything works just fine, and then all of sudden this issue starts. It has happened twice in the last few days, and the only way I have been able to fix it, is to restore the site from the last daily backup. Which of course, means I lose a days work.

Code: Select all

SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

http://www.niora.com


New member

Posts

Joined
Tue May 19, 2009 11:56 am

Post by sunrisephp » Fri Jun 12, 2015 8:16 am

i also have the same problem
standar installation..no external modules Version 2.0.1.1
i cannot edit or delete an order
i get this message
SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

OK
My server is siteground.eu

any suggestion?

Has anyone found a "real" solution for this because I tried all that was suggested but they don't work. From changing the api_id to making a secondary API. And even the .htaccess method. & https://

New member

Posts

Joined
Fri Sep 07, 2012 4:05 pm
Who is online

Users browsing this forum: No registered users and 10 guests