Post by vikki » Tue Nov 01, 2016 2:28 am

Hi,

I am trying to enable SEO URLs for open cart. I am running my website from addon domain. I have added the following .htaccess file to the root directory public_html/mystore.com. Then enabled SEO urls in setting. Home page loads fine. When i click ipod classic I am getting 500 internal server error. I have contacted my host and they said some redirect loop is happening in the code fix your htacess file. I am not sure how to fix it. Please help. I have .htaccess file in the admin folder also not sure if this will cause some issue

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

 Options +FollowSymlinks

# Prevent Directoy listing
 Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
# Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /mystore.com/
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

# 404 Page
 ErrorDocument 404 /404.shtml
I have spend close to 10 hrs in google no luck. Your help is really appreciated

Newbie

Posts

Joined
Sat Mar 10, 2012 8:29 am

Post by EvolveWebHosting » Tue Nov 01, 2016 8:06 am

Try this:

#Options +FollowSymlinks

Image
50% Off SSD Shared Hosting w/ cPanel
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by web-project » Tue Nov 01, 2016 7:45 pm

change the following:

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

 Options +FollowSymlinks

# Prevent Directoy listing
 Options -Indexes
to

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

#Options +FollowSymlinks

# Prevent Directoy listing
#Options -Indexes

New member

Posts

Joined
Tue Sep 06, 2016 9:06 pm
Location - Stevenage, UK

Post by artcore » Tue Nov 01, 2016 8:05 pm

I wouldn't recommend disabling this: Options -Indexes as everyone will be able to browse the folder contents.

Vikki, please check the error_log in your site root or apache logs to see why the server halts!

Attn: I no longer provide OpenCart extensions, nor future support - this includes forum posts.
Reason: OpenCart version 3+ ;D

Thanks!


User avatar
Active Member

Posts

Joined
Tue Jul 09, 2013 4:13 am
Location - The Netherlands

Post by vikki » Wed Nov 02, 2016 2:11 am

Thanks everyone for the reply. I changed this

RewriteBase /mystore.com/

to

RewriteBase /

It worked

Newbie

Posts

Joined
Sat Mar 10, 2012 8:29 am
Who is online

Users browsing this forum: No registered users and 29 guests