Post by zionhealth » Tue Mar 19, 2019 8:24 am

Trying to narrow down an issue with our Opencart v2.3.0.2 site. We've enabled the Free Shipping module and set the amount to 30.00. We received an order over the weekend for 25.99, and the customer received Free shipping. There were 5 products on the order, none of which had free shipping specified in the product itself. There were no coupons used . The only thing I noticed was that one of the products was on special. Normally price at 3.99, and on sale for 1.00. Could it be that the free shipping calculation was based on the regular price of the item, instead of the sale price that the customer paid?

New member

Posts

Joined
Tue Oct 18, 2016 8:12 am

Post by kestas » Tue Mar 19, 2019 3:08 pm

zionhealth wrote:
Tue Mar 19, 2019 8:24 am
Could it be that the free shipping calculation was based on the regular price of the item, instead of the sale price that the customer paid?
By default NO. Free shipping calculating on the special price and with tax if your goods are taxable.

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by Johnathan » Tue Mar 19, 2019 9:48 pm

Check your currency settings. If they used a non-default currency, then the 30.00 value would be converted into that currency, which could have triggered the free shipping threshold.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by zionhealth » Thu Mar 21, 2019 4:53 am

Thanks for the suggestions. We do have USD, Euro and British Pound enabled, but we rarely get orders in any currency other than USD. This particular order was USD.

New member

Posts

Joined
Tue Oct 18, 2016 8:12 am

Post by Johnathan » Thu Mar 21, 2019 10:34 pm

Double-check to make sure that USD is set to 1.00000. If not, it could be why the total value you entered isn't working.

If that checks out, I'm not sure then. It sounds like you have everything set up correctly, so the only thing I'd suggest is trying to reproduce the cart and see if you get the same result. If you do, it's probably either a mod you've installed, or a bug in OpenCart, or a setup issue. If you can't reproduce it, then it could be a one-off thing, or somehow they learned how to hack free shipping to be applied. I don't know of a way to do that, but I suppose it might be possible.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by kestas » Fri Mar 22, 2019 12:52 am

Johnathan wrote:
Thu Mar 21, 2019 10:34 pm
I suppose it might be possible.
If you are not able to do it by yourself, you can hire someone here in commercial support forum.

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am
Who is online

Users browsing this forum: No registered users and 19 guests