Post by Corobori » Fri Sep 04, 2020 9:57 pm

Hi,

I am having an issue with a payment method (Webpay, the most popular online payment method in Chile, not difficult when you are the only one offering that service) in my website. It is not working when using Chrome, well not always, most of the time it fails but I can't figure out why !! I have read similar reports and contacted the plugins' support but no answer so far.

It works fine with Firefox. Can anybody try it from their side to see if you can go thru a payment using Chrome ?.
I would appreciate if you can have a got at it and let me know if you're going thru fine or if the payment fails and the order ends up with status "Missing orders"

I just setup a shop from scratch here www.corobori.tienda/joyas

Steps to reproduce the issue:
1 ) Go to www.corobori.tienda/joyas
2 ) Add any item to the cart
3 ) Go to check out
4 ) Input any customer data
5 ) In payment method choose "Pago con Tarjetas de Crédito o Redcompra" (Here you can see the 1st issue: the logo doesn't come up, I reported it but still no answer)
6 ) Then click "Continuar a Webpay"

7 ) You should see a screen like this
Image
Choose "Tarjeta de Credito"

8 ) Then on this screen
Image
Enter in the card number this value 4051885600446623
Any date and 123 for CCV
Then click "Continuar"

9 ) On this screen
Image
Just leave it like it is an click "Continuar"

10 ) On this screen
Image
Enter the following information
Rut: 11.111.111-1
Clave: 123

11 ) On this screen
Image
Just click "Continuar"

12 ) And if things are fine you should see this
Image

13 ) But most of the time (not always !!!) in Chrome I am getting this
Image

If somebody has some spare time (!) and wants to go further and trying testing the plugin it is here and instructions are [urlhttps://www.transbankdevelopers.cl/plugin/opencart/#]here[/url].

Thank you

Newbie

Posts

Joined
Fri May 15, 2020 10:08 am

Post by letxobnav » Fri Sep 04, 2020 10:14 pm


Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Corobori » Fri Sep 04, 2020 10:52 pm

Indeed it could be, I applied those changes and it seems to be working.

Update: thank you @letxobnav it appears that applying the changes you pointed to in your post made my day or even more.

Newbie

Posts

Joined
Fri May 15, 2020 10:08 am
Who is online

Users browsing this forum: No registered users and 7 guests