Post by Caesium » Thu Nov 14, 2019 10:38 pm

I upgraded my site and it's failed spectacularly.

I now get this:

Warning: Use of undefined constant DIR_STORAGE - assumed 'DIR_STORAGE' (this will throw an Error in a future version of PHP) in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/startup.php on line 70 Fatal error: Uncaught Exception: Error: Table 'violets_hertfor.vs_translation' doesn't exist
Error No: 1146
SELECT * FROM vs_translation WHERE store_id = '0' AND language_id = '0' AND (route = 'engb' OR route = '') in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/library/db/mysqli.php:40 Stack trace: #0 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/library/db.php(45): DB\MySQLi->query('SELECT * FROM v...') #1 /customers/a/c/e/violets-hertford.com/httpd.www/shop/catalog/model/design/translation.php(6): DB->query('SELECT * FROM v...') #2 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/engine/loader.php(248): ModelDesignTranslation->getTranslations('engb') #3 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/engine/proxy.php(47): Loader->{closure}(Array, Array) #4 /customers/a/c/e/violets-hertford.com/httpd.www/shop/catalog/controller/event/translation.php(6): Proxy->__call('getTranslations', Array) #5 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/engi in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/library/db/mysqli.php on line 40

It initially looked like it worked okay but then crashed and burned. Any ideas?

I did back it up but the restore didn't help.

Newbie

Posts

Joined
Thu Dec 12, 2013 6:02 pm

Post by Caesium » Thu Nov 14, 2019 10:51 pm

I need to get all of my product data out of the database to store elsewhere and can't unless i can get opencart running again so any help would really be appreciated

The install process worked to start with, then failed.

Now I get this on the /install
Fatal error: Uncaught TypeError: Argument 2 passed to Event::trigger() must be of the type array, string given, called in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/storage/modification/system/engine/loader.php on line 119 and defined in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/engine/event.php:59 Stack trace: #0 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/storage/modification/system/engine/loader.php(119): Event->trigger('language/en-gb/...', 'en-gb') #1 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/framework.php(136): Loader->language('en-gb') #2 /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/startup.php(104): require_once('/customers/a/c/...') #3 /customers/a/c/e/violets-hertford.com/httpd.www/shop/install/index.php(41): start('install') #4 {main} thrown in /customers/a/c/e/violets-hertford.com/httpd.www/shop/system/engine/event.php on line 59

Newbie

Posts

Joined
Thu Dec 12, 2013 6:02 pm

Post by Caesium » Fri Nov 15, 2019 12:34 am

So I managed to reinstall a fresh version of opencart and move the DB files over for the products and it looked like I could get access to my data again.

When I entered the admin part of the shop there was a bloody annoying popup that said about moving the storage folder. I (unfortunately) clicked move and it's fucked it all up again!

This is such a pile!!!

Newbie

Posts

Joined
Thu Dec 12, 2013 6:02 pm
Who is online

Users browsing this forum: OSWorX and 9 guests