Post by JetAMC » Sat Apr 18, 2020 2:17 am

Hi guys! I'm installing clean opencart to my server, and have several errors. Opencart version: 3.0.3.2, PHP version: 7.4.4.

1. First error appears when i try to checkout, when i'm on tab "billing details" errors: (fopen, fwrite(), flock(), fflush(), fclose(), permission denied)

Code: Select all

expects parameter 1 to be resource, bool given in ... \system\library\cache\file.php</b> on line <b>57</b>
And fopen:

Code: Select all

/system/storage/cache/cache.catalog.language.1587150311
. After those errors "Region / State" field is blank and i can't choose address, text appears there only when i'm changing "Country" field.

2. Second error when i'm trying to "confrim order", it's SMTP error, looks like:

Code: Select all

mail(): SMTP server response: 554 5.7.1, Relay access denied in system\library\mail\mail.php</b> on line <b>77</b>
So i already tried to change permission of folders and files to 755, and cleaning cache in admin panel. Problem was not solved, and error is still showing. I also tried to change "file.php" like in this topic: viewtopic.php?f=176&p=733002#p718325 but it doesn't work for me. Can someone help me? Thank you.

Newbie

Posts

Joined
Sat Apr 18, 2020 1:59 am

Post by straightlight » Sat Apr 18, 2020 3:07 am

For the catalog.language issue, see this FAQ: viewtopic.php?f=134&t=215776#p750077 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by JetAMC » Sat Apr 18, 2020 4:37 am

straightlight wrote:
Sat Apr 18, 2020 3:07 am
For the catalog.language issue, see this FAQ: viewtopic.php?f=134&t=215776#p750077 .
Thank you very much, first problem with language and other issues are solved! What's about the second one, with mail problem, do you have any ideas ?

Newbie

Posts

Joined
Sat Apr 18, 2020 1:59 am

Post by straightlight » Sat Apr 18, 2020 4:48 am


The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by JetAMC » Sat Apr 18, 2020 5:00 am

straightlight wrote:
Sat Apr 18, 2020 4:48 am
See this post: viewtopic.php?f=202&t=216498&p=779948#p779948 .
This doesn't work for me, because my options in opencart -> mail tab was wrong. Mail server was incorrect, now it's correct and problem is solved. Thank you very much, straightlight!

Newbie

Posts

Joined
Sat Apr 18, 2020 1:59 am
Who is online

Users browsing this forum: No registered users and 11 guests