Post by Kalena » Fri Aug 07, 2020 6:24 pm

I have had oc 2.3.0.2 installed and have now switched to oc3.0.3.2 and only copied over the database to the new installation. Everything works as it should in admin, but when I check the browser I get the following message:
Notice: Undefined property: Proxy :: whosonline in /home/m/midgard/storage/modification/system/engine/action.php on line 79
Anyone know how to fix it? - need to have my store up. Please help.

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by xxvirusxx » Fri Aug 07, 2020 8:15 pm

You have to run install for upgrade....and not just replace files.
Disable all ocmod extensions and check.

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Kalena » Sun Aug 09, 2020 4:33 pm

I have got a new problem now - I cant go into my admin/system/settings to save my database, and when I try to - I get this message:

Uncaught exception 'Exception' with message 'Error: Unknown column 'username'
in 'order clause'<br />Error No: 1054<br />SELECT * FROM `oc_api` ORDER BY username ASC' in /home/m/midgard/www/system/library/db/mysqli.php:40 Stack trace:
#0 /home/m/midgard/www/system/library/db.php(45): DB\MySQLi->query('SELECT * FROM `...')
#1 /home/m/midgard/www/admin/model/user/api.php(77): DB->query('SELECT * FROM `...')
#2 [internal function]: ModelUserApi->getApis()
#3 /home/m/midgard/storage/modification/system/engine/loader.php(248): call_user_func_array(Array, Array)
#4 [internal function]: Loader->{closure}(Array, Array)
#5 /home/m/midgard/www/system/engine/proxy.php(47): call_user_func_array(Object(Closure), Array)
#6 /home/m/midgard/www/admin/controller/setting/setting.php(552): Proxy->__call('getApis', Array)
#7 /home/m/midgard/www/admin/controller/setting/setting.php(552): Proxy->getApis()
#8 [internal function]: ControllerSettingSetting->index()
#9 /home/m/midgard/storage/modification/system/engine/action.php(79):
in /home/m/midgard/www/system/library/db/mysqli.php on line 40

I dont have 'username' in my database only 'user' - and that probably depends on my copying between new and old database, but I dont now how to fix it.
If Install oc again it will probably overwrite my database since it changes the config.php and creates an new database?

In my browser I get this:
Error: A theme has not been assigned to this store!

Is there any chance to fix all this?

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by khnaz35 » Sun Aug 09, 2020 4:39 pm

The way you upgrade surely you will run into many problems.
My suggestions.
1) do you have backup of your working site/old database if do have then upload back it to server as you said you need store up.
2) work on local host/setup a sub domain to work with upgrade to latest versions whatever you want to update.

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by letxobnav » Sun Aug 09, 2020 5:05 pm

You cannot use a V2 database with a V3 installation, tables are different, fields are different, it's as simple as that.
You can try but you will go from issue to issue beyond Christmas.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Kalena » Sun Aug 09, 2020 5:23 pm

Ugh, I just wanted to make a simlpe upgrade from v2 to v3 without loosing by database, and my database was overwritten, so I try to save as much as I can.
I cant go back to older version because it is all deleted. My server doesnt support higher than 5.4 php. So even if I insatall newer version of oc, I need to have my database or I will loose all my customers - and that cant be.
I dont know what to do now. Isnt there any chance to change 'username' to 'user' in all files?

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by Kalena » Sun Aug 09, 2020 5:44 pm

ok, I tried to restore my database into localhost and got message:
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
OK
<br />
<b>Fatal error</b>: Uncaught Exception: Error: Unknown column 'company_id' in 'field list'&lt;br /&gt;Error No: 1054&lt;br /&gt;INSERT INTO `oc_address` (`address_id`, `customer_id`, `firstname`, `lastname`, `company`, `address_1`, `address_2`, `city`, `postcode`, `country_id`, `zone_id`, `custom_field`, `company_id`, `tax_id`) VALUES ('4', '4', 'Gunnel', 'Cirverius', '', 'Sickla kanalgata 7', '', 'Stockholm', '12067', '203', '3088', '', '0', '0') in C:\xampp\htdocs\opencart\install\system\library\db\mysqli.php:40
Stack trace:
#0 C:\xampp\htdocs\opencart\install\system\library\db.php(45): DB\MySQLi-&gt;query('INSERT INTO `oc...')
#1 C:\xampp\htdocs\opencart\install\admin\controller\tool\backup.php(103): DB-&gt;query('INSERT INTO `oc...')
#2 C:\xampp\htdocs\opencart\install\system\engine\action.php(79): ControllerToolBackup-&gt;import()
#3 C:\xampp\htdocs\opencart\install\admin\controller\startup\router.php(26): Action-&gt;execute(Object(Registry), Array)
#4 C:\xampp\htdocs\opencart\install\system\engine\action.php(79): ControllerStartupRouter-&gt;index()
in <b>C:\xampp\htdocs\opencart\install\system\library\db\mysqli.php</b> on line <b>40</b><br />

is it still about the version of database not fitting to opencart?

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by letxobnav » Sun Aug 09, 2020 5:52 pm

Well, yes.
You copied the V2 DB to be used with your V3 installation so you still have your V2 database.
Suggest you re-install V2 or recover your old V2 and use your V2 database.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by xxvirusxx » Sun Aug 09, 2020 6:21 pm

You don't have back-ups?
If that server doesn't support PHP 7.0....change it.

OC 2.3.0.2 | OC 3.0.3.6 | Extensions converted by me | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Kalena » Sun Aug 09, 2020 6:24 pm

Ok, Thanks , I will try that.
Can I then upgrade to v3 again and my database will follow ?

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by letxobnav » Sun Aug 09, 2020 6:48 pm

Well, yes, you will still encounter issues but not self inflicted nor of this magnitude.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Kalena » Tue Aug 11, 2020 12:55 am

I want to thank you all for your answers and adwises.
I have now restored my website back to v2 and also migrated to a new server, and my store is up again. It solved all my problems.
I will later on download the newest version of Opencart - but for now I am just happy to be back on track.
Many, many thanks.

New member

Posts

Joined
Thu Jan 29, 2015 5:44 pm

Post by khnaz35 » Tue Aug 11, 2020 1:50 am

Kalena wrote:
Tue Aug 11, 2020 12:55 am
I want to thank you all for your answers and adwises.
I have now restored my website back to v2 and also migrated to a new server, and my store is up again. It solved all my problems.
I will later on download the newest version of Opencart - but for now I am just happy to be back on track.
Many, many thanks.
Great, please add word [Solved] in the beginning of post title.
Thanks

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia
Who is online

Users browsing this forum: tiendung4 and 6 guests