Page 1 of 1

[SOLVED] Problems after upgrading to Version 3.0.3.6

Posted: Sat Aug 08, 2020 11:21 pm
by petsil
Hi,
I'm not sure if this is in the right section...But
After I upgraded version 3.0.3.2 to Version 3.0.3.6

1. First I could not get to admin side, but I found answer from the disscussions.
Problem was storage -folder I had to manually copy it, then it worked.

2. Bigger problem for me is that I can't get marketplace modules AND my own OCmod to work correctly.
Even they ALL worked in version 3.0.3.2 just fine.

Does anybody know are there big changes between versions I shoud take consider?
Should I have upgraded step by step versions 3.0.3.3 -4-5 and finally 6?

OCmod does install OK, but the changes won't show on shop-side.

Any help would be appriciated, thank you!

Best regards,
Petri

Re: Problems after upgrading to Version 3.0.3.6

Posted: Sat Aug 08, 2020 11:47 pm
by JNeuhoff
I hope you have a 3.0.3.2 backup of your site because later OC 3.0.x are all too buggy and not worth the trouble!

Re: Problems after upgrading to Version 3.0.3.6

Posted: Sat Aug 08, 2020 11:51 pm
by petsil
Thank you for fast answer.

Yes, of course I have backup.

So I think I will return to use 3.0.3.2, it could be the easiest solution, if I understand you correctly.

Re: Problems after upgrading to Version 3.0.3.6

Posted: Sun Aug 09, 2020 8:10 am
by letxobnav
I agree with JNeuhoff but you are bound to face the same issues on any "newest" version even a bug-free one.

Your extensions/modifications were written for certain versions and as such those ocmod xml files expect to find certain code patterns to change.
That "newest" version might very well have changed the core files in a way that those patterns can no longer be found and as such the modification is not (or partially) executed.

Re: Problems after upgrading to Version 3.0.3.6

Posted: Tue Aug 11, 2020 12:49 am
by petsil
Yes letxobnav, I understand what you mean.
But I updated the extensions/modifications and there was said it should support "newest" version (this time 3.0.3.6). But there were still problems and didn't work properly. Of course, my own OCmod should be checked by myself. This is why I asked if anybody know are there big changes between versions I shoud take consider, because I could not find the information in nowhere myself...
But now I use again version 3.0.3.2 for the time being.
Thank you for answers!

Re: Problems after upgrading to Version 3.0.3.6

Posted: Tue Aug 11, 2020 12:53 am
by JNeuhoff
Use this solution if you want to go with OpenCart 3.0.3.6!

Re: Problems after upgrading to Version 3.0.3.6

Posted: Tue Aug 11, 2020 1:43 am
by petsil
Thank You!