Post by ri2k » Tue Sep 15, 2020 4:23 pm

I am not able to send email to customers using Marketing->Mail option.

Whenever I click send, I get a pop up error message - 412.

Is this a bug or a configuration issue. Can someone please help?

Attachments

Untitled.jpg

Untitled.jpg (197.23 KiB) Viewed 508 times

Last edited by ri2k on Thu Sep 17, 2020 2:04 pm, edited 1 time in total.

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by khnaz35 » Tue Sep 15, 2020 4:59 pm

Most likely the server side error
https://developer.mozilla.org/en-US/doc ... Status/412

Are you able to send other emails using the same module ?

Or is the admin email working while customer orders or test order created from store front?

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member
Online

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by ri2k » Tue Sep 15, 2020 5:16 pm

No, I am not able to send email to any groups, subscribers, affiliates, customers, no one. You saw the error, it won't go through at all.

khnaz35 wrote:
Tue Sep 15, 2020 4:59 pm
Most likely the server side error
https://developer.mozilla.org/en-US/doc ... Status/412

Are you able to send other emails using the same module ?

Or is the admin email working while customer orders or test order created from store front?

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by ADD Creative » Tue Sep 15, 2020 6:13 pm

Ask your host, it looks like a web application firewall such as ModSecurity is blocking the request.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by letxobnav » Tue Sep 15, 2020 6:14 pm

first use browser developer tools console to see where the error comes from.
second contact your host on whether they are blocking with some security module.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by ri2k » Wed Sep 16, 2020 1:19 pm

I get this error from checking the browser developer took -

Failed to load resource: the server responded with a status of 412 ()

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by khnaz35 » Wed Sep 16, 2020 1:23 pm

ri2k wrote:
Wed Sep 16, 2020 1:19 pm
I get this error from checking the browser developer took -

Failed to load resource: the server responded with a status of 412 ()
Error 412 is the same error what are you seeing even from dashboard.
Have you contacted your host?

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member
Online

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by ri2k » Wed Sep 16, 2020 11:40 pm

khnaz35 wrote:
Wed Sep 16, 2020 1:23 pm
ri2k wrote:
Wed Sep 16, 2020 1:19 pm
I get this error from checking the browser developer took -

Failed to load resource: the server responded with a status of 412 ()
Error 412 is the same error what are you seeing even from dashboard.
Have you contacted your host?
I will do that now.

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by khnaz35 » Wed Sep 16, 2020 11:56 pm

Ok. Update us on the status too

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member
Online

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by ri2k » Thu Sep 17, 2020 1:06 pm

It is working now. You are right it was about the Mode Security file.

The server operator said the following-

you have attempted something too many times and you have gotten locked out for a period of time by the mod_security.


Then he first did this-

whitelisted the problematic ID with a command inside your .htaccess so now everything should be as intended.


But after that the problem persisted.


Then he completely disabled the mod_security temporary

And then it worked.

Now it's working, I hope it stays that way.


khnaz35 wrote:
Wed Sep 16, 2020 11:56 pm
Ok. Update us on the status too

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by khnaz35 » Thu Sep 17, 2020 1:16 pm

That's great to hear, it should stay if you don't change anything.

Btw how does it goes with your css changes did the issue resolved?

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member
Online

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by ri2k » Thu Sep 17, 2020 1:57 pm

khnaz35 wrote:
Thu Sep 17, 2020 1:16 pm
That's great to hear, it should stay if you don't change anything.

Btw how does it goes with your css changes did the issue resolved?
Yes, css issue is also resolved. Got advised from someone someone and it worked. Thanks for asking :)

New member

Posts

Joined
Mon Aug 24, 2020 7:31 pm

Post by khnaz35 » Thu Sep 17, 2020 1:59 pm

ri2k wrote:
Thu Sep 17, 2020 1:57 pm
khnaz35 wrote:
Thu Sep 17, 2020 1:16 pm
That's great to hear, it should stay if you don't change anything.

Btw how does it goes with your css changes did the issue resolved?
Yes, css issue is also resolved. Got advised from someone someone and it worked. Thanks for asking :)
Glad to know that :) you can word [SOLVED] in the beginning of your post title.
Thanks

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member
Online

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by letxobnav » Thu Sep 17, 2020 3:42 pm

But after that the problem persisted.
Then he completely disabled the mod_security temporary
And then it worked.
Now it's working, I hope it stays that way.
The clue is in the word "temporary"

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan
Who is online

Users browsing this forum: Bing [Bot], Hillaryli and 9 guests