Post by MeanGuns » Wed Mar 23, 2011 10:30 am

USPS in Open Cart 1.4.9.4

It seems that after the upgrade, and the copy of all files and after running th db script it works but, my main problem still exists.

OpenCart © 2009-2011 All Rights Reserved.
Version 1.4.9.4

The USPS First class mail option still does not work

this is what I get when all shipping options are checked including USPS first class..... When you check something out from the store as you can tell USPS fist class is not included in the shipping options.


Shipping Method

Please select the preferred shipping method to use on this order.
United States Postal Service (Weight: 9.00oz)
Express Mail $29.15
Express Mail Sunday/Holiday Delivery $41.65
Express Mail Flat Rate Envelope $18.30
Express Mail Sunday/Holiday Delivery Flat Rate Envelope $30.80
Priority Mail $10.65
Priority Mail Large Flat Rate Box $14.95
Priority Mail Medium Flat Rate Box $10.95
Priority Mail Small Flat Rate Box $5.20
Priority Mail Flat Rate Envelope $4.95
Parcel Post $8.87
Media Mail $5.50
Library Mail $5.22
Flat Rate
Flat Shipping Rate $12.00
Payment Method

Please select the preferred payment method to use on this order.
Cheque / Money Order
PayPal

Newbie

Posts

Joined
Sat Nov 14, 2009 2:38 am

Post by Qphoria » Wed Mar 23, 2011 11:21 am

There is a setting I see in the api for

<FirstClassMailType></FirstClassMailType

That is probably the issue. Let me try that

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by MeanGuns » Wed Mar 23, 2011 11:26 am

I am sure if anyone can figure out this it would be you.

Good Luck.

If you figure it out let us know.

Everyone here including myself knows how grueling programming can be and we all appreciate your efforts.

MeanGuns

Newbie

Posts

Joined
Sat Nov 14, 2009 2:38 am

Post by Qphoria » Wed Mar 23, 2011 11:38 am

Ok I got it. Seems firstclass no longer returns as part of "ALL" services. So I had to add some code to determine if the package was less than or equal to 13oz, then use service of "FIRST CLASS" otherwise use "ALL". Seems to work well.

Attached patch file to first post

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Wed Mar 23, 2011 12:03 pm

Johnathan wrote:Thanks for another update!

Were you planning on adding in my update to Weight-Based Shipping at any point? If not, that's fine, just let me know and I'll put it up in the extension store.
Just noticed this now.. Yea I'll add it.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by openmycart.com » Wed Mar 23, 2011 1:12 pm

in admin\controller\sale\order.php

I found new changed (arround line 857)
this should be

Code: Select all

					'invoice_date'      => date($this->language->get('date_format_short'), strtotime($invoice_date)),
instead ?

Code: Select all

					'invoice_date'      => $invoice_date,

Find and get many various of opencart modules, themes, mods, etc for your opencart store at http://www.openmycart.com/oc/, OPENCART SITE customization and Maintenance supports at here


User avatar
Active Member

Posts

Joined
Tue Oct 12, 2010 4:47 am


Post by aaron1988 » Wed Mar 23, 2011 5:58 pm

Hi Q, just wondering if i was to do this UPGRADE as at moment i have version 1.4.9.3 would it overwrite my template files? also if i have isntalled like CSV Import Pro and that will it mess these up? or are they fine to still use.

Regards,
Aaron

Active Member

Posts

Joined
Thu Jan 27, 2011 10:03 am

Post by ckonig » Wed Mar 23, 2011 7:25 pm

Hey Q,
thank you for the new release. I really like the way you work with filters now. It's much more readable and understandable. But why did you not change the customer controller in the same way you did with the order controller? I really don't get it.
I was trying to fix my vqmods and ran into pure confusion.

User avatar
Active Member

Posts

Joined
Wed Feb 16, 2011 4:26 pm
Location - Netherlands

Post by Brum26 » Thu Mar 24, 2011 6:09 am

Hi,

I'm still quite new to all this and always paranoid about completely messing up my site. I am currently on version 1.4.9.2. What do I need to do in order to upgrade as I'm hoping that this is going to solve the problem that I am having with setting up moneybookers.

Thanks

New member

Posts

Joined
Mon Jan 17, 2011 9:35 pm

Post by Qphoria » Thu Mar 24, 2011 6:51 am

ckonig wrote:Hey Q,
thank you for the new release. I really like the way you work with filters now. It's much more readable and understandable. But why did you not change the customer controller in the same way you did with the order controller? I really don't get it.
Baby steps. Wasnt planning on doing it all until 1.5 but the order one was needing other stuff so I figured i'd just do it there to give it real world experience. More will follow

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Brum26 » Thu Mar 24, 2011 6:18 pm

Please can somebody help. I have just tried to follow the instructions in the update.txt file to update my site. I uploaded all the new files except config.php and admin/config.php. When I get to step 4 I can't work out what I need to do. What program do I need to use to open the file and fill in the HTTPS section? My site seems to be working but when I try to go to admin login I get a message that it can not display the web page.

New member

Posts

Joined
Mon Jan 17, 2011 9:35 pm

Post by Qphoria » Thu Mar 24, 2011 6:55 pm

what version are you coming from? If it is 1.4.8 or you can probably can skip step 4 since it should already be done.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Brum26 » Thu Mar 24, 2011 7:04 pm

Ok, I think I have sorted that out as I can now get in to my admin section. However there seems to be a problem with the featured and bestsellers modules at the bottom of the page. www.propergifts.co.uk

I think I messed up by uploading some of the files in to the wrong place. I thought I had corrected them all but it appears maybe I haven't.

New member

Posts

Joined
Mon Jan 17, 2011 9:35 pm

Post by Brum26 » Thu Mar 24, 2011 7:32 pm

Also I had an addfast thing setup for adding products much more quickly and this seems to have vanished also.

New member

Posts

Joined
Mon Jan 17, 2011 9:35 pm

Post by mystifier » Thu Mar 24, 2011 9:02 pm

I know that delta.txt provides a list of all changes files, but is it easy to provide a 1.4.9.3 to 1.4.9.4 patch?

I can't do a wholesale update because it affects quite a few files that I have modified.

Free v1.4.9 Extensions: Default Specials | Improved Search | Customer Activity Report | Customer Groups | Royal Mail With Handling | Improved Product Page | Random Products | Stock Report | All Products


User avatar
Active Member

Posts

Joined
Tue May 18, 2010 5:15 pm

Post by Qphoria » Thu Mar 24, 2011 9:33 pm

mystifier wrote:I know that delta.txt provides a list of all changes files, but is it easy to provide a 1.4.9.3 to 1.4.9.4 patch?

I can't do a wholesale update because it affects quite a few files that I have modified.
WTF! Does anyone frickin read anymore!? How hard is it to find the damn download link in the first post of this thread??! WTF does it say right below the delta quote!?
Image


You've been here long enough to know i've been putting out patch only releases since 1.4.9! RTFM! :rtfm:

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Thu Mar 24, 2011 9:35 pm

Brum26 wrote:Also I had an addfast thing setup for adding products much more quickly and this seems to have vanished also.
This is likely due to you uploading files to the wrong place or some core files you edited were also files that were changed in the upgrade.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by mystifier » Thu Mar 24, 2011 10:06 pm

1.4.9.4 doesn't work in the forum search. Viz:
"The following words in your search query were ignored because they are too common words: 1 4 9 4"

I simply got 1.4.9.4 from Downloads and the patch isn't included as in previous versions.

Besides, I like to watch you explode now and again.

Free v1.4.9 Extensions: Default Specials | Improved Search | Customer Activity Report | Customer Groups | Royal Mail With Handling | Improved Product Page | Random Products | Stock Report | All Products


User avatar
Active Member

Posts

Joined
Tue May 18, 2010 5:15 pm

Post by Brum26 » Thu Mar 24, 2011 10:13 pm

Ok, Does anyone know why my bestsellers and featured modules have gone like this though? www.propergifts.co.uk

New member

Posts

Joined
Mon Jan 17, 2011 9:35 pm

Post by Qphoria » Thu Mar 24, 2011 10:26 pm

mystifier wrote:1.4.9.4 doesn't work in the forum search. Viz:
"The following words in your search query were ignored because they are too common words: 1 4 9 4"

I simply got 1.4.9.4 from Downloads and the patch isn't included as in previous versions.

Besides, I like to watch you explode now and again.
Yet you managed to find this thread though ... so much for that excuse...
The patch is always mentioned in the first post in the thread of the new release. It is never inside the full zip..

Life lesson #243: You should never post a reply in a thread if you haven't read the entire first post of that thread.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 6 guests