Post by MikeSCC » Thu Mar 14, 2013 8:30 pm

I am having this issue on version 1.5.4 using PayPal Pro and have tried every solution I can find on the OC forums - please could someone advise on any other possibilities?



Active Member


Tue Nov 20, 2012 5:55 pm

Post by Dando265 » Thu Dec 05, 2013 8:19 pm

Hello Everyone,

I'm on Opencart 1.5.6

I too had the same issue with PP Pro and PP Pro UK. Everything seemed to be working OK up to the point of confirming the order. Then the page would display the infamous "please wait" and do nothing. When checking the opencart admin the order was actually being recorded. The same too with Paypal the payment was going through but despite that the checkout page just seems to freeze.

I had three different experts try to fix this and all three failed to find the bug or a fix. They all came back with different reasons and various bugs, which were later found not to be bugs at all.

I discovered the reason for the "please wait" error myself. My problem was caused by the order email not being authorised and not beng sent. Strange but true.

Please check that your order emails are being sent. It may be worth doing some tests with demo products set as cash on delivery to ensure it's not the email sending which is stopping the page. Make sure you setup your mail as

Code: Select all

on the correct port 465 with a time out of 5 sec.

This worked for me, once my emails were being sent OK the "Please wait" disappeared and the page went through to "Success" page.

Not everyone will have the same issue but it's one worth checking right from the off before you start debugging and tearing files apart because it's normally easy to fix.

Anyone else had this issue or did this fix work for you? Let us know :)



Thu Dec 05, 2013 7:57 pm

Post by mholmquist » Fri Mar 21, 2014 10:03 pm

I am also having this issue in version
I am using the payment gateway (AIM).

The payment is going through, but the order is not being emailed, and it is ending up in the Missing Orders area.

The error is a cURL 28 message. I am considering contacting my host and see if they will clear the DNS cache, if that will help.

Anyone else have any insight on this?




Thu Jun 07, 2012 5:58 am

Post by wanv » Mon Aug 11, 2014 1:01 am

Having the same issue OC 1.5.6..



Sat May 19, 2012 1:53 am

Post by cwswebdesign » Mon Aug 11, 2014 6:32 am

For all of you in the last few posts, I've run into this several times and it's due to the email settings being incorrect. You'll probably have to try a few combinations to get it right.

Use the and check with your host about the ports (non SSL should be 25 or 26 in most cases).

I have a lot of stores using 1.5.6.x and and email do work.


This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.


User avatar
Active Member


Sun Dec 11, 2011 12:26 am
Location - USA
Who is online

Users browsing this forum: No registered users and 1 guest