Post by counter-revolution » Wed Jun 22, 2011 4:34 am

Qphoria , thanks for all the hard work by you and Daniel. I have two questions...

1) I want to make sure I get this straight. I have a site that uses options on version 1.4.9.5
Can I run the upgrade script on 1.5 without screwing the options up?

2) Is there a way to manually or automatically upgrade to 1.5.0.5 (it sounds like manually at the moment)?

Thanks again!


Posts

Joined
Thu Mar 03, 2011 4:06 am

Post by Qphoria » Wed Jun 22, 2011 4:46 am

counter-revolution wrote:Qphoria , thanks for all the hard work by you and Daniel. I have two questions...

1) I want to make sure I get this straight. I have a site that uses options on version 1.4.9.5
Can I run the upgrade script on 1.5 without screwing the options up?

2) Is there a way to manually or automatically upgrade to 1.5.0.5 (it sounds like manually at the moment)?

Thanks again!
The fact that you had to ask number 1 means one of the following:
- You are completely blind
- You are color blind and yellow highlighting blocks your vision
- You simply cannot read
- You just want me to abuse you verbally.

2. There will never be an automatic upgrade for 1.4.x to 1.5.x. There are a lot of changes that just aren't made to mesh well and this is a temporary process of conversion. At some point in about a year, 90% of people that plan on upgrading their carts will hopefully be upgraded to 1.5.x and this process will no longer be needed so it is not a project worth spending a lot of time on, just for it to die.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by counter-revolution » Wed Jun 22, 2011 4:57 am

Qphoria wrote:
counter-revolution wrote:Qphoria , thanks for all the hard work by you and Daniel. I have two questions...

1) I want to make sure I get this straight. I have a site that uses options on version 1.4.9.5
Can I run the upgrade script on 1.5 without screwing the options up?

2) Is there a way to manually or automatically upgrade to 1.5.0.5 (it sounds like manually at the moment)?

Thanks again!
The fact that you had to ask number 1 means one of the following:
- You are completely blind
- You are color blind and yellow highlighting blocks your vision
- You simply cannot read
- You just want me to abuse you verbally.

2. There will never be an automatic upgrade for 1.4.x to 1.5.x. There are a lot of changes that just aren't made to mesh well and this is a temporary process of conversion. At some point in about a year, 90% of people that plan on upgrading their carts will hopefully be upgraded to 1.5.x and this process will no longer be needed so it is not a project worth spending a lot of time on, just for it to die.
I like the verbal abuse, and currently laughing out loud. I agree, the first question was pretty dumb and I can read English. Let me rephrase the question. Can I simply add all files (with the exception of config and admin) from the newly extracted 1.5.0.5 download to my server (and of course running the install script) without screwing up options? That I'm not clear on.


Posts

Joined
Thu Mar 03, 2011 4:06 am

Post by cmann » Wed Jun 22, 2011 6:04 pm

I have also received the following error when I run the upgrade script:
Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in C:\php\Web\gratusonline.com\install\upgrade-14x-to-15x.no-opt.php on line 77
And when I visit the store I just get a page full of errors:
Notice: Undefined variable: text_login in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 108 My AccountShopping CartCheckout
Notice: Undefined variable: entry_search in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 118
Notice: Undefined variable: keyword in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 120
Notice: Undefined variable: button_go in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 136 Notice: Undefined variable: text_advanced in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 136
Notice: Undefined variable: breadcrumbs in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 149Warning: Invalid argument supplied for foreach() in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 149
Rand
Euro Pound Sterling Rand US Dollar
English English
English English
Notice: Undefined variable: welcome in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\home.tpl on line 3 Notice: Undefined variable: modules in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\home.tpl on line 20Warning: Invalid argument supplied for foreach() in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\home.tpl on line 20

** I am running version 1.4.9.1 and attempting to upgrade to version 1.5.0.4
Last edited by cmann on Wed Jun 22, 2011 6:06 pm, edited 1 time in total.

Newbie

Posts

Joined
Wed Jun 22, 2011 6:00 pm

Post by thanhcong171 » Wed Jun 22, 2011 6:06 pm

i got "Warning: Please check the form carefully for errors" when try config store in admin panel.
Tell me problem!!!!!!!!!!!!11

Newbie

Posts

Joined
Wed Jun 22, 2011 6:03 pm

Post by cmann » Wed Jun 22, 2011 7:38 pm

cmann wrote:And when I visit the store I just get a page full of errors:
Notice: Undefined variable: text_login in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 108 My AccountShopping CartCheckout
You can ignore this, I should have looked a little closer at the errors; I see now that the errors were caused by the old 1.4 theme and the store does work despite the mysql errors in the update script.

Newbie

Posts

Joined
Wed Jun 22, 2011 6:00 pm

Post by Qphoria » Wed Jun 22, 2011 9:20 pm

cmann wrote:
cmann wrote:And when I visit the store I just get a page full of errors:
Notice: Undefined variable: text_login in C:\php\Web\gratusonline.com\catalog\view\theme\gratus\template\common\header.tpl on line 108 My AccountShopping CartCheckout
You can ignore this, I should have looked a little closer at the errors; I see now that the errors were caused by the old 1.4 theme and the store does work despite the mysql errors in the update script.
Ding Ding Ding :)

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Wed Jun 22, 2011 9:27 pm

counter-revolution wrote: I like the verbal abuse, and currently laughing out loud. I agree, the first question was pretty dumb and I can read English. Let me rephrase the question. Can I simply add all files (with the exception of config and admin) from the newly extracted 1.5.0.5 download to my server (and of course running the install script) without screwing up options? That I'm not clear on.
:) Looks like I need to be more abusive. Let's slow it down for our friend here.....

Let's analyze that first post..
Image

Does your limited viewing ability allow you to see arrows?

THIS SCRIPT WILL DELETE ALL PRODUCT OPTIONS!
IF YOU HAVE PRODUCT OPTIONS AND RUN THIS SCRIPT, YOU WILL HAVE ONLY PRODUCTS LEFT, WITH NO OPTIONS
PRODUCT WITH OPTIONS WILL BECOME PRODUCTS WITHOUT OPTIONS
ORDERS OF PRODUCTS WITH OPTIONS WILL BECOME ORDERS OF PRODUCTS WITHOUT OPTIONS

I really can't say it any other way. :hammer:

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by imadam » Thu Jun 23, 2011 1:25 am

he may have been talking about store options. could be wrong though. my thought is because you've made the product options answer very clear so what else could he mean

my opencart carpet cleaning woking guildford and Office Cleaning Services in Guildford


Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by Oneilus » Thu Jun 23, 2011 2:33 am

Hi Q,

Is there any other version of the script which keep options on product?

I really don't understand your moves.
I saw a post where you said something like : "I don't want to spend time on something people are gona use only once"

I'm using OC since V1.4.
Now my shop is still ruining on 1.4.9 and I really want to upgrade it to 1.5 but I can't...
I can't do it because there is no possibility to upgrade a live shop with a BETA script containing errors.
So what's is going on here? Do you expect current users to re-edit all their product database?

I don't think to be the only case here.

New member

Posts

Joined
Fri Mar 26, 2010 2:26 am

Post by imadam » Thu Jun 23, 2011 2:41 am

how much did you pay for the upgrade script and the cart Oneilus? sounds like you need a refund as i got it all for free just loads of hard work from the dev's so can't really complain that stuff doesn't happen right away.

the beta was released so we have something. i'm sure if a full one is needed then it'll get done at some point, but 1.4 cart works fine as is so it's not essential you upgrade, and not essential there is a bug less script made today.

as this cart is open source why don't you make an upgrade scipt that carries options across and is bugless? or in almost your own words "do you expect current devs to re-edit all your product database for free?"

my opencart carpet cleaning woking guildford and Office Cleaning Services in Guildford


Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by Oneilus » Thu Jun 23, 2011 4:17 am

I know is an open source, and it's(was?) one of the best, that is why i use it.
I'm just surprised to see a developer of this project saying such of things.
It's like they offer us a very nice car but without the keys to use it :/
can't really complain that stuff doesn't happen right away.
An upgrade script is the most important tool when you release a new version.
the beta was released so we have something
What is the point of having a good 1.5 final release when the upgrade script is not ready?

At the end of the day, any existing shop using OC 1.4 can't use 1.5.

1.5 has some good tools.. it's pity we can only use it in localhost..

New member

Posts

Joined
Fri Mar 26, 2010 2:26 am

Post by Tom52 » Thu Jun 23, 2011 5:21 am

Hello,

I tried to do the upgrade and this is what I get.

Any help please?
Tom

Code: Select all

OpenCart 1.x Upgrade Script (BETA)

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/xxxx/install/upgrade-14x-to-15x.no-opt.php on line 77

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxxx/public_html/xxx/install/upgrade-14x-to-15x.no-opt.php on line 77

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/xxx/install/upgrade-14x-to-15x.no-opt.php on line 77

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxxx/public_html/xxxx/install/upgrade-14x-to-15x.no-opt.php on line 77

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/xxx/install/upgrade-14x-to-15x.no-opt.php on line 74

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/xxxx/install/upgrade-14x-to-15x.no-opt.php on line 77

The following errors occured:

Could not execute this query: DELETE FROM extension WHERE `type` = 'module' AND `key` = 'currency'; Unknown column 'key' in 'where clause'


Could not execute this query: ALTER TABLE coupon_description DEFAULT CHARSET=utf8 COLLATE=utf8_bin; Table 'handcra9_opDB.coupon_description' doesn't exist


Could not execute this query: ALTER TABLE product_option_description DEFAULT CHARSET=utf8 COLLATE=utf8_bin; Table 'handcra9_opDB.product_option_description' doesn't exist


Could not execute this query: ALTER TABLE product_option_value_description DEFAULT CHARSET=utf8 COLLATE=utf8_bin; Table 'handcra9_opDB.product_option_value_description' doesn't exist


Could not execute this query: DELETE FROM `extension` WHERE `type` = 'module' AND `key` = 'latest'; Unknown column 'key' in 'where clause'


Could not execute this query: INSERT INTO `extension` (`extension_id`, `type`, `key`) VALUES (NULL, 'module', 'latest') ON DUPLICATE KEY UPDATE extension_id=extension_id; Unknown column 'key' in 'field list'


Could not execute this query: ALTER TABLE `category_description` CHANGE `meta_keywords` `meta_keyword` varchar(255) NOT NULL COLLATE utf8_bin; Duplicate column name 'meta_keyword'


Could not execute this query: ALTER TABLE `extension` CHANGE `key` `code` varchar(32) NOT NULL COLLATE utf8_bin; Unknown column 'key' in 'extension'


Could not execute this query: ALTER TABLE `order` CHANGE `invoice_id` `invoice_no` int(11) NOT NULL DEFAULT '0'; Duplicate column name 'invoice_no'


Could not execute this query: ALTER TABLE `order` CHANGE `currency` `currency_code` varchar(3) NOT NULL; Unknown column 'currency' in 'order'


Could not execute this query: ALTER TABLE `order` CHANGE `value` `currency_value` decimal(15,8) NOT NULL; Unknown column 'value' in 'order'


Could not execute this query: INSERT INTO `coupon_history` (coupon_id, order_id, customer_id, date_added) SELECT coupon_id, order_id, customer_id, date_added FROM `order`; Unknown column 'coupon_id' in 'field list'


Could not execute this query: ALTER TABLE `order` ADD `reward` int(8) NOT NULL DEFAULT 0 COMMENT '' AFTER total, ADD `affiliate_id` int(11) NOT NULL DEFAULT 0 COMMENT '' AFTER order_status_id, ADD `commission` decimal(15,4) NOT NULL COMMENT '' AFTER affiliate_id, MODIFY `invoice_prefix` varchar(10) NOT NULL COMMENT '' COLLATE utf8_bin, DROP `invoice_date`, DROP `coupon_id`, ALTER `date_modified` DROP DEFAULT, ALTER `date_added` DROP DEFAULT; Can't DROP 'coupon_id'; check that column/key exists


Could not execute this query: ALTER TABLE `product` ADD `upc` varchar(12) NOT NULL COLLATE utf8_bin AFTER sku, ADD `points` int(8) NOT NULL DEFAULT '0' AFTER price, DROP `maximum`, DROP `cost`; Duplicate column name 'upc'


Could not execute this query: ALTER TABLE `product_description` CHANGE `meta_keywords` `meta_keyword` varchar(255) NOT NULL COLLATE utf8_bin; Duplicate column name 'meta_keyword'


The above errors occurred because the script could not properly determine the existing state of those db elements. Your store may not need those changes. Please post any errors on the forums to ensure that they can be addressed in future versions

v1.5.0.5


New member

Posts

Joined
Thu Oct 07, 2010 7:41 am

Post by keithb » Thu Jun 23, 2011 6:20 am

deleted by qphoria

MY CAR BULBS


New member

Posts

Joined
Thu Jun 03, 2010 6:12 pm


Post by Qphoria » Thu Jun 23, 2011 7:19 am

You guys need to slow down.

@Onelius:
This script works fine for stores that do not have "Product Options".
I am still working on a script that supports stores that DO have "Product Options".
My point about not spending a lot of time on it means I'm not going to worry about the little errors and warnings people see on the upgrade script because they are non-errors and false-positives. The process is actually working, but mysql doesn't have error handling like a normal programming language, so the method I am using at the moment is "raw" but working. For a 1.5.x to 1.5.x upgrade, I will likely revamp the design and use php to handle the upgrades, as the conversions have gotten trickier to do with plain mysql statements as I've been able to use with 1.3.x and 1.4.x. But for this 1.4.x to 1.5.x, the process isn't going to get any easier or refined. It needs to be just good enough to do it once. The only thing planned is the added support for stores with product options.

@Tom52:
all the errors you are getting is simply because you ran the script twice. It doesn't hurt anything, but since things like "key" don't exist, that just means the upgrade was already run once and already converted them. Just continue on with the rest of the upgrade steps. At this point, enough people have run through the upgrade script and none of the errors you see are show stoppers.

@keith:
Sorry but it looks like you took a lot of time editing and writing... Aside from being way too long for anyone to read, there are no code changes needed here. Read what I wrote to Tom above.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Thu Jun 23, 2011 7:26 am

Oneilus wrote: What is the point of having a good 1.5 final release when the upgrade script is not ready?
.
That's a pretty naive question. What about people who are just coming to opencart after 1.5.x is released? Not sure why you think the upgrade from 1.4.x to 1.5.x is such a golden thing. You should be focused on your business. You've managed to get this far with 1.4.x and it is still the more stable option for a live site. But 1.5.x is moving forward, and upgrade scripts are a one-time run. Would you prefer more time be wasted on something you will run once vs features and stability in the new version?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Tom52 » Thu Jun 23, 2011 9:03 am

I did the upgraded and the admin area is ok, but the frontend this is what I get
How can I fix this?

Thanks
Tom


Notice: Undefined variable: text_special in /home/xxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 62Notice: Undefined variable: text_bookmark in /home/xxxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 63Notice: Undefined variable: text_contact in /home/xxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 64Notice: Undefined variable: text_sitemap in /home/xxxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 65

HomeNotice: Undefined variable: text_login in /home/xxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 68My AccountShopping CartCheckout

Notice: Undefined variable: entry_search in /home/xxxxxx/public_html/xxx/catalog/view/theme/village-basic/template/common/header.tpl on line 79

Notice: Undefined variable: keyword in /home/xxxxxx/public_html/xxxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 81Notice: Undefined variable: text_category in /home/xxxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 87

Notice: Undefined variable: button_go in /home/xxxxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 97 Notice: Undefined variable: text_advanced in /home/xxxxx/public_html/xxx/catalog/view/theme/village-basic/template/common/header.tpl on line 97

Notice: Undefined variable: breadcrumbs in /home/xxxxx/public_html/xxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 110Warning: Invalid argument supplied for foreach() in /home/xxxxx/public_html/xxxxx/catalog/view/theme/village-basic/template/common/header.tpl on line 110




US Dollar

US Dollar





English

English








Information
•Order Trackers
•Shipping & Returns
•About Us
•Privacy Policy
•Terms & Conditions


Customer Service
•Contact Us
•Returns
•Site Map


Extras
•Brands
•Gift Vouchers
•Affiliates
•Specials


Account
•Login
•Order History
•Wish List
•Newsletter

v1.5.0.5


New member

Posts

Joined
Thu Oct 07, 2010 7:41 am

Post by MasterG » Thu Jun 23, 2011 11:28 am

Tom52 wrote:I did the upgraded and the admin area is ok, but the frontend this is what I get
How can I fix this?

Thanks
Tom
...
Change the theme to default. save. then go to store page and do ctrl+F5 to reload.

Newbie

Posts

Joined
Sun Jun 19, 2011 5:09 am

Post by Qphoria » Thu Jun 23, 2011 11:49 am

MasterG wrote:
Tom52 wrote:I did the upgraded and the admin area is ok, but the frontend this is what I get
How can I fix this?

Thanks
Tom
...
Change the theme to default. save. then go to store page and do ctrl+F5 to reload.
Just like the upgrade step by step document says. (At least the first part) :stick:
I found that Firefox works with one ctrl+f5 hit
but chrome tends to need two ctrl+f5 hits

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Tom52 » Thu Jun 23, 2011 12:29 pm

Thanks guys.
Tom

v1.5.0.5


New member

Posts

Joined
Thu Oct 07, 2010 7:41 am
Who is online

Users browsing this forum: No registered users and 5 guests