Post by vera6000 » Sun Feb 16, 2014 6:36 am

Hi,
I got an SSL certfificate that I want to apply on crain pages like checkout... My SSL has benn added by mhost and I have checked the SSL option in the Opemcart admin. When I type HTTPS instead of HTTP my CSS doesn't load. Do you have an idea of what it could be and how it can be solved?
Thanks :)

New member

Posts

Joined
Mon Nov 25, 2013 10:52 pm

Post by victorj » Sun Feb 16, 2014 6:44 am

did you edit your config files so it is directing to https in https sections ?

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by vera6000 » Sun Feb 16, 2014 6:57 am

In the config.htp files, I have:

// HTTP
define('HTTP_SERVER', 'http://mydomainname.com/');
define('HTTP_CATALOG', 'http://mydomainname.com/');
define('HTTP_IMAGE', 'http://mydomainname/image/');
define('HTTP_ADMIN', 'http://mydomainname/admin/');

// HTTPS
define('HTTPS_SERVER', HTTP_SERVER);
define('HTTPS_IMAGE', HTTP_IMAGE);

Is there something to change here?

New member

Posts

Joined
Mon Nov 25, 2013 10:52 pm

Post by victorj » Sun Feb 16, 2014 7:04 am

Code: Select all

// HTTPS
define('HTTPS_SERVER', 'https://mydomainname.com/);
define('HTTPS_IMAGE', 'https://mydomainname/image/);
same for config.php lacated in folder admin

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by vera6000 » Sun Feb 16, 2014 7:17 am

Beautiful, everything works now. I was so close to the solution but kept going around!! Thanks a lot Victor!

New member

Posts

Joined
Mon Nov 25, 2013 10:52 pm

Post by alin301 » Wed Mar 31, 2021 4:54 pm

I had this issue with my websites several times and the problem came from Google Pagespeed extension in my cPanel. I solved this by adding the following code to my .htaccess root file.

Code: Select all

ModPagespeedDisableFilters combine_css

Newbie

Posts

Joined
Sun Jan 17, 2021 10:54 pm
Who is online

Users browsing this forum: Bing [Bot] and 24 guests