Post by mastplas » Fri Jan 16, 2015 9:00 am

Hi

I am currently building my 4th OC site and I seem to be having slow load times on all pages. 13-15 seconds

V 1.5.6.4

I'm not not sure what info to give you to get your help the site is http://fascias.com/index.php

There are currently about 3000 products with more to be added.

If you could offer suggestions on how to fix i would appreciate it.

Regards

Rob

Newbie

Posts

Joined
Fri Oct 17, 2014 2:12 am

Post by melbagnato » Fri Jan 16, 2015 12:04 pm

There are many, many ways to speed up your site. I'd be happy to take a look and apply some db indexing and some mods which speed up the site. Also, look through the posts by IP_CAM, he's got some awesome suggestions.

PM me some details if you want some assistance.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by mastplas » Fri Jan 16, 2015 7:48 pm

Hi Mel

Thanks for the reply and offer, I will PM you.

Also, reading the forums last night, there was a suggestion to another user to disable the categories on the home page and not the load time, if i disable the categories on the home page the site loads in under a second, so i guess my main issue is with the category mod, as well as other suggestions you make.

Regards

Rob

Newbie

Posts

Joined
Fri Oct 17, 2014 2:12 am

Post by melbagnato » Fri Jan 16, 2015 8:04 pm

There are changes that need to be made when you have a site with many products, categories or entries. I'll show you the changes that will be specific to you and your version of OC.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne


Post by madimar » Fri Jan 16, 2015 9:05 pm

I can confirm that, in most of cases, so long waiting time are due to some lack of db indexing. It is the first thing I'd check.
M

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by tjsystems » Fri Jan 16, 2015 9:54 pm


Live with 2.2.0.0 fully SSL.


Active Member

Posts

Joined
Sun Aug 26, 2012 5:39 pm
Location - NL, Amsterdam

Post by Dhaupin » Sat Jan 17, 2015 7:24 am

This question has been asked countless times, still the same answer :) The site @tjsystems suggested has some great starts. Look at these too:

DB index fix: http://bloke.org/php/opencart-is-slow-w ... mment-3993

Product count fix: disable category count in store setting

Product count function fix: http://www.opencart.com/index.php?route ... n_id=10999

Guaranteed a 300% speed increase on large stores from those 3 items

https://creadev.org | support@creadev.org - Opencart Extensions, Integrations, & Development. Made in the USA.


User avatar
Active Member

Posts

Joined
Tue May 13, 2014 3:45 am
Location - PA

Post by mastplas » Mon Feb 02, 2015 8:34 pm

melbagnato wrote:There are changes that need to be made when you have a site with many products, categories or entries. I'll show you the changes that will be specific to you and your version of OC.

- Mel
Hi Mel

I sent you a PM but not sure you've got it? Can you confirm...

Rob

Newbie

Posts

Joined
Fri Oct 17, 2014 2:12 am

Post by IP_CAM » Tue Feb 03, 2015 3:40 am


I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'160 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Dhaupin » Wed Feb 04, 2015 12:28 am

IP_CAM wrote:I just published some little 'helper' - infos:

http://devs.mx/topic/380-caching-openca ... ry-counts/
http://devs.mx/topic/377-openshop-with- ... installed/

Ernie
bigmax.ch/shop/
How do you use that devs.mx site? It always times out or internal server error. Ive only been able to connect to it once. Do they host it on a cable modem or something? lol

https://creadev.org | support@creadev.org - Opencart Extensions, Integrations, & Development. Made in the USA.


User avatar
Active Member

Posts

Joined
Tue May 13, 2014 3:45 am
Location - PA

Post by IP_CAM » Wed Feb 04, 2015 1:55 am

>> How do you use that devs.mx site? <<
You know, the fella's from Ukrania, so, he's a busy Guy.
Don't push the Forum Link an the Page Header to go to the Forum, it leads you to the desert of Siberia, or someplace, I never found out. But on the left Side Link-Section, it works. Minor details, I like him anyway, and the way he does it. His Extension is unmatched, and combined with some of villagedefrance.net's Mod's, it's even better, at least to me.
Onby one of his latest Cache-Mod's, it's a pre-release, not final, and just for tests. It's not longer on his Page either, so, please, nobody should use it for real !!! 8)

Ernie
bigmax.ch/shop/

Update 08.Febr.2015:
Latest Cache-Mod, can be found here:
http://www.opencart.com/index.php?route ... n_id=19886
Last edited by IP_CAM on Mon Feb 09, 2015 4:43 am, edited 1 time in total.

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'160 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Dhaupin » Wed Feb 04, 2015 2:25 am

Weird! I think its just the devs.mx domain itself....lightning.devs.mx loads fine

That mod looks cool, thanks man

https://creadev.org | support@creadev.org - Opencart Extensions, Integrations, & Development. Made in the USA.


User avatar
Active Member

Posts

Joined
Tue May 13, 2014 3:45 am
Location - PA
Who is online

Users browsing this forum: No registered users and 76 guests