Post by livelinkwebsites » Mon Apr 29, 2019 7:47 am

Hi there

I've been trying to fix this issue but I just can't find anything I can do to help it without disabling mods one by one... which would be very dangerous to do, as this website is quite old and has been heavily customised to get it the way my client likes.

The website is currently on a test server at livelinktest2.com while I do some updates but I noticed that after a customer logs in using the login button at the top right of the page, logs out or creates an account, the website redirects them to a blank page.

Edit: this version of OC is 1.5.6.4 and I'm using the theme Moda.

Does anyone know of a way I might fix this? I've already tried editing the catalog/controller/account/login.php file to make it redirect to common/home instead of account/account but that does nothing.

Any help would be much appreciated.

Thanks!

New member

Posts

Joined
Tue Feb 24, 2015 7:51 am

Post by IP_CAM » Mon Apr 29, 2019 10:16 am

Well, disable all Modules, not required for 'default' OC Operation,
and possibly check in the default Theme first, if the Error exists there too.
Then disable all the VqMods, and nothing will happen, if everything has
been installed and set, as it should have been made in the first place.

And after cleaning out all Cache + Log Sections, re-install/activate
one Module after the other, and possibly a VqMod related, sometimes
linking some Mods to some Admin and Front Side Sections.

Then test your Shop again, and compare Sections, where Errors
accurred before, to so find out, where your Problems come from.
It will take a little time, but it's the only way, to find out, if one does
not understand the OC System and it's way of doing things well ... 8)
And ALWAYS clear out all Cache Sections first, before trying again,
including your Browser Cache as well ! :'(

It might be something simple, and/or related to PHP-7.x, since not
all OC v.1.x Code and Extensions will further function with PHP-7.x.
One important file needs to be changed, as you can find out here:
viewtopic.php?f=179&t=202581&p=753545#p753545
---
Like the nice Web File Manager, unfortunately belonging to the
Loosers of the PHP-7 Change:
https://www.opencart.com/index.php?rout ... n_id=20624
---
Or then, get someone, to take the load of you, but that would not
come for free, as you might be aware of ... :'(
Good Luck! ;)
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by livelinkwebsites » Mon Apr 29, 2019 12:01 pm

Hi Ernie

Thanks for your reply! I guess I'll have to do some heavy work... :-\ I was hoping maybe someone else had had a similar problem with a fix they could recommend but oh well! :crazy:

If anyone has anything else to suggest, I'm still open to suggestions :P

New member

Posts

Joined
Tue Feb 24, 2015 7:51 am

Post by dparakhiya » Mon Apr 29, 2019 12:27 pm

A blank and white page means in 99% of all cases a php-error. so check your error log ...

For quick, professional OpenCart support
Online
contact me on skype : dparakhiya_1
email : dipneshp@gmail.com


User avatar
New member

Posts

Joined
Fri Jul 28, 2017 1:13 pm
Location - India

Post by livelinkwebsites » Mon Apr 29, 2019 12:46 pm

The error log is as follows:

2019-04-29 14:45:31 - PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/live2testlink/public_html/index.php:1) in /home/live2testlink/public_html/system/library/session.php on line 10
2019-04-29 14:45:31 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/live2testlink/public_html/index.php:1) in /home/live2testlink/public_html/index.php on line 685
2019-04-29 14:45:31 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/live2testlink/public_html/index.php:1) in /home/live2testlink/public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 28
2019-04-29 14:45:31 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/live2testlink/public_html/index.php:1) in /home/live2testlink/public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 29

New member

Posts

Joined
Tue Feb 24, 2015 7:51 am
Who is online

Users browsing this forum: No registered users and 51 guests