Post by drjawn1962 » Mon May 18, 2020 1:41 am

Not sure when it started, but the add to cart, add to wish list and add to compare buttons stopped working in the following locations:

Featured
Latest
Best Seller

Will work on some products pages, but not others.

In a few cases the buttons work on the first page of a product, but on the second one.

I've checked the config files, templates, disabled extensions/mods, checked for oddities in some of the affected
category and product entries. Same thing using Chrome, Safari, Opera, Avast Secure browser,
Explorer, Brave, Firefox and a couple of other browsers.

I'm losing my mind trying to figure this out. Can anyone here provide some insight?

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by straightlight » Mon May 18, 2020 2:25 am

Please provide your OC version and URL.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by drjawn1962 » Mon May 18, 2020 2:28 am


New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by straightlight » Mon May 18, 2020 2:54 am

Ensure all layouts are properly configured from your OC admin > extensions > modules page for each extension modules you are using.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by drjawn1962 » Mon May 18, 2020 3:08 am

I had all the mods disabled and removed extensions that were just an xml file. Nothing changed.

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by ADD Creative » Mon May 18, 2020 3:23 am

Look in your web browser's development console. You will probably see a CORS policy error. This is because you categories start with www. and your other pages do not. Likely caused by a bad theme or modification.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by drjawn1962 » Mon May 18, 2020 3:30 am

I'll try that, thanks.

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by drjawn1962 » Mon May 18, 2020 3:34 am

You're onto something, at least 20 CORS Policy errors. Now to fix them.......

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by drjawn1962 » Mon May 18, 2020 3:49 am

That was it my friend!! When I made the new navbar and a grid with the image links, out of habit I included www. Removed those and all is well.
Thanks so much for your help!!

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by drjawn1962 » Mon May 18, 2020 7:55 am

Ooops, only partially solved.

Still not working under,features, bestseller and latest.

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am

Post by ADD Creative » Mon May 18, 2020 6:06 pm

You need to decide if you want to use www.domain or just domain, set that in all your configs and redirect from one to the other in your htaccess.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by drjawn1962 » Mon May 18, 2020 8:16 pm

I actually looked at some products that a storefront employee had entered, found options with no values assigned, things working properly again, but
www is my choice, I will have to check the htaccess file for shites and giggles. Thanks.

New member

Posts

Joined
Fri Apr 24, 2020 5:40 am
Who is online

Users browsing this forum: No registered users and 47 guests