Post by Mike Guenther » Wed Nov 14, 2012 11:31 pm

Hello All,

If I add a new product in opencart it assigns the correct URL for it, but even though I check what category it belongs to it doesn't get added to the menu or submenu it is assigned to.

The product in question is: SB-Orange Bulk Harvest Egg-1000 (HA1000BULK-O) and it's direct URL is: http://sunnybunnyeastereggs.com/store/H ... t-Egg-1000

But, if you try to navigate to it using the top navbar under harvest eggs then to Bulk Orange Harvest Eggs the URL just gores to Harvest-Eggs and obviously doesn't find the product.

Any ideas why?

MG
Last edited by Mike Guenther on Thu Nov 15, 2012 12:19 am, edited 1 time in total.

Active Member

Posts

Joined
Thu Oct 13, 2011 12:00 am

Post by Tcalp » Wed Nov 14, 2012 11:34 pm

SEO URLs need to be globally unique, you don't seem to be following this logic, Products can show in the 'nav' bar if you have a category and a product with the same SEO slug, but it will depend on what appears first in the database records as to what is called (I think?).

Increase Page Speed (#1 rated commercial extension on OpenCart Marketplace)
15in1 Essential Extensions Value Pack Premium Customer Testimonials Reward Points Extended Admin Security Lockdown Suite

Image
irc.freenode.net #opencart


User avatar
Active Member

Posts

Joined
Wed Jul 06, 2011 1:49 pm

Post by Mike Guenther » Wed Nov 14, 2012 11:40 pm

AH HA! That pointed me in the right direction!

I didn't have Bulk Orange Harvest Eggs set in the SEO Keyword blank for that category.

THANK YOIU!

Active Member

Posts

Joined
Thu Oct 13, 2011 12:00 am
Who is online

Users browsing this forum: No registered users and 17 guests