Post by straightlight » Mon Oct 30, 2017 5:28 am

In that file, find:

Code: Select all

if ($product_option_value_info) {
replace with:

Code: Select all

if (!empty($product_option_value_info['weight_prefix'])) {

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by d3z1gnr » Fri May 18, 2018 6:37 am

I'm getting a slightly different error (but very similar) when running a shipping list...

Warning: A non-numeric value encountered in /home/vapemonk/public_html/admin/controller/sale/order.php on line 1799

What seems to work for me is changing (on line 1768):

$option_weight = '';

to

$option_weight = 0;

Mike Little
Director / Developer / Makes the coffee
Creative Digital Limited
http://www.creativedigital.co.nz


User avatar
Active Member

Posts

Joined
Mon Jan 18, 2010 2:59 pm
Location - Auckland, New Zealand

Post by khnaz35 » Mon Aug 10, 2020 11:26 pm

d3z1gnr wrote:
Fri May 18, 2018 6:37 am
I'm getting a slightly different error (but very similar) when running a shipping list...

Warning: A non-numeric value encountered in /home/vapemonk/public_html/admin/controller/sale/order.php on line 1799

What seems to work for me is changing (on line 1768):

$option_weight = '';

to

$option_weight = 0;
Thanks work for me too

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by straightlight » Thu Aug 13, 2020 7:11 pm

Already fixed in pre-release and master.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by khnaz35 » Thu Aug 13, 2020 9:20 pm

straightlight wrote:
Thu Aug 13, 2020 7:11 pm
Already fixed in pre-release and master.
Hey Straightlight, its good to see you back on fourm.

Btw i have downloaded 3.0.3.5 and it was not fix , so i have to use the above tweak.

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by ADD Creative » Fri Aug 14, 2020 12:10 am

Because some of the 3.0.3.4 fixes were not pushed to GitHub they didn't make it to 3.0.3.5.

I have made a pull request for 3.0.x.x_Maintenance. Hopefully one of the developers will merge it and maybe it will make 3.0.3.7.
https://github.com/opencart/opencart/pull/8223

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by AlanARG » Fri Oct 02, 2020 11:34 am

Hey guys! how's it going?

I'm getting an error at the checkout right at the end when I press the "place order" button, it didn't happen a couple of days ago and I have an everyday backup of database + public_html folder so I guess I can just rollback, right?

Anyway, the error is not showing anything on the log found in "System > Maintenance > Error logs" and when I test it out it just appears a popup window that says "error" and nothing more :(

All I found in the log was something that says:

Code: Select all

2020-09-25 23:44:07 - PHP Warning:  A non-numeric value encountered in /home/c1811017/public_html/admin/controller/sale/order.php on line 1799
2020-09-25 23:44:07 - PHP Warning:  A non-numeric value encountered in /home/c1811017/public_html/admin/controller/sale/order.php on line 1799
I tested it out right now and the logs didn't update and there's nothing there from today (October 1st).

There's other lines in the error that mention the "sale" and "order" word, but I don't have a clue if it's related to this or not.

I've applied this fix but didn't work :(

PS: If u wanna check it out, here it is, just log in with username "test" pw "test123".

Active Member

Posts

Joined
Mon Feb 22, 2016 6:15 pm

Post by ADD Creative » Fri Oct 02, 2020 5:43 pm

What version of OpenCart and what do you have at the line in the error message?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by straightlight » Fri Oct 02, 2020 8:07 pm

Already fixed on the master branch: https://github.com/opencart/opencart/bl ... .php#L1764 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AlanARG » Fri Oct 02, 2020 9:50 pm

ADD Creative wrote:
Fri Oct 02, 2020 5:43 pm
What version of OpenCart and what do you have at the line in the error message?
3.0.3.6
Right at the end when I press the "place order" button, it just says "ERROR" and nothing more.
On Chrome Inspector this is what I got: https://imgur.com/a/3mVf0rx

I can't access the server logs of my host because they said it's a shared log for all the accounts in the server :(

Active Member

Posts

Joined
Mon Feb 22, 2016 6:15 pm

Post by letxobnav » Fri Oct 02, 2020 10:58 pm

the php error logs, not the server logs.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by AlanARG » Sat Oct 03, 2020 12:07 am

letxobnav wrote:
Fri Oct 02, 2020 10:58 pm
the php error logs, not the server logs.
My host sent me this over my email since I can't access the logs myself:

Code: Select all

[root@c181a ~] # cat /opt/apache/logs/error_log | grep nomadebaker.com
[Sun Sep 27 09:02:41.057163 2020] [:error] [pid 29456:tid 140127274608384] [client 152.168.214.195] ModSecurity: Request body (Content-Length) is larger than the configured limit (13107200). [hostname \"nomadebaker.com\"] [uri \"/admin/index.php\"] [unique_id \"X3B-YRBnk9tuLLIoaYrCbAABRwA\"]
[Fri Oct 02 06:58:13.489119 2020] [proxy_fcgi:error] [pid 23200:tid 139894290589440] [client 34.68.114.57:47500] AH01071: Got error \'Primary script unknown\', referer: http://nomadebaker.com/wp-login.php
The php error logs are in /var/log/ apparently but I don't have access to that I believe, I already asked my host to help me out with that as well. Is there any way for me to access to it via phpmyadmin control panel?

Thanks!

/edit: So sorry I was posting here, if anyone is willing to help me I created a thread in the right place: viewtopic.php?f=202&t=220268&p=801045#p801045
Thank you so much.

Active Member

Posts

Joined
Mon Feb 22, 2016 6:15 pm
Who is online

Users browsing this forum: No registered users and 4 guests