Post by labeshops » Fri Aug 14, 2020 8:52 pm

opencart version 3.0.3.2. Every time i try to add an order in admin, the currency field goes red (I only use us dollars) and I get "Warning: You do not have permission to access the API!" at th top and cannot continue. My ip address is added, my developer does not get the error when he tries it, but I cannot add an order. It's like it has issues with my ip and no idea why.

Yes, I added my ip, generated the api and selected that api in the default store's settings, cleared all caches. Yet nothing works.

Running Opencart v3.0.3.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by straightlight » Fri Aug 28, 2020 1:35 am

Check your access logs. If you also use dynamic IPs rather than a static IP, this could also create more problems. If you use an IP restriction as an extension on your store, ensure your IP is not blacklisted. If you use services on your domain where your host panel could filter IP addresses to decline remote services, ensure your IP address is not being blacklisted as well.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 5 guests