Post by Blnukem » Sat Apr 10, 2021 1:01 am

OCMOD 3.0.3.7 not working with .twig file new install.

XML:

<?xml version="1.0" encoding="utf-8"?>
<modification>
<name>Template Test</name>
<version>1.0</version>
<link>Blnukem@gmail.com</link>

<file path="catalog/view/theme/default/template/common/header.twig">
<operation>
<search><![CDATA[
<link href="catalog/view/theme/default/stylesheet/stylesheet.css" rel="stylesheet">
]]></search>

<add position="after"><![CDATA[
<link href="catalog/view/theme/default/stylesheet/tesfile.css" rel="stylesheet">
]]></add>
</operation>
</file>

</modification>

New member

Posts

Joined
Wed Apr 28, 2010 11:17 pm

Post by JNeuhoff » Sat Apr 10, 2021 1:12 am

Don't forget to do a refresh of your OCmod modifications at Extensions > Modifications.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Blnukem » Sat Apr 10, 2021 1:30 am

Yea. I did refresh about 16,000 times.

New member

Posts

Joined
Wed Apr 28, 2010 11:17 pm

Post by straightlight » Sat Apr 10, 2021 1:37 am

Blnukem wrote:
Sat Apr 10, 2021 1:30 am
Yea. I did refresh about 16,000 times.
On the same date, it must be well-counted!

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by xxvirusxx » Sat Apr 10, 2021 2:05 am

JNeuhoff wrote:
Sat Apr 10, 2021 1:12 am
Don't forget to do a refresh of your OCmod modifications at Extensions > Modifications.
And clear theme cache and SASS cache.
Also you can check ocmod logs...

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Blnukem » Sat Apr 10, 2021 2:49 am

All cache has been cleared, No errors in log, its not working. :crazy:
works on .php extensions not .twig

New member

Posts

Joined
Wed Apr 28, 2010 11:17 pm

Post by xxvirusxx » Sat Apr 10, 2021 3:12 am

Sure it is 3.0.3.7 and not 3.0.3.6 ?

Your file is same as this one?
https://github.com/opencart/opencart/bl ... cation.xml

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by sw!tch » Sat Apr 10, 2021 3:33 am

Your ocmod isn't formatted correctly, eg: missing <code></code>

Should be like:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<modification>
 <name></name>
 <version>1.0</version>
 <author></author>
 <link></link>
 <code></code>
.....
Also if you have used the theme editor it will take priority over any ocmod.

Full Stack Web Developer :: Send a PM for Custom Work.
Backup and learn how to recover before you make any changes!


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA
Who is online

Users browsing this forum: No registered users and 7 guests