Post by print-n-tees » Tue Oct 10, 2017 11:09 pm

Greetings.

One thing I always disliked about Opencart is it's image / file Manager. When uploading a new product and its images... each time you have to navigate to the proper folder to find your product images rather than the manager remembering the last folder you were in. That makes uploading images a nightmare.

Can anyone recommend a good image/file manager for Opencart 3.0.2.0? I have one on an install of 1.5.6 but it has not been updated for 3X

Any help would be greatly appreciated.

Angelina

User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by straightlight » Tue Oct 10, 2017 11:17 pm

Followed is an Image Manager free extension for v3.x releases: https://www.opencart.com/index.php?rout ... n_id=31676

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by print-n-tees » Tue Oct 10, 2017 11:41 pm

Thanks again!!

I tried that last night and like others who left comments without replies... I got the same error after installing:

Invalid backend response.
Data is not JSON

I checked permissions etc... an all was good. I even removed permission and when I tried I was told I did not have permissions. Put permissions back on... figured mabe a glitch or something but nope... Got the invalid backend message again.

Virtually no documentation is provided with it.

User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by straightlight » Tue Oct 10, 2017 11:43 pm

What does the error logs indicates in the Opencart admin-end when the JSON error message appears?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by print-n-tees » Tue Oct 10, 2017 11:49 pm

give me a minute to see if I can find it. Im now to 3.0.2.0 always used 1.5.Seems like everything is changed. so may take me a minute to find the logs.

User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by straightlight » Tue Oct 10, 2017 11:52 pm

Admin - > Navigation - > System - > Maintenance - > Error logs.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by print-n-tees » Tue Oct 10, 2017 11:54 pm

Ok found them... Nothing in there. I just tried it again to see if something will show in error log but it does not. Here is the actual error:

Attachments

Error.jpg

Error.jpg (312.03 KiB) Viewed 1676 times


User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by straightlight » Wed Oct 11, 2017 12:59 am

Report to the publisher that this is the URL token not being passed properly through the site header.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Oct 11, 2017 3:00 am

In admin/controller/extension/module/bcimlite.php file,

find:

Code: Select all

if (!$this->user->hasPermission('modify', 'extension/module/elfinder')) {
replace with:

Code: Select all

if (!$this->user->hasPermission('modify', 'extension/module/bcimlite')) {
Then, find:

Code: Select all

if (isset($this->error['warning'])) {
			$data['error_warning'] = $this->error['warning'];
		} else {
			$data['error_warning'] = '';
		}
add below:

Code: Select all

if (!empty($this->request->post['module_bcimlite_status'])) {
			$data['module_bcimlite_status'] = $this->request->post['module_bcimlite_status'];
		} elseif ($this->config->has('module_bcimlite_status')) {
			$data['module_bcimlite_status'] = $this->config->get('module_bcimlite_status');
		} else {
			$data['module_bcimlite_status'] = 0;
		}
In admin/view/template/extension/module/bcmlite.twig file,

replace the entire content with:

Code: Select all

{{ header }}{{ column_left }}
<div id="content">
  <div class="page-header">
    <div class="container-fluid">
      <div class="pull-right">
	    
        <button type="submit" form="form-module" data-toggle="tooltip" title="{{ button_save }}" class="btn btn-primary"><i class="fa fa-save"></i></button>
        <a href="{{ cancel }}" data-toggle="tooltip" title="{{ button_cancel }}" class="btn btn-default"><i class="fa fa-reply"></i></a></div>
      <h1>{{ heading_title }}</h1>
      <ul class="breadcrumb">
        {% for breadcrumb in breadcrumbs %}
        <li><a href="{{ breadcrumb.href }}">{{ breadcrumb.text }}</a></li>
        {% endfor %}
      </ul>
    </div>
  </div>
  <div class="container-fluid">
    {% if error_warning %}
    <div class="alert alert-danger"><i class="fa fa-exclamation-circle"></i> {{ error_warning }}
      <button type="button" class="close" data-dismiss="alert">&times;</button>
    </div>
    {% endif %}
    <div class="panel panel-default">
	 <div class="panel-heading">
        <h3 class="panel-title"><i class="fa fa-pencil"></i> {{ text_edit }}</h3>
      </div>
      <div class="panel-body">
        <form action="{{ action }}" method="post" enctype="multipart/form-data" id="form-module" class="form-horizontal">
          <div class="form-group">
            <label class="col-sm-2 control-label" for="input-status">{{ entry_status }}</label>
            <div class="col-sm-10">
              <select name="module_bcimlite_status" id="input-status" class="form-control">
                {% if module_bcimlite_status %}
                <option value="1" selected="selected">{{ text_enabled }}</option>
                <option value="0">{{ text_disabled }}</option>
                {% else %}
                <option value="1">{{ text_enabled }}</option>
                <option value="0" selected="selected">{{ text_disabled }}</option>
                {% endif %}
              </select>
            </div>
          </div>
        </form>
      </div>
      <div id="elfinder"></div>
    </div>
  </div>
</div>
  <script type="text/javascript"><!--
    $(document).ready(function() {
		var elf = $('#elfinder').elfinder(JSON.stringify({
			url : '{{ url }}',
			height : $(document).height() * 0.75
		})).elfinder('instance');
    });
	//--></script>
{{ footer }}
This should resolved the problem with the error message, including the permission settings.

Note: After applying these modifications, clear all all caches .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by print-n-tees » Wed Oct 11, 2017 4:50 am

Again thank you for your help. I made all the changes and it appears the image / file manager now works... but only on the extensions settings page. I do not see a way to enable it so it works on the products or category admin pages. When I add a product image I still get the default image loader tool.

On the extension modules page it shows as disabled. When I click the edit button it brings me to the tool itself. But I dont see how to enable it.

Angelina

User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by straightlight » Wed Oct 11, 2017 5:12 am

At this point, you'd need to get in touch with the publisher. At least, the error message is gone and you do have the right permissions.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by print-n-tees » Wed Oct 11, 2017 7:33 am

Thank you again for your help. I have messaged them. we'll see if and when they reply.

Thank you again!!

User avatar
New member

Posts

Joined
Sun Feb 24, 2013 2:54 pm


Post by Ghost Leader » Thu May 30, 2019 5:56 pm

print-n-tees wrote:
Wed Oct 11, 2017 7:33 am
Thank you again for your help. I have messaged them. we'll see if and when they reply.

Thank you again!!
sorry for the necro. I encounter the same problem as you. Did you receive an answer? Did you solve your problem?
Thanks...

New member

Posts

Joined
Fri Nov 04, 2016 3:58 pm

Post by straightlight » Thu May 30, 2019 6:22 pm

Ghost Leader wrote:
Thu May 30, 2019 5:56 pm
print-n-tees wrote:
Wed Oct 11, 2017 7:33 am
Thank you again for your help. I have messaged them. we'll see if and when they reply.

Thank you again!!
sorry for the necro. I encounter the same problem as you. Did you receive an answer? Did you solve your problem?
Thanks...
By contacting the developer of that extension … you should know if an answer has been provided at this point.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 13 guests