Post by eBsimplicity » Thu Oct 12, 2017 3:26 am

Hello!

I am installing OC without configuring anything, but I get a blank page at the contact us success page. Another strange error is that it says "Use gift certificate (0.00kg)" in the shopping cart, where it should say "Shopping cart". And the text "Your shopping cart is empty" is also shared with the reward module and the wishlist. So that it will say "Your shopping cart is empty" under wishlist.

Seeing that it's a fresh install, I have no idea what's wrong here. Ideas? See for yourself here: http://www.eivindberheim.no
Blank contact us page: http://www.eivindberheim.no/index.php?r ... ct/success

???

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 3:59 am

By viewing your error logs in the admin, what does it display? You can also check your system/storage/logs/error.txt file if the admin is inaccessible.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 4:08 am

Thank you for your reply.

It says as follows:

2017-10-03 21:31:29 - PHP Warning: unlink(/home/ebxnotgg/ocartdata/storage/cache/cache.catalog.language.1507069888): No such file or directory in /home/ebxnotgg/public_html/system/library/cache/file.php on line 68

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 4:13 am

Which OC version are you using? Is this message persistently appearing?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 4:20 am

I am using version 3.0.2.0

I tried reinstalling a fresh version of OC yet again. Now it does not display that error code. There is no errors displayed in the log at all. But the page is still blank, and the weird placements of the the catalog words are still there.

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 4:29 am

See in your web host logs for additional errors that may not show from Opencart since your new installation.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 4:39 am

I ran a diagnosis provided by my server host, but it is showing 0 errors and only 1 recommendation - which is to upgrade the php version from 5.4 to a newer one.

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by eBsimplicity » Thu Oct 12, 2017 4:42 am

And upgrading the php version does not help, as I've already tried all kinds of versions. ;D

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 4:48 am

Upgrading to the latest version of PHP 7 releases does help, in this case. A lot of development have been added / re-worked by the industry since. Opencart does run really fine with PHP 7 when excluding the problematic features that most users may currently encounter but lots of bug fixes have also been posted since.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 5:07 am

Yes that may be, but putting it on i.e. php 7.1, which it is at now, won't solve this problem it seems. :(

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by eBsimplicity » Thu Oct 12, 2017 5:10 am

I installed throughthe app in cpanel "softaculous", and it seems the problem is in their software as their demo has the same issues as seen here: https://www.softaculous.com/softaculous/demos/OpenCart

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 5:14 am

See if the today's correction on Github is working: https://github.com/opencart/opencart/bl ... e/file.php

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 5:45 am

No, that didn't seem to do anything. I notified the softaculous team that their latest version of OC is bugged. Hopefully they'll respond.

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by eBsimplicity » Thu Oct 12, 2017 5:53 am

Image from the softaculous demo site attached showing 1 of the bugs.

Could there be a fix to be made in the database?

Attachments

gcbug.jpg

gift card in cart - gcbug.jpg (112.21 KiB) Viewed 1934 times


User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 7:32 am

I don't see on the screenshot where the cache error appears ...

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 7:36 am

I'm sorry, I'm trying to fix the blank contact us page and the other mix-ups. It is probably unrelated to the error message in the log.

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 7:47 am

In this case, please create a new topic.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 7:48 am

eBsimplicity wrote:
Thu Oct 12, 2017 3:26 am
Hello!

I am installing OC without configuring anything, but I get a blank page at the contact us success page. Another strange error is that it says "Use gift certificate (0.00kg)" in the shopping cart, where it should say "Shopping cart". And the text "Your shopping cart is empty" is also shared with the reward module and the wishlist. So that it will say "Your shopping cart is empty" under wishlist.

Seeing that it's a fresh install, I have no idea what's wrong here. Ideas? See for yourself here: http://www.eivindberheim.no
Blank contact us page: http://www.eivindberheim.no/index.php?r ... ct/success

???
But that it what this thread is already about ^^

User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am

Post by straightlight » Thu Oct 12, 2017 7:52 am

Can you highlight the exact part of the screenshot where you are looking for a fix?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by eBsimplicity » Thu Oct 12, 2017 7:56 am

Please see http://eivindberheim.no/. Attached is also image of bugged cart vs as it should be.

Attachments

bugged.jpg

bugged.jpg (68.42 KiB) Viewed 1893 times

Normal.jpg

Normal.jpg (49.01 KiB) Viewed 1893 times


User avatar
New member

Posts

Joined
Thu Dec 08, 2011 12:21 am
Who is online

Users browsing this forum: No registered users and 35 guests