Post by AusGirl » Tue Oct 17, 2017 9:04 pm

Hello,

I am suddenly experiencing the below problems.

Products in the cart, delete one product and its still there, refresh and deleted product is gone.
Products in compare, remove one product, its still shows until refreshed.
Images - Add image (product, category ect...) it uploads, but doesn't show until I log out and log back in again.

One day its working beautifully, the next its not playing nice :choke:

Opencart 3.0
No extensions installed
Default theme
Only modifications are colours and language
Website: www.soaptasia.com

Thank you, help much appreciated :)
Last edited by AusGirl on Tue Oct 17, 2017 9:22 pm, edited 1 time in total.

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 9:17 pm

Which exact version of Opencart are you using?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 9:20 pm

The latest version v3.0.2.0 :)

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by AusGirl » Tue Oct 17, 2017 9:39 pm

Now the checkout isn't working :(

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 9:53 pm

What are the admin error logs reporting based on those reported activities?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 9:56 pm

straightlight wrote:
Tue Oct 17, 2017 9:53 pm
What are the admin error logs reporting based on those reported activities?
Nothing, no errors

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 10:03 pm

Since you're using a custom theme, switch back to the default theme and see if you can reproduce the same issues. Also, clear all caches before re-attempting those events.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 10:07 pm

straightlight wrote:
Tue Oct 17, 2017 10:03 pm
Since you're using a custom theme, switch back to the default theme and see if you can reproduce the same issues. Also, clear all caches before re-attempting those events.
I dont have a custom theme, its the default theme, I just changed the colours in the stylesheet and I have cleared all caches in Admin and my browser. I just had a customer contact me saying they cant checkout. Then I tried and now nothing adds to the cart, refresh, it shows, click checkout, but nothing happens :(

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 10:11 pm

The default theme is not supposed to be modified. Rename the folder to something else and re-upload the default theme, clear all caches and see if the issue gets reproduced.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 10:14 pm

Closed it all down, cleared cache again, it worked, tried it twice, worked the first time but 2nd time its back to playing up

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 10:16 pm

I am still seeing the custom over default theme and not the default theme.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 10:34 pm

I only changed colours in the stylesheet, reuploaded the original and its still doing the same thing, I also deleted all the changes in Language Editor in Admin but it still doing it :(

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by AusGirl » Tue Oct 17, 2017 10:38 pm

An error showed up :) lol
PHP Notice: Undefined index: key in admin/controller/design/translation.php on line 412
Last edited by AusGirl on Tue Oct 17, 2017 10:40 pm, edited 1 time in total.

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 10:39 pm

Follow the instructions above and see if the issue still persists. Otherwise, you will be loosing valuable time to troubleshoot an issue that might only be reproduced by using your modified theme.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Oct 17, 2017 10:39 pm

What is on line 412 of that file if you look at the error logs or the error handler?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 10:41 pm

PHP Notice: Undefined index: key in admin/controller/design/translation.php on line 412

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by AusGirl » Tue Oct 17, 2017 10:43 pm

line 412 if ((utf8_strlen($this->request->post['key']) < 3) || (utf8_strlen($this->request->post['key']) > 64)) {
$this->error['key'] = $this->language->get('error_key');

I dont know what that means

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 10:49 pm

Modifications were applied for the admin translation forms lately:

- https://github.com/opencart/opencart/bl ... _form.twig
- https://github.com/opencart/opencart/bl ... _list.twig
- https://github.com/opencart/opencart/bl ... lation.php

Download both files and upload them accordingly to your admin-end. Clear all caches and see if that error message persists.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AusGirl » Tue Oct 17, 2017 11:12 pm

I renamed my theme, uploaded new theme (from original) replaced those files as suggested above, cleared cache, no new errors but still have to refresh to see products in the cart or have them deleted. I have to refresh the Admin as well to see changes now, silly thing

User avatar
New member

Posts

Joined
Sat Sep 09, 2017 3:00 pm


Post by straightlight » Tue Oct 17, 2017 11:15 pm

Check the checkout page to see if it is still not working after making those replacements.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 34 guests