Post by kelemvor » Mon Oct 23, 2017 8:47 am

Just tried to place a test order on a store I'm playing with and got this error:

Code: Select all

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
OK
<b>Warning</b>: ini_set() has been disabled for security reasons in <b>/opencart/system/library/mail/mail.php</b> on line <b>72</b><b>Warning</b>: ini_set() has been disabled for security reasons in <b>/opencart/system/library/mail/mail.php</b> on line <b>72</b>{"redirect":"http:\/\/neys.awhatmom.com\/index.php?route=checkout\/success"}
Seems to be something with sending Mail but the order did go through and I did get both the customer email and the admin email so not sure what the errors mean.
Thanks.

Active Member

Posts

Joined
Fri Oct 12, 2012 6:58 am

Post by straightlight » Mon Oct 23, 2017 9:14 am

Rather seem more like a host restriction for initiating the ini_set function for PHP which prevents to apply specific events. This issue can be resolved if you have access to your php.ini file. Solution posted here: https://stackoverflow.com/questions/340 ... ty-reasons .

Otherwise, you will have to contact your host support to resolve this restriction problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by kelemvor » Mon Oct 23, 2017 10:10 am

I found a php.ini file in my opencart folder but all it has is:

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 64M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.auto_start = Off;
session.use_only_cookies = On;
session.use_cookies = On;
session.use_trans_sid = Off;
session.cookie_httponly = On;
session.gc_maxlifetime = 3600;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;
Is something in there I need to turn off or is there a different php.ini file that I'd need to modify?

Active Member

Posts

Joined
Fri Oct 12, 2012 6:58 am

Post by straightlight » Mon Oct 23, 2017 10:38 am

It is a different one. You'd need to contact your host support if you don't have access to your main php.ini file in order to remove these restrictions.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by kelemvor » Mon Oct 23, 2017 11:09 am

Thanks. I opened a ticket with my host.

Active Member

Posts

Joined
Fri Oct 12, 2012 6:58 am
Who is online

Users browsing this forum: No registered users and 13 guests