Post by Garret H » Sat Aug 04, 2018 3:56 pm

Hello,

I just installed OC 3.0 and migrated all my orders and info over from 1.5.6.4 using Excelport. I initially installed the site in its own folder and everything worked great. I moved it over to the root and now I'm getting "error undefined" when trying to edit or delete an order.

I searched the issue and it appears to be an SSL problem but I couldn't find any legitimate solves. Help!

New member

Posts

Joined
Wed Jan 25, 2012 12:20 am

Post by straightlight » Sat Aug 04, 2018 8:24 pm

As a new forum user, please read the forum rules. Error / server access logs unprovided.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Garret H » Sun Aug 05, 2018 12:18 am

I checked the error log after trying to delete an order and there are no errors showing for the the current time. When I try to delete a order, I get a pop-up saying, "error undefined."

New member

Posts

Joined
Wed Jan 25, 2012 12:20 am

Post by straightlight » Sun Aug 05, 2018 4:14 am

Did you created your API account? Also, are you using any Anti-Fraud extension modules?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Garret H » Sun Aug 05, 2018 5:21 am

Yes on API, no on fraud extensions.

New member

Posts

Joined
Wed Jan 25, 2012 12:20 am

Post by straightlight » Sun Aug 05, 2018 5:42 am

What is the full error message of the API error message?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Garret H » Sun Aug 05, 2018 5:56 am

It just says "Error undefined"

What's strange is the website functions just fine in the subfolder but I get these errors when I move it to the root. The other option is I can just leave it in the subfolder if there's a way to make it so the www.mysite.com points to www.mysite.com/oc3

Thanks for your assistance

New member

Posts

Joined
Wed Jan 25, 2012 12:20 am

Post by straightlight » Sun Aug 05, 2018 9:04 pm

Duplicated topic: viewtopic.php?f=199&t=206183#p731096 . Twisted words.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MrPhil » Sun Aug 05, 2018 9:31 pm

Garret H wrote:
Sun Aug 05, 2018 5:56 am
What's strange is the website functions just fine in the subfolder but I get these errors when I move it to the root. The other option is I can just leave it in the subfolder if there's a way to make it so the www.mysite.com points to www.mysite.com/oc3
It's always a bad idea to move an existing store from its original position (the subfolder). If the whole point of the exercise is to eliminate the need for a customer to type in "/oc3", it's better to rewrite the URL in /.htaccess (assuming you're on a server that permits this). The following will rewrite a visit to https://www.mysite.com to https://www.mysite.com/oc3 without the customer having to do any extra effort:

Code: Select all

RewriteEngine On
# force https and www.
RewriteCond  %{HTTPS}  !on  [OR]
RewriteCond  %{HTTP_HOST}  !^www\.  [NC]
RewriteRule  ^(.*)$   https://www.mysite.com/$1  [R=301,L]
# if visit to root, jump to /oc3
RewriteCond  %{REQUEST_URI}  !^/oc3 
RewriteRule  ^(.*)$  /oc3/$1
It also forces SSL usage (https), and the use of www. in the domain name. Most sites want to do it that way. The rewrite to /oc3 is invisible until some other link is clicked, when /oc3 will start showing up. Your internal links in your store (defined in the configure.php files) should still contain /oc3.

The advantage to doing it this way is that if you later add a "landing page" /index.html (for instance) to welcome visitors and direct them to various parts of the site (blog, gallery, etc.), all you have to do is remove the rewrite to /oc3 and all the existing bookmarks and search engine entries will still be valid.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by Garret H » Fri Aug 17, 2018 4:58 am

Thank you both for your help.

I've used 1.5.6.4 for almost 7 years now. I upgraded to 3.0 because my site was constantly getting hacked. I was hoping 3.0 would be better than 1 .5.6.4 which had a ton of glitches and required numerous mods to fix. Sadly, I see it is no different. Simple things such as the contact us page didn't work properly. Opencart has some serious development issues and sadly, I don't have the time and money to spend fixing it like I did with 1.5.6.4. I've made the migration over to Shopify. The $26 a month is nothing compared to the thousands I've spent trying to keep OC working right over the years. It's refreshing to use a cart system that actually works properly out of the box.

New member

Posts

Joined
Wed Jan 25, 2012 12:20 am

Post by yas » Mon Feb 24, 2020 7:51 pm

i have moved admin folder from primary domain to subdomain please help solve my issue,while editing its showing 'error undefined',i am not getting what is exact error.but its working in primary domain

yas
Newbie

Posts

Joined
Mon Feb 24, 2020 1:24 pm

Post by letxobnav » Mon Feb 24, 2020 8:22 pm

use your browser developer tools when doing these things and check the console/network tabs for errors.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by yas » Tue Feb 25, 2020 3:00 pm

Thanks for your help..
but i am getting error - Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://www.xyz.com/index.php?route=api/ ... store_id=0. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

yas
Newbie

Posts

Joined
Mon Feb 24, 2020 1:24 pm

Post by letxobnav » Tue Feb 25, 2020 3:30 pm

so you are either mixing http and https or www and non-www or both, check your config.php files to make sure all servers are set to the same.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by yas » Tue Feb 25, 2020 3:39 pm

for the sub domain of admin config file
define('HTTP_SERVER', 'http://admin.xyz.com/');
define('HTTP_CATALOG', 'http://www.xyz.com/');
//define('HTTP_IMAGE', 'http://www.xyz.com/');

// HTTPS
define('HTTPS_SERVER', 'http://admin.xyz.com/');
define('HTTPS_CATALOG', 'http://www.xyz.com/');
define('HTTPS_IMAGE', 'http://www.xyz.com/');

// DIR
define('DIR_APPLICATION', '/home/xyz/admin_xyz_com/admin/');

i have used like this for admin

yas
Newbie

Posts

Joined
Mon Feb 24, 2020 1:24 pm

Post by yas » Tue Feb 25, 2020 4:00 pm

FIRST OF ALL THANK YOU FOR YOUR HELP.
WHAT IS THE SOLUTION FOR IT,I AM NEW TO OPENCART CAN YOU SUGGEST ME TO SOLVE THIS ISSUE,I HAVE USED SUB DOMAIN FOR ADMIN PLEASE CHECK ABOVE DETAILS

yas
Newbie

Posts

Joined
Mon Feb 24, 2020 1:24 pm

Post by letxobnav » Tue Feb 25, 2020 4:09 pm

oh, you are putting admin in a sub-domain, kinky, any reason for that or just because you can?

In any event, that is the problem, your calls via api from admin sub-domain to the catalog sub-domain is not allowed.
You could try this in htaccess, straight from stack overflow, it is supposed to set the correct CORS headers for sub-domains:

Code: Select all

SetEnvIf Origin ^(https?://.+\.mywebsite\.com(?::\d{1,5})?)$   CORS_ALLOW_ORIGIN=$1
Header append Access-Control-Allow-Origin  %{CORS_ALLOW_ORIGIN}e   env=CORS_ALLOW_ORIGIN
Header merge  Vary "Origin"
(adapt to your domain)

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by letxobnav » Tue Feb 25, 2020 4:10 pm

Trust me, I can read lower-case text just fine without glasses.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by yas » Tue Feb 25, 2020 4:21 pm

thank you, you are genius its working for me,,thanks a lot....

i need to send sms once admin changed order status can you please help me to guide,i had tried but its not possible please help me

yas
Newbie

Posts

Joined
Mon Feb 24, 2020 1:24 pm

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România
Who is online

Users browsing this forum: No registered users and 31 guests