Post by ihateusernames » Wed Aug 14, 2019 9:22 pm

Hi,
In order to install an import/export extension, OC or the extension builder is requesting I install an API key into OC.
Can someone please let me know how to do this & where? Is this a request to install my server key or OC's? Or what?
It's about as clear as mud to me at the moment.
I tried to contact the extension builders support but it refuses to let me even leave a comment without the API key been installed somewhere?
I'm looking through all OC's menus and I can't see anything API connected or related.
?????????
Anyone with some help would be greatly appreciated.
Thanks.

New member

Posts

Joined
Wed Jul 24, 2019 10:31 am

Post by Johnathan » Wed Aug 14, 2019 10:36 pm

The API system in OpenCart can be found in System > Users > API. You should be able to add new API users / IPs in there.

It's used for some functionality that requires accessing the front-end, like editing orders, but some extensions also leverage it for other things they do.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by ihateusernames » Thu Aug 15, 2019 10:42 am

Thanks Jonathan,

Found the API settings now, as per your instructions.

Everything there looks in good order with the key already installed. So I guess I'll just have to wait for the developer to get back to me with a fix for the installation issue.

Thanks for your help.

New member

Posts

Joined
Wed Jul 24, 2019 10:31 am

Post by ihateusernames » Sat Aug 17, 2019 2:23 pm

Still no response from the extension developer. So not sure how to resolve this issue?

Using OC Version 3.0.3.2


New member

Posts

Joined
Wed Jul 24, 2019 10:31 am

Post by ihateusernames » Sat Aug 17, 2019 2:35 pm

Currently, the error message when installing the import/export extension states...' mismatched signature hash'. No response from developer. Any help appreciated. Thanks.

Using OC Version 3.0.3.2


New member

Posts

Joined
Wed Jul 24, 2019 10:31 am

Post by Johnathan » Sat Aug 17, 2019 10:47 pm

Are you trying to install it directly from the 3.0 marketplace? That message is one that is typical of using that functionality. If so, you need to hook up your OpenCart store to the marketplace in your installation. You can do that in Extensions > Marketplace by clicking the red warning sign at the top of the page, then following the instructions in the help text in the pop-up.

Alternately, just download the extension files from your account on opencart.com, and then install using the OpenCart extension installer. That will also install the extension without having to use that direct marketplace link.

If that's not your issue, I'm afraid I probably can't assist if it's internal to their extension. If they won't respond, you might consider hiring someone else. If you need to find a developer, you can post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by ihateusernames » Sun Aug 18, 2019 7:47 pm

Thanks Jonathan,

Yes, I'm using the market place link in OC. I've gone through the API secret process & it gets flagged as being installed correctly. Then I try to install the extension but that's when it states there's an error that the signature key doesn't match. I have installed an extension previously but I can't recall if I downloaded it on my laptop or used the market place? Not sure/can't remember?

Small rant: Having used OC now for a couple of weeks, I'm beginning to think it's very poorly laid out. It looks like they are trying to make things more difficult to edit rather than simplifying the process. Having seen some YouTube videos of version 2, this latest version 3 has fewer editing facilities & files & folders spread even further apart. Is this the general consensus?

Anyway, thanks for your help so far.

New member

Posts

Joined
Wed Jul 24, 2019 10:31 am

Post by Johnathan » Mon Aug 19, 2019 10:37 pm

3.0 has some good new features, like the theme editor and removing FTP requirements for the installer. However, it needs a lot of polish, and there are still bugs in the main branch 2 years after it was released (like the theme editor not being compatible with any ocMod that edits the same file). Because of that, it doesn't have a very good reputation with developers, so many of us are still recommending using 2.3 for new installations. I'm hopeful that 3.1 will address all these issues and add some other improvements, but I haven't checked out the beta versions at this point to see what's changed.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by ihateusernames » Tue Aug 20, 2019 10:52 am

Thanks Jonathan,

That's interesting to hear. So basically they released v.3 too early.

I installed via my hosting server, so I didn't use the ftp installation. However, I do have to use ftp to upload images & icons etc, as you can only upload 1 image at a time in oc, which is pretty useless for most shops/stores/wholesalers/etc. I can only speak as a new user of oc, but I've found it very chaotic & not at all simple to use. The layout is very confusing & changing anything requires a lot of patience & research. There's no easy user guide to follow & it's taken up way more of my time than it should, to upload a catalogue of products. I still have hours of editing to do to get a store that will look 'just ok'. I'll then have to do further programming to get the features I need.

But thanks for the help & comments, they are appreciated.

New member

Posts

Joined
Wed Jul 24, 2019 10:31 am
Who is online

Users browsing this forum: thekrotek and 68 guests