Page 1 of 1

Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 4:15 pm
by khurramsch
Hi Guys,
I have a site on opencart 3.0.2.0. It was working fine but suddenly it has started to misbehave.
When i open it with domain name only https://iualiving.co.uk/
It gives page not found - Categories error. Which means somehow its considering homepage as a category.

However, on clicking continue OR clicking on Logo or using the route link https://iualiving.co.uk/index.php?route=common/home

It opens the home page perfectly. It was working fine for 1 - 2 months since developed.

Any suggestion how to sort this out. I have tried disabling & enabling SEO URLS and no effect on it. Uninstalled any modifications there were. but still the same issue. Its considering home as category. I am ok to use route common link for homepage if that works.

Please advise.

Many Thanks

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 5:42 pm
by JNeuhoff
What's in your '.htaccess' file? Any additional redirects?

Also check your 'oc_seo_url' DB table. Does it contain entries where the 'keyword' field is empty?

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 6:29 pm
by khurramsch
JNeuhoff wrote:
Sat Aug 08, 2020 5:42 pm
What's in your '.htaccess' file? Any additional redirects?

Also check your 'oc_seo_url' DB table. Does it contain entries where the 'keyword' field is empty?
Hi, thank you for your reply.
.htaccess is below:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
I have checked OC_SEO_URL table, there is no entry with empty keyword field.

Thanks

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 6:56 pm
by letxobnav
I think it is a server setting issue, not using index.php as default.
if you use:

Code: Select all

https://iualiving.co.uk/index.php
it also works and has no relation to seo urls.

then again, you have more issues:

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 7:01 pm
by khurramsch
letxobnav wrote:
Sat Aug 08, 2020 6:56 pm
I think it is a server setting issue, not using index.php as default.
if you use:

Code: Select all

https://iualiving.co.uk/index.php
it also works and has no relation to seo urls.

then again, you have more issues:
thanks for your help. what you suggest? shall i contact hosting and confirm if its using index.php as default?

thanks

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 7:15 pm
by JNeuhoff

Re: Home page working as Category & showing not found

Posted: Sat Aug 08, 2020 9:01 pm
by letxobnav
you can put this in your htaccess

Code: Select all

<IfModule dir_module>
    DirectoryIndex index.php 
</IfModule>
but normally that is set on a server host/virtual host level, so better check with your host if they forgot something there.

Re: Home page working as Category & showing not found

Posted: Sun Aug 09, 2020 12:03 am
by khurramsch
Thank you guys for your help.

added the code in .htaccess however that didnt work
So contacted the hosting provider and came to know that mod_security rules triggered. That is why it wasnt working so not that has been whitelisted and its working.

thanks

Re: Home page working as Category & showing not found

Posted: Mon Aug 10, 2020 5:53 pm
by paulfeakins
khurramsch wrote:
Sun Aug 09, 2020 12:03 am
its working.
Please add [SOLVED] to the beginning of the post title.