Post by wazawaza84 » Sat Sep 19, 2020 2:56 pm

Hello all,

I am running a 3.0.2.0 Opencart, began facing some issues when the host changed to the latest php. The issues originated from extensions that I have not updated. Once those got updated and everything started working well in the back end, the front end completely crashed. I am getting the following:

Fatal error: require_once(): Failed opening required '/home/xxxxx/public_html/zzzzzzzzz.com/system/library/google_marketing_tools/includes/footer.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/xxxxx/public_html/storage/modification/catalog/controller/common/footer.php on line 67

I am not sure what to do, please support :)

Newbie

Posts

Joined
Sat Sep 19, 2020 2:51 pm

Post by EvolveWebHosting » Sat Sep 19, 2020 11:16 pm

wazawaza84 wrote:
Sat Sep 19, 2020 2:56 pm
Hello all,

I am running a 3.0.2.0 Opencart, began facing some issues when the host changed to the latest php. The issues originated from extensions that I have not updated. Once those got updated and everything started working well in the back end, the front end completely crashed. I am getting the following:

Fatal error: require_once(): Failed opening required '/home/xxxxx/public_html/zzzzzzzzz.com/system/library/google_marketing_tools/includes/footer.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/xxxxx/public_html/storage/modification/catalog/controller/common/footer.php on line 67

I am not sure what to do, please support :)
Does the file mentioned in the error message actually exist? I would try clearing the Opencart modification cache a couple of times.

I see from the error message that they are using PHP 7.4 . Instead, is it possible to try PHP 7.3? Both versions are fully supported (by the PHP developers). https://www.php.net/supported-versions.php

Image
Shared Hosting for $12 for the first year. Use the code $12ANNUAL and choose annual term. Free transfers too!
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by thekrotek » Sun Sep 20, 2020 12:06 am

Error says for itself: there's no such file and thus it can not be included. There's no google_marketing_tools in default OC package, so contact extension developer on the matter.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member
Online

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by rjcalifornia » Mon Sep 21, 2020 6:17 am

wazawaza84 wrote:
Sat Sep 19, 2020 2:56 pm
Hello all,

I am running a 3.0.2.0 Opencart, began facing some issues when the host changed to the latest php. The issues originated from extensions that I have not updated. Once those got updated and everything started working well in the back end, the front end completely crashed. I am getting the following:

Fatal error: require_once(): Failed opening required '/home/xxxxx/public_html/zzzzzzzzz.com/system/library/google_marketing_tools/includes/footer.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/xxxxx/public_html/storage/modification/catalog/controller/common/footer.php on line 67

I am not sure what to do, please support :)
Disable third party extensions/vqmod. It seems like Google Marketing Tools is having some issues. Try reaching the developer about it.

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by wazawaza84 » Mon Sep 21, 2020 6:30 pm

thank you for your replies. Is there a way to know which extension is causing this. I dont remember deploying any thing like that.. so I am a big confused and lost.

Newbie

Posts

Joined
Sat Sep 19, 2020 2:51 pm

Post by thekrotek » Mon Sep 21, 2020 6:48 pm

wazawaza84 wrote:
Mon Sep 21, 2020 6:30 pm
thank you for your replies. Is there a way to know which extension is causing this. I dont remember deploying any thing like that.. so I am a big confused and lost.
I already told you which extension, see my reply.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member
Online

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by wazawaza84 » Mon Sep 21, 2020 7:57 pm

thekrotek wrote:
Mon Sep 21, 2020 6:48 pm
wazawaza84 wrote:
Mon Sep 21, 2020 6:30 pm
thank you for your replies. Is there a way to know which extension is causing this. I dont remember deploying any thing like that.. so I am a big confused and lost.
I already told you which extension, see my reply.
I looked over all of the extensions I have, there is nothing called Google Marketing Tools thats why I am confused

Newbie

Posts

Joined
Sat Sep 19, 2020 2:51 pm

Post by by mona » Mon Sep 21, 2020 8:26 pm

Well one would suspect that you did and have remove it, which is why it can’t find it.
1. Refresh your modifications top left and make sure that if/when you removed it you did in fact update your modifications.

2. Go to line storage/modification/catalog/controller/common/footer.php on line 67 - It may have a note who wrote it or what it is from
go through the extensions you have installed and in the xml file that line will be there THAT IS THE MODIFICATION causing the problem.
As thekrotek says - something like google marketing tools, that does not mean that is exactly the same name but a direction.

Maybe your theme of course, it is impossible to pinpoint it, only to direct you on what you can check to find it.

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by rjcalifornia » Thu Sep 24, 2020 9:26 am

wazawaza84 wrote:
Mon Sep 21, 2020 7:57 pm


I looked over all of the extensions I have, there is nothing called Google Marketing Tools thats why I am confused
Well, look at every extension. One of them has those marketing tools and it is giving you problems

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide
Who is online

Users browsing this forum: Bing [Bot] and 25 guests