Post by ken516888 » Sun Apr 11, 2021 7:03 pm

HI
I'm use OC 3.0.3.6 , I don't know why my OC Rewards points are not subtracting, when when I changed its status on Complete.

This allows the user to spend his points over and over again, since they never get discounted, not even after an order is processed and complete.

We don't want to update the system. We have many extensions installed, and a custom Theme, which make it even more difficult. Does anyone know of a way to fix this rewards problem, on the version of OC3.0.3.6?

Newbie

Posts

Joined
Fri Apr 14, 2017 4:25 pm

Post by by mona » Sun Apr 11, 2021 11:32 pm

Check you have set it up correctly
viewtopic.php?t=200017

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by ken516888 » Mon Apr 12, 2021 12:43 am

HI
Thank for reply
I have tried this method, but it still doesn't work.
by mona wrote:
Sun Apr 11, 2021 11:32 pm
Check you have set it up correctly
viewtopic.php?t=200017

Newbie

Posts

Joined
Fri Apr 14, 2017 4:25 pm

Post by by mona » Mon Apr 12, 2021 1:16 am

test on 3.0.3.6 works both with setting it to complete and to pending
Check again -
Set processing to pending
Set complete to complete

NB: Setting to complete is not ideal because it won’t subtract until the order is complete - not ideal - pending works as I would expect it

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am
Who is online

Users browsing this forum: No registered users and 27 guests