Post by Marzy1357 » Wed Apr 24, 2019 8:18 pm

Hi, I have weird stuff going on with my OC 3.0.2.0 and VQMOD.

My website was working fine for a couple of months, and stopped working randomly (get below error when try to visit my website). I didn't change anything in files, settings, just stopped working and this error.

So if I go to vqmod/vqcache and delete all the files from there, my website starts working and after some time (hours or a day) it stops working again, so basically if I want to keep my website on I need to delete that cache folder every day.

Can anyone help me to sort this issue? Thanks

"Warning: require_once(/home/myweb/public_html/vqmod/vqcache/composer/autoload_real.php): failed to open stream: No such file or directory in /home/myweb/public_html/vqmod/vqcache/vq2-_home_myweb_storage_vendor_autoload.php on line 5

Fatal error: require_once(): Failed opening required '/home/myweb/public_html/vqmod/vqcache/composer/autoload_real.php' (include_path='.:/opt/cpanel/ea-php72/root/usr/share/pear') in /home/myweb/public_html/vqmod/vqcache/vq2-_home_myweb_storage_vendor_autoload.php on line 5"

Newbie

Posts

Joined
Sat Jan 16, 2016 6:09 pm

Post by Marzy1357 » Fri Apr 26, 2019 8:29 pm

After deleting cache yesterday, website is no longer working today with another random error:

Fatal error: Uncaught Error: Class 'Controllercommonfooter' not found in /home/naturima/public_html/vqmod/vqcache/vq2-_home_naturima_storage_modification_system_engine_action.php:71 Stack trace: #0 /home/naturima/public_html/vqmod/vqcache/vq2-_home_naturima_storage_modification_system_engine_loader.php(48): Action->execute(Object(Registry), Array) #1 /home/naturima/public_html/catalog/controller/common/home.php(16): Loader->controller('common/footer') #2 /home/naturima/public_html/vqmod/vqcache/vq2-_home_naturima_storage_modification_system_engine_action.php(79): ControllerCommonHome->index() #3 /home/naturima/public_html/catalog/controller/startup/router.php(25): Action->execute(Object(Registry)) #4 /home/naturima/public_html/vqmod/vqcache/vq2-_home_naturima_storage_modification_system_engine_action.php(79): ControllerStartupRouter->index() #5 /home/naturima/public_html/system/engine/router.php(67): Action->execute(Object(Registry)) #6 /home/naturima/public_html/system/engine/router.php(56): Router->execute(Object(Action in /home/naturima/public_html/vqmod/vqcache/vq2-_home_naturima_storage_modification_system_engine_action.php on line 71

Newbie

Posts

Joined
Sat Jan 16, 2016 6:09 pm

Post by kestas » Fri Apr 26, 2019 9:21 pm

You can try to disable all xml files (modules) you have installed, by changing in vqmod/xml folder " your_module.xml" to "your_module.xml_" (without quotes) except vqmod_opencart.xml. After that delete all files from vqmod/vqcache folder and delete all files (except index.html), from storage/modification folder.
It should help to access your site. And do not use vqmod in OC 3 version.

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by grgr » Sat Apr 27, 2019 2:03 pm

kestas wrote:
Fri Apr 26, 2019 9:21 pm
And do not use vqmod in OC 3 version.
There is a known issue with vQmod and OC3 where the storage folder is ABOVE the store root (i.e. not accessible from the internet) which is suggested to do when you first login to the admin (the warning popup). If you have the storage directory within the store root then there is no problem.

A workaround is to just implement an automatic deletion of the 2 cache files.

-
Image Image Image Image
VIEW ALL EXTENSIONS * EXTENSION SUPPORT * WEBSITE * CUSTOM REQUESTS


User avatar
Active Member

Posts

Joined
Mon Mar 28, 2011 4:08 pm
Location - UK
Who is online

Users browsing this forum: Google [Bot] and 6 guests