Post by Sportfreunde » Sun Dec 22, 2019 8:10 pm

Hallo zusammen

Ich wollte anstatt die PHP Mail funktion im Opencart Shop auf SMTP umschalten. Habe die ganzen Einstellungen vorgenommen und auch nochmals im Inet geschaut. Doch leider bekomme ich immer die Fehlermeldung nach dem Bestellabschluss:

***********************************************

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
OK
<br />
<b>Fatal error</b>: Uncaught Exception: Error: Connection refused (111) in /home/...../public_html/system/library/mail/smtp.php:90
Stack trace:
#0 /home/...../public_html/system/library/mail.php(142): Mail\Smtp-&gt;send()
#1 /home/...../public_html/catalog/controller/mail/order.php(275): Mail-&gt;send()
#2 /home/...../public_html/catalog/controller/mail/order.php(34): ControllerMailOrder-&gt;add(Array, '1', 'Bitte angezeigt...', true)
#3 /home/...../storage/modification/system/engine/action.php(79): ControllerMailOrder-&gt;index('checkout/order/...', Array)
#4 /home/...../public_html/system/engine/event.php(62): Action-&gt;execute(Object(Registry), Array)
#5 /home/...../storage/modification/system/engine/loader.php(232): Event-&gt;trigger('model/checkout/...', Array)
#6 /home/...../public_html/system/engine/proxy.php(47): Loader-&gt;{closure}(Array, Array)
#7 /home/...../public_html/catalog/controller/extension/payment/bank_transfer.php(23): Proxy-&gt;__call('addOrderHistory', Array)
#8 /ho in <b>/home/...../public_html/system/library/mail/smtp.php</b> on line <b>90</b><br />

***************************************************************************

Ausgefüllt ist es eigentlich auch wie beschrieben auf: https://bit.ly/34J4gJz

Weiss einer wieso ich diese Fehlermeldungen immer bekomme?

New member

Posts

Joined
Sat Nov 30, 2019 4:46 am

Post by IP_CAM » Sun Dec 22, 2019 11:02 pm

Meine Hostpoint Server haben SMTP auf Port 587 in smtp.jacob.ch

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'100 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Sportfreunde » Tue Dec 24, 2019 1:23 am

Nein bei mir ist es definitiv 465. An was könnte es sonst noch liegen? Eine Ahnung?

New member

Posts

Joined
Sat Nov 30, 2019 4:46 am

Post by IP_CAM » Thu Dec 26, 2019 10:23 am


I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'100 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Sportfreunde » Fri Jan 03, 2020 12:34 am

Leider fand ich nichts was mich weiter brauchte. Auch die Beschreibung von Opencart:

https://www.opencart-templates.co.uk/ma ... nformation

Funktioniert für MICH nicht. Kann das evtl. an den Panel Einstellungen liegen? Auch mein Mailprovider kann das Problem nicht verstehen.

Es muss doch eine Lösung geben oder bin ich der Einzige mit dem Problem? Das kann ich nicht glauben :)

Grüsse

New member

Posts

Joined
Sat Nov 30, 2019 4:46 am

Post by Galaxywarrior » Sat Jan 11, 2020 6:07 am

Hast Du unter System/Settings/deinStore/Mail im Feld "SMTP Hostname" den prefix ssl:// oder tls://smtp.deinServer.com verwendet?

enjoy

•••••••••••••••••••••••

Open Cart v3.032
Beginner


User avatar
Newbie

Posts

Joined
Mon Nov 04, 2019 4:21 pm
Who is online

Users browsing this forum: No registered users and 5 guests