Post by ybpc_tj » Tue Sep 01, 2020 9:45 pm

My website(Opencart 3.0.2.0) hosted at Crazydomains and the email hosted at Gsuite. I found that website mail notification works but it will stop working after frequently send/receive. I have contacted Google. The tech have checked everything at google admin console and found no problem. And then contacted hosting provider. I had over 30 emails communications with them. Finally, They told me that email triggered the max limitation defer list. That means my domain name is added in the deferred list after reach the limits. After a couple of hours, the system will be refreshed and my domain name in the defer list will be removed. And email notification in the website will work again. As by default setting of Opencart, configure 'mail' and port 25 works for email address hosted at local mail sever. But configure 'SMTP' and port either 465 or 587 will not work. Therefore, the hosting provider asked me to use a plugin as PHPmailer to configure SMTP authorisation. I was wondering what the problem is from? Dose PHPmailer will solve email problem?

Here is feedback from hosting provider.

Upon further investigation, It seems like your script is trying to send mail via system "mail" command. Thus, to avoid the same issue, kindly use a mail plugin/class (like PHPMailer) and please configure SMTP authorization to send these emails.

Newbie

Posts

Joined
Thu Jun 23, 2011 8:18 am

Post by letxobnav » Tue Sep 01, 2020 10:39 pm

you can use smtp instead of php sendmail if you select it in admin, no need to install phpmailer.
just use ssl://stmphostname on port 465 or tls://smtphostname on port 587 that will force authentication.

if that does not work because your mail server does not accept those, installing phpmailer will not solve that, it is much better class but in OC will not do more than the default smtp class.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by paulfeakins » Wed Sep 02, 2020 9:49 pm

ybpc_tj wrote:
Tue Sep 01, 2020 9:45 pm
please configure SMTP authorization to send these emails.
There's some info about this here: https://www.antropy.co.uk/blog/how-to-s ... sing-smtp/

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by ybpc_tj » Thu Sep 03, 2020 12:17 am

letxobnav wrote:
Tue Sep 01, 2020 10:39 pm
you can use smtp instead of php sendmail if you select it in admin, no need to install phpmailer.
just use ssl://stmphostname on port 465 or tls://smtphostname on port 587 that will force authentication.

if that does not work because your mail server does not accept those, installing phpmailer will not solve that, it is much better class but in OC will not do more than the default smtp class.
Thanks. I did configure 'SMTP’ instead of 'mail'. But the loading icon keep spinning when I submit a message enquiry at website front-end. I did some topic. People said phpmailer will work for Gsuite issue. I am not sure whether will solve my issue.

Newbie

Posts

Joined
Thu Jun 23, 2011 8:18 am

Post by ybpc_tj » Thu Sep 03, 2020 12:20 am

paulfeakins wrote:
Wed Sep 02, 2020 9:49 pm
ybpc_tj wrote:
Tue Sep 01, 2020 9:45 pm
please configure SMTP authorization to send these emails.
There's some info about this here: https://www.antropy.co.uk/blog/how-to-s ... sing-smtp/
Thanks for your reply. I did configure SMTP. It is does not work. Even message enquiry can not go through. Loading icon keep spininig after I submit a enquiry form.

Newbie

Posts

Joined
Thu Jun 23, 2011 8:18 am

Post by sw!tch » Thu Sep 03, 2020 4:13 am

ybpc_tj wrote:
Thu Sep 03, 2020 12:20 am
paulfeakins wrote:
Wed Sep 02, 2020 9:49 pm
ybpc_tj wrote:
Tue Sep 01, 2020 9:45 pm
please configure SMTP authorization to send these emails.
There's some info about this here: https://www.antropy.co.uk/blog/how-to-s ... sing-smtp/
Thanks for your reply. I did configure SMTP. It is does not work. Even message enquiry can not go through. Loading icon keep spininig after I submit a enquiry form.
Contact your web host again explain you still cant send email even with SMTP. They are best to debug this, some hosting companies will throttle mail if too much is being sent at once.

Backup and learn how to recover before you make any changes!
Full Stack Web Developer :: Contact via PM for custom work.


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA

Post by letxobnav » Thu Sep 03, 2020 7:23 am

Loading icon keep spininig after I submit a enquiry form.
Then you have other issues than mail.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan
Who is online

Users browsing this forum: No registered users and 31 guests