Post by mxmark » Tue Jan 19, 2021 5:48 am

Okay guys and gals,

I feel like I’ve been left with no option but to ask this question, because my website host is moving their servers to php 7.4 and making anything lower than 7.2 obsolete very soon.

I’m currently running OC 1.5.6.4 with an updated encryption file, and updated config files to allow my site to run on php 7.2. If I raise my php level from 7.2 to 7.3 or 7.4 then all kinds of things start to go wrong on the backend. I begin to see all kinds of errors in the log.

Now I know that Journal 2 is hated by most mods on here, but please bear with me here because I’m not looking for any support for the Journal 2 theme, but nevertheless, I do have to mention it because it plays a big part in what is happening.

When I change my php level to 7.3 or 7.4 then all kinds of errors begin to happen and all with the dreaded journal 2 info in them.
Obviously, my next move was to contact the developers about this, but to my surprise they don’t support Journal 2 anymore, only the new Journal 3, so it looks like if I want to continue to use the Journal theme, I have to upgrade my OC site to either 2.x or 3.x in order for them to support it!

This is a real headache whichever way I look at it and I could have done without it, but I suppose all good things come to an end sooner or later and I have to move with the times, which brings me nicely to the title of this post…OpenCart 1.5x, 2x or 3x…What’s the best & why do you consider it to be the best version?

• Do the later versions have any more goodies included in them as opposed to version 1.5x?
• Are there any other alternative feature rich responsive themes for OC?
• Will 2 or 3 work okay with php 7.4?
• Are there more extensions available for the later versions?
• Can OC be upgraded from 1.5x to the later version without the need for any extensions?
• How easy is it to upgrade from 1.5.6.4 to the later versions?

All your feedback would be greatly appreciated ;)

Cheers!
Mark

New member

Posts

Joined
Tue Dec 23, 2014 12:06 am
Location - Greater Manchester, UK

Post by IP_CAM » Tue Jan 19, 2021 6:38 am

please bear with me here because I’m not looking for any support for the Journal 2 theme ...
Well, sure you do, just without beeing aware of. And this, because a default
themed OC v.1.5.6.4, with a new encryption.php file, could still work, by
use of a PHP v.7.4.x Version, depending on additional extensions installed.
But in Combination with the Theme you use, it most likely won't. 8)
Ernie
Last edited by IP_CAM on Thu Jan 21, 2021 5:31 am, edited 1 time in total.

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'100 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by JNeuhoff » Tue Jan 19, 2021 5:56 pm

With regards to web themes: Make sure to use a standard-compliant web theme, and stay clear of poorly written frameworks like Journal3. The latter is not supported by the OC community here for a good reason.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by xxvirusxx » Tue Jan 19, 2021 6:13 pm

I'm curious if other themes that are in the Marketplace are standard-compliant :laugh: but they are allowed there.

LE.
This code from system\journal2\classes\journal2_utils.php on line 478

Code: Select all

'box-shadow: ' . implode($res, ' ')
should be:

Code: Select all

'box-shadow: ' . implode(' ', $res)
This code from catalog\view\theme\journal2\template\journal2\assets\css.tpl on line 4

Code: Select all

<?php echo $selector['selector'] . "{" . implode($selector['properties'], ';') . "}" . PHP_EOL; ?>
should be:

Code: Select all

<?php echo $selector['selector'] . "{" . implode(';', $selector['properties']) . "}" . PHP_EOL; ?>
Last edited by xxvirusxx on Tue Jan 19, 2021 7:10 pm, edited 1 time in total.

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by IP_CAM » Tue Jan 19, 2021 6:57 pm

I'm curious if other themes that are in the Marketplace are standard-compliant :laugh: but they are allowed there.
Well, that might be the case :D , but a very few of them require ~2'700 - 5'000+ lines of Source Code,
just to i.E. display a simple Category or Product Page. :crazy: , in contrary to a well compressed
'regular' type 2-liner Bootstrap OC 2 type Theme ... :laugh:
Last edited by IP_CAM on Thu Jan 21, 2021 5:30 am, edited 3 times in total.

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'100 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by mxmark » Wed Jan 20, 2021 5:21 am

IP_CAM wrote:
Tue Jan 19, 2021 6:38 am
please bear with me here because I’m not looking for any support for the Journal 2 theme ...
Well, sure you do, just without beeing aware of. And this, because a default
themed OC v.1.5.6.4, with a new encryption.php file, could still work, by
use of a PHP v.7.4.x Version, depending on additional extensions installed.
But in Combination with the Theme you use, it most likely won't. 8)

And your Theme is also the reason, why your Topic has been moved now into
the commercial Forum Section, it could have been deleted as well, what's
usually the case, when it comes to Journal lately here. I just moved it here,
because I am also a v.1.5.6.x Freak, and possibly, others will be confronted
with similar Problems, and so at least find a usable answer to this matter here.

And the main reason for that is, that Opencart itself never had any relations to/with
Journal, and never made a single Cent on/with Journal. So, there is absolutely no
Reason, why this Forum should support a Software, who has never been adding to
OC's wealth. :laugh:

In addition to the well-known Fact, that Journal belongs to the most stolen OC
Theme Extensions on Earth. So, should this Place really serve as Platform, to
support all those Thiefs and Crooks as well, just to make them feel good ? :crazy:
It would be contrary to any Business Logic, not to act accordingly, and get rid
of them here, I assume, you at least would agree on this ...

They made a few hundred GRANDS of Profit out of Journal Sales, but never cared
about, creating their own free Journal User Forum, likely aware of, that all the dark
Sheeps of the OC-Journal-Scene would be trying to take advantage of it too ... :laugh:
Just visit the Facebook Opencart Forums, to get an impression on how many of
those mostly darknet OC-Journal-Users are steady looking for free help ...

Whatever, possibly, one of the OC Professionals around here might be willing,
to assist you on getting your Site to work with PHP v.7.4.x, but sure not for free.

And don't get angry, OC is all about Business, as you're well aware of, and it's not
meant personal either. You might think about upgrading to another OC Version,
but then, your Database Content would no longer function, as it exists. Or you
could try, to just slightly move up to a 'latest' 1.5.6.5_Release Candidate Version,
to likely avoid large cost, related with a move further up, to either one of the latest
(custom upgraded) v.2.3.0.2 (+) Releases, to be found on my Github Repository Site.
OC v.3.x Versions are a completely different story, compared with anything before.
Ernie
Okay Ernie, I hear what you're saying and completely get it about the dreaded 'J' theme.

I know you think I made my post to ask for help with the 'J' Theme, but I promise you, I didn't. I wasn't aware of all the history on how that theme came about, so thank you for educating me about it.

After hearing everything you've said about it, I'm extremely willing to move away from using that theme any longer. I think the main reason why most people use it (including myself) is because of the massive list of tools included in the theme and how it allows us mere mortals the chance to edit our own sites with regards to styling and layouts without knowing how to code.
In other words it's the convenience of the theme that attracts us none coders (like myself) to it. But if I can find an alternative responsive theme that allows me to make my site look pretty, them I'm in.

New member

Posts

Joined
Tue Dec 23, 2014 12:06 am
Location - Greater Manchester, UK

Post by mxmark » Wed Jan 20, 2021 5:28 am

JNeuhoff wrote:
Tue Jan 19, 2021 5:56 pm
With regards to web themes: Make sure to use a standard-compliant web theme, and stay clear of poorly written frameworks like Journal3. The latter is not supported by the OC community here for a good reason.
Hey JNeuhoff,

Thanks for your input.

Even though I'm not really seeing the answers I was hoping for from this thread, I'm finding it extremely educational.

Just curious, you mention a 'standard-compliant web theme' right? I know I'm probably going to come across a little stupid here, but are all the themes for sale in the OC marketplace 'standard-compliant web themes'?

Also, if I find a suitable alternative theme to my 'J' theme, does that mean it would be supported on this forum?

New member

Posts

Joined
Tue Dec 23, 2014 12:06 am
Location - Greater Manchester, UK

Post by by mona » Wed Jan 20, 2021 5:36 am

Your question is too subjective to receive the response you are hoping for. It is like asking which is better a classic lotus, a modern lotus, or a new lotus .. Classic cars are classics, they can be maintained, they require a little more effort, but their simplicity makes that easier. Modern versions have more security, features and easier to get parts .. If you want electric windows you might be better with a newer version, but you can if you really want get electric windows in a classic - the question for you is would you? Best you can hope for is an opinion. For a less subjective response you might be better asking which model within the range, that is a fairer question to evaluate.

It is also dependant on your requirements and that is true within the model not just the version.

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by mxmark » Thu Jan 21, 2021 6:34 am

by mona wrote:
Wed Jan 20, 2021 5:36 am
Your question is too subjective to receive the response you are hoping for. It is like asking which is better a classic lotus, a modern lotus, or a new lotus .. Classic cars are classics, they can be maintained, they require a little more effort, but their simplicity makes that easier. Modern versions have more security, features and easier to get parts .. If you want electric windows you might be better with a newer version, but you can if you really want get electric windows in a classic - the question for you is would you? Best you can hope for is an opinion. For a less subjective response you might be better asking which model within the range, that is a fairer question to evaluate.

It is also dependant on your requirements and that is true within the model not just the version.
Apologies if my post was too subjective, I just wanted to try and get some pro OC users to explain which is better and why. I completely understand your Lotus analogies though...I'm guessing you're a bit of a petrol head going off your explanation. Me too!

But back to the topic in question, here's what I currently have including extensions list:
  • A pretty looking responsive OC 1.5.6.4 site
  • Get Clear Thinking Johnathan's shipping extension
  • OCDevs smart checkout upsell
  • Dreamventions Cart Related Products (now not working on the admin side since the update)
  • MarketInSG's Quick Checkout
  • Bulk Product Update Pro
  • Qphorias options boost
  • And a review extension
I just want them all to work in harmony with each other like they did previously on php 5.6 without any errors and I don't really care which version of OC I'm using just so long as it works on php7.4. Obviously I'd like to stick with what I've got to avoid any of the update hassles, but if need must then I'll have to hire someone to do it for me.

New member

Posts

Joined
Tue Dec 23, 2014 12:06 am
Location - Greater Manchester, UK
Who is online

Users browsing this forum: No registered users and 7 guests